From: Roland McGrath <roland@redhat.com>
To: Oleg Nesterov <oleg@redhat.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: [FOR REVIEW, PATCH 2/2] introduce "struct wait_opts" to simplify do_wait() pathes
Date: Thu, 7 May 2009 00:20:03 -0700 (PDT) [thread overview]
Message-ID: <20090507072003.8E0ACFC39E@magilla.sf.frob.com> (raw)
In-Reply-To: Oleg Nesterov's message of Thursday, 7 May 2009 08:45:59 +0200 <20090507064559.GC15220@redhat.com>
> Yes, I considered this option too. But since (I hope) you do not have
> a strong opinion on this, I'd prefer to keep the code as is. This way
> do_wait() looks more symmetrical wrt to other helpers. And we don't
> copy args twice.
I don't feel strongly. But I do think that those two repeated assignment
blocks are more to read and harder to read, and more error-prone for drift
in future changes (vs prototype changes getting quick compilation errors).
do_wait() is not "another helper", it's the main function. On machines
with 6 argument registers (everything but x86-32?), the compiler probably
does fine making the callers' register shuffling be free. On x86-32, a few
cache-hot stack stores and loads are in the tiny noise vs the whole cost of
this hairy syscall, and IMHO don't compare to source maintainability issues.
Thanks,
Roland
next prev parent reply other threads:[~2009-05-07 7:20 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-05-06 5:33 Oleg Nesterov
2009-05-06 7:27 ` Ingo Molnar
2009-05-07 6:41 ` Oleg Nesterov
2009-05-07 7:54 ` Ingo Molnar
2009-05-09 16:15 ` Oleg Nesterov
2009-05-11 10:53 ` Andy Whitcroft
2009-05-11 12:43 ` Ingo Molnar
2009-05-06 20:09 ` Roland McGrath
2009-05-07 6:45 ` Oleg Nesterov
2009-05-07 7:20 ` Roland McGrath [this message]
2009-05-07 7:40 ` Oleg Nesterov
2009-05-07 7:49 ` Roland McGrath
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090507072003.8E0ACFC39E@magilla.sf.frob.com \
--to=roland@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=oleg@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®