mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Frederic Weisbecker <fweisbec@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	Oleg Nesterov <oleg@redhat.com>,
	Zhao Lei <zhaolei@cn.fujitsu.com>,
	Anton Blanchard <anton@samba.org>,
	Steven Rostedt <rostedt@goodmis.org>,
	Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH 0/5] tracing/workqueue updates
Date: Mon, 1 Jun 2009 23:42:32 +0200	[thread overview]
Message-ID: <20090601214232.GB5786@elte.hu> (raw)
In-Reply-To: <1243876637-6616-1-git-send-email-fweisbec@gmail.com>


* Frederic Weisbecker <fweisbec@gmail.com> wrote:

> Hi Ingo,
> 
> The following patches are fixes and cleanup for the workqueue tracer.
> 
> One of them makes the worklet search patch faster.
> Some of them fix and sanitize the histogram output and the others clean and
> standardize the code.
> 
> Thanks.
> 
> The following changes since commit c5f0530c4bb2ec77a805cfcf23db09b3e5ab09d4:
>   Ingo Molnar (1):
>         Merge branch 'tracing/core' into tracing/workqueues
> 
> are available in the git repository at:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/frederic/random-tracing.git tracing/workqueue
> 
> Anton Blanchard (2):
>       tracing/events: use %pf in workqueue trace events
>       tracing/events: rename worklet_execute to worklet_entry and worklet_complete to worklet_exit
> 
> Zhaolei (3):
>       tracing/workqueue: get rid of searching last executed worklet in probe_worklet_complete()
>       tracing/workqueue: fix list header and function name format
>       tracing/workqueue: cleanup for trace_workqueue.c
> 
>  Documentation/trace/workqueue.txt |   12 ++--
>  include/trace/events/workqueue.h  |    8 +-
>  kernel/trace/trace_workqueue.c    |  124 +++++++++++++++++-------------------
>  3 files changed, 69 insertions(+), 75 deletions(-)

Pulled, thanks Frederic!

	Ingo

      parent reply	other threads:[~2009-06-01 21:43 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-06-01 17:17 Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 1/5] tracing/workqueue: get rid of searching last executed worklet in probe_worklet_complete() Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 2/5] tracing/events: use %pf in workqueue trace events Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 3/5] tracing/events: rename worklet_execute to worklet_entry and worklet_complete to worklet_exit Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 4/5] tracing/workqueue: fix list header and function name format Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 5/5] tracing/workqueue: cleanup for trace_workqueue.c Frederic Weisbecker
2009-06-01 21:42 ` Ingo Molnar [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090601214232.GB5786@elte.hu \
    --to=mingo@elte.hu \
    --cc=akpm@linux-foundation.org \
    --cc=anton@samba.org \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oleg@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=zhaolei@cn.fujitsu.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®