mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Theodore Tso <tytso@mit.edu>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: "Frédéric Weisbecker" <fweisbec@gmail.com>,
	"Ingo Molnar" <mingo@elte.hu>,
	linux-kernel@vger.kernel.org,
	"Andrew Morton" <akpm@linux-foundation.org>,
	"Minchan Kim" <minchan.kim@gmail.com>,
	"Mel Gorman" <mel@csn.ul.ie>,
	"Christoph Hellwig" <hch@infradead.org>,
	"Rik van Riel" <riel@redhat.com>,
	"Pekka Enberg" <penberg@cs.helsinki.fi>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Mathieu Desnoyers" <compudj@krystal.dyndns.org>,
	"Lai Jiangshan" <laijs@cn.fujitsu.com>,
	Zhaolei <zhaolei@cn.fujitsu.com>,
	"KOSAKI Motohiro" <kosaki.motohiro@jp.fujitsu.com>,
	"Jason Baron" <jbaron@redhat.com>,
	"Jiaying Zhang" <jiayingz@google.com>,
	"Tom Zanussi" <tzanussi@gmail.com>,
	"Xiao Guangrong" <xiaoguangrong@cn.fujitsu.com>
Subject: Re: [PATCH 00/11] [GIT PULL] more updates for the tag format
Date: Wed, 10 Jun 2009 12:03:03 -0400	[thread overview]
Message-ID: <20090610160303.GA10240@mit.edu> (raw)
In-Reply-To: <alpine.DEB.2.00.0906100911190.30552@gandalf.stny.rr.com>

On Wed, Jun 10, 2009 at 09:49:29AM -0400, Steven Rostedt wrote:
> > 
> > Maybe I'm missing something, but looks like the this new format, while
> > simpler and easier to read, doesn't have support for using a more
> > complicated C expression as a printk argument.  For example:
> > 
> > 	TP_printk("dev %s ino %lu mode %d uid %u gid %u blocks %llu",
> > 		  jbd2_dev_to_name(__entry->dev), __entry->ino, __entry->mode,
> > 		  __entry->uid, __entry->gid, __entry->blocks)
> > 
> > How should I handle the "jbd2_dev_to_name(__entry->dev)" argument to
> > TP_printk?  The whole point of calling jbd2_dev_to_name() at TP_printk
> > time is to not bloat the ring buffer with a 32 byte devname.
> 
> Understood, and the example you just gave also has the flaw that a 
> userspace tool could not parse it, because it would not know what to do 
> with "jbd2_dev_to_name()".
> 
> This is why I suggested keeping the TP_printk, for cases like this. Since 
> it is also currently useless in userspace.
> 
> But we really should convert all cases, and I was toying with an idea to 
> dynamically make your own data type, and be able to make a way to print 
> it.

Yes, another approach for handling this case would be to take my
"jbd2_dev_to_name" function and support it as a first-class tagged
type; after all, I'm sure ext4 won't be the only place that would like
to take a dev_t and print the device name.  So this could certainly be
fixed by adding some kind of "<dev:xxx>" sort of tagged name.

But I think it would be good to keep TP_printk because otherwise I'll
have to scramble and change my marker->tracepoint patches during the
merge window, which would invalidate all of the testing to date.

I agree that the new tagged format is superior, but I'm wondering
whether it really makes sense to try to scramble and try to switch my
ext4/jbd2 users in the 36 hours or so before Linus opens the merge
window....

						- Ted

  parent reply	other threads:[~2009-06-10 16:03 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-06-10  5:42 Steven Rostedt
2009-06-10  5:42 ` [PATCH 01/11] tracing/events: convert block trace points to TRACE_EVENT(), fix Steven Rostedt
2009-06-10  5:42 ` [PATCH 02/11] tracing: add nsec2sec print formats Steven Rostedt
2009-06-10  5:42 ` [PATCH 03/11] tracing: convert lockdep lock_acquired trace point to use nsec2usec tag Steven Rostedt
2009-06-10  5:42 ` [PATCH 04/11] tracing: add major and minor tags for print format Steven Rostedt
2009-06-10  5:42 ` [PATCH 05/11] tracing: use << to print < instead of \< Steven Rostedt
2009-06-10  5:42 ` [PATCH 06/11] tracing: convert the block trace points to use the new tag format Steven Rostedt
2009-06-10  5:42 ` [PATCH 07/11] tracing: add test for strings in event " Steven Rostedt
2009-06-10  5:42 ` [PATCH 08/11] tracing: add func and symfunc to " Steven Rostedt
2009-06-10  7:48   ` Frederic Weisbecker
2009-06-10 12:55     ` Steven Rostedt
2009-06-10  5:42 ` [PATCH 09/11] tracing: check full name for field Steven Rostedt
2009-06-10  5:42 ` [PATCH 10/11] tracing: update sample code with new tag format Steven Rostedt
2009-06-10  5:42 ` [PATCH 11/11] tracing: move > to out of macros and into print statement Steven Rostedt
2009-06-10  9:26 ` [PATCH 00/11] [GIT PULL] more updates for the tag format Ingo Molnar
2009-06-10 11:11   ` Frédéric Weisbecker
2009-06-10 13:01     ` Theodore Tso
2009-06-10 13:49       ` Steven Rostedt
2009-06-10 14:39         ` Mathieu Desnoyers
2009-06-10 15:21           ` Steven Rostedt
2009-06-10 16:03         ` Theodore Tso [this message]
2009-06-10 16:17           ` Steven Rostedt
2009-06-11 13:03           ` Christoph Hellwig
2009-06-11 15:47             ` Theodore Tso
2009-06-11 17:14               ` Frederic Weisbecker
2009-06-11 19:20                 ` Theodore Tso
2009-06-19  8:14                   ` [BUG] bugs in jbd2_dev_to_name() (was Re: [PATCH 00/11] [GIT PULL] more updates for the tag format) Li Zefan
2009-06-19 12:32                     ` Theodore Tso
2009-06-22  1:36                       ` Li Zefan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090610160303.GA10240@mit.edu \
    --to=tytso@mit.edu \
    --cc=akpm@linux-foundation.org \
    --cc=compudj@krystal.dyndns.org \
    --cc=fweisbec@gmail.com \
    --cc=hch@infradead.org \
    --cc=jbaron@redhat.com \
    --cc=jiayingz@google.com \
    --cc=kosaki.motohiro@jp.fujitsu.com \
    --cc=laijs@cn.fujitsu.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mel@csn.ul.ie \
    --cc=minchan.kim@gmail.com \
    --cc=mingo@elte.hu \
    --cc=penberg@cs.helsinki.fi \
    --cc=peterz@infradead.org \
    --cc=riel@redhat.com \
    --cc=rostedt@goodmis.org \
    --cc=tzanussi@gmail.com \
    --cc=xiaoguangrong@cn.fujitsu.com \
    --cc=zhaolei@cn.fujitsu.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome