mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Len Brown <lenb@kernel.org>
Cc: x86@kernel.org, sfi-devel@simplefirmware.org,
	linux-kernel@vger.kernel.org, linux-acpi@vger.kernel.org
Subject: Re: [PATCH v2 for 2.6.32] SFI - Simple Firmware Interface support
Date: Sat, 11 Jul 2009 10:26:49 +0200	[thread overview]
Message-ID: <20090711082649.GB11522@elte.hu> (raw)
In-Reply-To: <alpine.LFD.2.00.0907102059320.4088@localhost.localdomain>


* Len Brown <lenb@kernel.org> wrote:

> 
> > 
> > > Feng Tang (10):
> > >       SFI, x86: add CONFIG_SFI
> > >       SFI: document boot param "sfi=off"
> > >       SFI: create include/linux/sfi.h
> > >       SFI: add core support
> > >       ACPI, x86: remove ACPI dependency on some IO-APIC routines
> > >       SFI: add x86 support
> > >       SFI, x86: hook e820() for memory map initialization
> > >       SFI: Enable SFI to parse ACPI tables
> > >       SFI, PCI: Hook MMCONFIG
> > >       SFI: add boot-time initialization hooks
> > 
> > Now that commit quality is all the rage, let me point out a 
> > (trivial) detail that could be improved: patch title capitalization. 
> > 
> > In particular for commits touching arch/x86/ we try to standardize 
> > on capitalizing the word after the 'x86: ' tag. But in the above 
> > titles the capitalization is mixed-case:
> > 
> >  [aligned vertically for easier readability ]
> > 
> > >       SFI, x86:  add CONFIG_SFI
> > >       SFI:       document boot param "sfi=off"
> > >       SFI:       create include/linux/sfi.h
> > >       SFI:       add core support
> > >       ACPI, x86: remove ACPI dependency on some IO-APIC routines
> > >       SFI:       add x86 support
> > >       SFI, x86:  hook e820() for memory map initialization
> > >       SFI:       Enable SFI to parse ACPI tables
> > >       SFI, PCI:  Hook MMCONFIG
> > >       SFI:       add boot-time initialization hooks
> > 
> > So it would be more consistent to have:
> > 
> > >       SFI, x86:  Add CONFIG_SFI
> > >       SFI:       Document boot param "sfi=off"
> > >       SFI:       Create include/linux/sfi.h
> > >       SFI:       Add core support
> > >       ACPI, x86: Remove ACPI dependency on some IO-APIC routines
> > >       SFI:       Add x86 support
> > >       SFI, x86:  Hook e820() for memory map initialization
> > >       SFI:       Enable SFI to parse ACPI tables
> > >       SFI, PCI:  Hook MMCONFIG
> > >       SFI:       Add boot-time initialization hooks
> > 
> > ( Capitalizing like that has the added (minor) benefit of making it 
> >   slightly easier to read these titles - the 'real' natural language 
> >   sentence portion of the title begins with a capital letter. )
> 
> Ingo,
> While I really do appreciate your attention to detail,
> a little time off might be good for you:-)

No objections on my part ;-)

	Ingo

      reply	other threads:[~2009-07-11  8:27 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-07-08  4:13 Len Brown
2009-07-08  4:13 ` [PATCH 01/12] SFI: Simple Firmware Interface - new MAINTAINERS entry Len Brown
2009-07-08  4:13   ` [PATCH 02/12] SFI, x86: add CONFIG_SFI Len Brown
2009-07-10  5:23     ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 03/12] SFI: document boot param "sfi=off" Len Brown
2009-07-28 19:24     ` Bjorn Helgaas
2009-07-28 19:52       ` Len Brown
2009-07-08  4:13   ` [PATCH 04/12] SFI: create include/linux/sfi.h Len Brown
2009-07-10  6:48     ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 05/12] SFI: add core support Len Brown
2009-07-10  7:40     ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 06/12] ACPI, x86: remove ACPI dependency on some IO-APIC routines Len Brown
2009-07-10  6:51     ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 07/12] SFI: add x86 support Len Brown
2009-07-10  6:37     ` Ingo Molnar
2009-07-10  6:48       ` Feng Tang
2009-07-08  4:13   ` [PATCH 08/12] SFI, x86: hook e820() for memory map initialization Len Brown
2009-07-08 21:37     ` H. Peter Anvin
2009-07-09  1:11       ` Feng Tang
2009-07-09  3:57         ` H. Peter Anvin
2009-07-08  4:13   ` [PATCH 09/12] SFI: Enable SFI to parse ACPI tables Len Brown
2009-07-10  6:10     ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 10/12] ACPI: check acpi_disabled in acpi_table_parse() Len Brown
2009-07-08  4:13   ` [PATCH 11/12] SFI, PCI: Hook MMCONFIG Len Brown
2009-07-10  5:52     ` Ingo Molnar
2009-07-10  7:17       ` Feng Tang
2009-07-10 11:14         ` Ingo Molnar
2009-07-08  4:13   ` [PATCH 12/12] SFI: add boot-time initialization hooks Len Brown
2009-07-10  5:18 ` [PATCH v2 for 2.6.32] SFI - Simple Firmware Interface support Ingo Molnar
2009-07-11  1:01   ` Len Brown
2009-07-11  8:26     ` Ingo Molnar [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090711082649.GB11522@elte.hu \
    --to=mingo@elte.hu \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sfi-devel@simplefirmware.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®