From: "Stephen M. Cameron" <scameron@beardog.cce.hp.com>
To: akpm@linux-foundation.org, axboe@kernel.dk
Cc: linux-kernel@vger.kernel.org, linux-scsi@vger.kernel.org,
andrew.patterson@hp.com, mikem@beardog.cce.hp.com,
scameron@beardog.cce.hp.com
Subject: [PATCH 03/20] cciss: Allow triggering of rescan of logical drive topology via sysfs entry
Date: Thu, 17 Sep 2009 13:47:03 -0500 [thread overview]
Message-ID: <20090917184703.15105.31661.stgit@beardog.cce.hp.com> (raw)
In-Reply-To: <20090917184310.15105.43508.stgit@beardog.cce.hp.com>
From: Andrew Patterson <andrew.patterson@hp.com>
Added /sys/bus/pci/devices/<dev>/ccissX/rescan sysfs entry used
to kick off a rescan that discovers logical drive topology changes.
Signed-off-by: Andrew Patterson <andrew.patterson@hp.com>
Signed-off-by: Stephen M. Cameron <scameron@beardog.cce.hp.com>
Acked-by: Mike Miller <mike.miller@hp.com>
---
.../ABI/testing/sysfs-bus-pci-devices-cciss | 7 ++++
drivers/block/cciss.c | 36 ++++++++++++++++++--
2 files changed, 40 insertions(+), 3 deletions(-)
diff --git a/Documentation/ABI/testing/sysfs-bus-pci-devices-cciss b/Documentation/ABI/testing/sysfs-bus-pci-devices-cciss
index 0a92a7c..ac3429d 100644
--- a/Documentation/ABI/testing/sysfs-bus-pci-devices-cciss
+++ b/Documentation/ABI/testing/sysfs-bus-pci-devices-cciss
@@ -31,3 +31,10 @@ Date: March 2009
Kernel Version: 2.6.30
Contact: iss_storagedev@hp.com
Description: A symbolic link to /sys/block/cciss!cXdY
+
+Where: /sys/bus/pci/devices/<dev>/ccissX/rescan
+Date: August 2009
+Kernel Version: 2.6.31
+Contact: iss_storagedev@hp.com
+Description: Kicks of a rescan of the controller to discover logical
+ drive topology changes.
diff --git a/drivers/block/cciss.c b/drivers/block/cciss.c
index e7273a4..763535e 100644
--- a/drivers/block/cciss.c
+++ b/drivers/block/cciss.c
@@ -194,6 +194,7 @@ static int sendcmd_withirq_core(ctlr_info_t *h, CommandList_struct *c,
static int process_sendcmd_error(ctlr_info_t *h, CommandList_struct *c);
static void fail_all_cmds(unsigned long ctlr);
+static int add_to_scan_list(struct ctlr_info *h);
static int scan_thread(void *data);
static int check_for_unit_attention(ctlr_info_t *h, CommandList_struct *c);
@@ -459,9 +460,19 @@ static void __devinit cciss_procinit(int i)
#define to_hba(n) container_of(n, struct ctlr_info, dev)
#define to_drv(n) container_of(n, drive_info_struct, dev)
-static struct device_type cciss_host_type = {
- .name = "cciss_host",
-};
+static ssize_t host_store_rescan(struct device *dev,
+ struct device_attribute *attr,
+ const char *buf, size_t count)
+{
+ struct ctlr_info *h = to_hba(dev);
+
+ add_to_scan_list(h);
+ wake_up_process(cciss_scan_thread);
+ wait_for_completion_interruptible(&h->scan_wait);
+
+ return count;
+}
+DEVICE_ATTR(rescan, S_IWUSR, NULL, host_store_rescan);
static ssize_t dev_show_unique_id(struct device *dev,
struct device_attribute *attr,
@@ -565,6 +576,25 @@ static ssize_t dev_show_rev(struct device *dev,
}
DEVICE_ATTR(rev, S_IRUGO, dev_show_rev, NULL);
+static struct attribute *cciss_host_attrs[] = {
+ &dev_attr_rescan.attr,
+ NULL
+};
+
+static struct attribute_group cciss_host_attr_group = {
+ .attrs = cciss_host_attrs,
+};
+
+static struct attribute_group *cciss_host_attr_groups[] = {
+ &cciss_host_attr_group,
+ NULL
+};
+
+static struct device_type cciss_host_type = {
+ .name = "cciss_host",
+ .groups = cciss_host_attr_groups,
+};
+
static struct attribute *cciss_dev_attrs[] = {
&dev_attr_unique_id.attr,
&dev_attr_model.attr,
next prev parent reply other threads:[~2009-09-17 18:46 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-09-17 18:46 [PATCH 00/20] cciss: fix scan_thread, sysfs stuff, dynamically allocate per drive structure Stephen M. Cameron
2009-09-17 18:46 ` [PATCH 01/20] cciss: Remove sysfs entries for logical drives on driver cleanup Stephen M. Cameron
2009-09-17 18:46 ` [PATCH 02/20] cciss: Use one scan thread per controller and fix hang during rmmod Stephen M. Cameron
2009-09-17 18:47 ` Stephen M. Cameron [this message]
2009-09-17 18:47 ` [PATCH 04/20] cciss: Remove some unused code in rebuild_lun_table() Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 05/20] cciss: Dynamically allocate struct device for each logical drive as needed Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 06/20] cciss: Rearrange logical drive sysfs code to make the "changing a disk" path work Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 07/20] cciss: Handle failure of blk_init_queue gracefully in cciss_add_disk Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 08/20] cciss: Handle cases when cciss_add_disk fails Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 09/20] cciss: Handle special case for sysfs attributes of the first logical drive Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 10/20] cciss: Clear all sysfs-exposed data for deleted logical drives Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 11/20] cciss: Fix usage_count check in rebuild_lun_table when triggered via sysfs Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 12/20] cciss: Fix excessive gendisk freeing bug on driver unload Stephen M. Cameron
2009-09-17 18:47 ` [PATCH 13/20] cciss: Silence noisy per-disk messages output by cciss_read_capacity Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 14/20] cciss: Preserve all 8 bytes of LUN ID for logical drives Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 15/20] cciss: Don't check h->busy_initializing in cciss_open() Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 16/20] cciss: Add lunid attribute to each logical drive in /sys Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 17/20] cciss: fix some magic numbers in the raid-level decoding Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 18/20] cciss: Add a "raid_level" attribute to each logical drive in /sys Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 19/20] cciss: Add usage_count " Stephen M. Cameron
2009-09-17 18:48 ` [PATCH 20/20] cciss: Dynamically allocate the drive_info_struct for each logical drive Stephen M. Cameron
2009-09-18 20:14 ` [PATCH 00/20] cciss: fix scan_thread, sysfs stuff, dynamically allocate per drive structure Jens Axboe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20090917184703.15105.31661.stgit@beardog.cce.hp.com \
--to=scameron@beardog.cce.hp.com \
--cc=akpm@linux-foundation.org \
--cc=andrew.patterson@hp.com \
--cc=axboe@kernel.dk \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=mikem@beardog.cce.hp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®