mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@elte.hu>
To: Trond Myklebust <trond.myklebust@fys.uio.no>
Cc: Yinghai Lu <yhlu.kernel@gmail.com>,
	Pekka Enberg <penberg@cs.helsinki.fi>,
	Arjan van de Ven <arjan@infradead.org>,
	David Miller <davem@davemloft.net>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: nfs mount fail
Date: Mon, 19 Oct 2009 10:04:03 +0200	[thread overview]
Message-ID: <20091019080403.GA24036@elte.hu> (raw)
In-Reply-To: <1255938774.11116.35.camel@heimdal.trondhjem.org>


* Trond Myklebust <trond.myklebust@fys.uio.no> wrote:

> > --- a/fs/nfs/super.c
> > +++ b/fs/nfs/super.c
> > @@ -1253,6 +1253,7 @@ static int nfs_parse_mount_options(char *raw,
> >  			default:
> >  				dfprintk(MOUNT, "NFS:   unrecognized "
> >  						"transport protocol\n");
> > +				kfree(string);
> >  				return 0;
> >  			}
> >  			break;
> 
> There is a possible clean up there too. We can move the other kfree() 
> calls out of the inner switch statement, and coalesce them all into a 
> single call.

Correct - separately from the leak fix. (which potentially wants to go 
to -stable as well)

Plus it's not just the kfree() calls that can be refactored but also the 
~25 match_strdup() call sites. Most of these repetitive sequences:

                case Opt_retrans:
                        string = match_strdup(args);
                        if (string == NULL)
                                goto out_nomem;
                        rc = strict_strtoul(string, 10, &option);
                        kfree(string);
                        if (rc != 0 || option == 0)
                                goto out_invalid_value;
                        mnt->retrans = option;
                        break;

could be pushed into a helper function, along the lines of:

                case Opt_retrans:
			if (parse_opt(args, &mnt->retrans) < 0 || mnt->retrans == 0)
                                goto out_invalid_value;
                        break;

where the non-repetitive value checks can be done after a generic 
parse_opt(). (or something like that)

That makes it more readable as well, as the switch statement will only 
list true per option properties, with minimal repetitive patterns.

	Ingo

  reply	other threads:[~2009-10-19  8:04 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-10-18  1:25 Yinghai Lu
2009-10-18  4:22 ` Yinghai Lu
2009-10-19  2:35 ` Pekka Enberg
2009-10-19  2:43   ` Arjan van de Ven
2009-10-19  2:58     ` Pekka Enberg
2009-10-19  5:52       ` Yinghai Lu
2009-10-19  6:30         ` Trond Myklebust
2009-10-19  6:54           ` Ingo Molnar
2009-10-19  6:58             ` Pekka Enberg
2009-10-19  7:08               ` Ingo Molnar
2009-10-19  7:31                 ` Yinghai Lu
2009-10-19  7:52                   ` Trond Myklebust
2009-10-19  8:04                     ` Ingo Molnar [this message]
2009-10-19  8:23                       ` Ingo Molnar
2009-10-19  8:29                         ` Trond Myklebust
2009-10-19  8:39                           ` [PATCH] nfs: Fix nfs_parse_mount_options() kfree() leak Ingo Molnar
2009-10-19  7:04             ` [re-send PATCH] nfs: Fix nfs_parse_mount_options() double kfree() Ingo Molnar
2009-10-19  7:10               ` Ingo Molnar
2009-10-19  7:04             ` nfs mount fail Trond Myklebust

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20091019080403.GA24036@elte.hu \
    --to=mingo@elte.hu \
    --cc=arjan@infradead.org \
    --cc=davem@davemloft.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=penberg@cs.helsinki.fi \
    --cc=trond.myklebust@fys.uio.no \
    --cc=yhlu.kernel@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®