From: Ingo Molnar <mingo@elte.hu>
To: Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
Cc: linux-kernel@vger.kernel.org,
"Rusty Russell" <rusty@rustcorp.com.au>,
"Thomas Gleixner" <tglx@linutronix.de>,
"Peter Zijlstra" <a.p.zijlstra@chello.nl>,
"Mike Galbraith" <efault@gmx.de>,
"Arnaldo Carvalho de Melo" <acme@redhat.com>,
Frédéric_Weisbecker <fweisbec@gmail.com>
Subject: Re: [RFC][PATCH 5/7] Adding general performance benchmarking subsystem to perf.
Date: Tue, 3 Nov 2009 08:40:55 +0100 [thread overview]
Message-ID: <20091103074055.GE19928@elte.hu> (raw)
In-Reply-To: <20091103.133824.590139143948085461.mitake@dcl.info.waseda.ac.jp>
* Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp> wrote:
>
> Adding general performance benchmarking subsystem to perf.
> This patch adds builtin-bench.c
>
> builtin-bench.c is general framework for benchmark suites.
>
> Signed-off-by: Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
> Cc: Rusty Russell <rusty@rustcorp.com.au>
> Cc: Thomas Gleixner <tglx@linutronix.de>
> Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
> Cc: Mike Galbraith <efault@gmx.de>
> ---
> tools/perf/builtin-bench.c | 87 ++++++++++++++++++++++++++++++++++++++++++++
> 1 files changed, 87 insertions(+), 0 deletions(-)
> create mode 100644 tools/perf/builtin-bench.c
>
> diff --git a/tools/perf/builtin-bench.c b/tools/perf/builtin-bench.c
> new file mode 100644
> index 0000000..85fa927
> --- /dev/null
> +++ b/tools/perf/builtin-bench.c
> @@ -0,0 +1,87 @@
> +/*
> + *
> + * builtin-bench.c
> + *
> + * General benchmarking subsystem provided by perf
> + *
> + * Copyright (C) 2009, Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
> + *
> + */
> +
> +/*
> + *
> + * Available subsystem list:
> + * sched ... scheduler and IPC mechanism
> + *
> + */
> +
> +#include "perf.h"
> +#include "util/util.h"
> +#include "util/parse-options.h"
> +#include "builtin.h"
> +#include "bench-suite.h"
> +
> +#include <stdio.h>
> +#include <stdlib.h>
> +#include <string.h>
> +
> +static const char * const bench_sched_usage[] = {
> + "perf bench sched <options>",
> + NULL
> +};
> +
> +struct bench_suite {
> + const char *name;
> + int (*fn)(int, const char **, const char *);
> +};
> +
> +static struct bench_suite sched_suite_array[] = {
> + { "messaging", bench_sched_messaging },
> + { "pipe", bench_sched_pipe },
> + { NULL, NULL }
> +};
ok, making it flexible on that level is a good thing - we'll likely want
to add more tests so having an array is useful.
a really small style nit, we tend to write tools/perf array initializers
like this:
static struct bench_suite sched_suite_array[] = {
{ "messaging", bench_sched_messaging },
{ "pipe", bench_sched_pipe },
{ NULL, NULL }
};
> + for (i = 0; subsys_array[i].name; i++) {
> + if (!strcmp(subsys_array[i].name, argv[1])) {
> + for (j = 0;
> + subsys_array[i].suite_array[j].name;
> + j++) {
> + s = subsys_array[i].suite_array[j].name;
> + if (!strcmp(s, argv[2])) {
> + fn = subsys_array[i].suite_array[j].fn;
> + status = fn(argc - 2,
> + argv + 2, prefix);
> + goto end;
> + }
> + }
> + }
> + }
The 80 cols line limit is hurting the nested code above. You can avoid
that problem and still have nice-looking code by doing something like:
for (i = 0; subsys_array[i].name; i++) {
if (strcmp(subsys_array[i].name, argv[1]))
continue;
for (j = 0; subsys_array[i].suite_array[j].name; j++) {
s = subsys_array[i].suite_array[j].name;
if (strcmp(s, argv[2]))
continue;
fn = subsys_array[i].suite_array[j].fn;
also, i'd suggest to shorten the subsys_array[i].suite_array[j] name.
One trick you use for that is by naming it subsystems[i].suites[j] -
it's very clear from that kind of plural usage that this is an array.
Ingo
prev parent reply other threads:[~2009-11-03 7:41 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-11-03 4:38 Hitoshi Mitake
2009-11-03 7:40 ` Ingo Molnar [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20091103074055.GE19928@elte.hu \
--to=mingo@elte.hu \
--cc=a.p.zijlstra@chello.nl \
--cc=acme@redhat.com \
--cc=efault@gmx.de \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mitake@dcl.info.waseda.ac.jp \
--cc=rusty@rustcorp.com.au \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®