mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RFC][PATCH 5/7] Adding general performance benchmarking subsystem to perf.
@ 2009-11-03  4:38 Hitoshi Mitake
  2009-11-03  7:40 ` Ingo Molnar
  0 siblings, 1 reply; 2+ messages in thread
From: Hitoshi Mitake @ 2009-11-03  4:38 UTC (permalink / raw)
  To: Ingo Molnar
  Cc: linux-kernel, Rusty Russell, Thomas Gleixner, Peter Zijlstra,
	Mike Galbraith, Arnaldo Carvalho de Melo,
	Frédéric_Weisbecker


Adding general performance benchmarking subsystem to perf.
This patch adds builtin-bench.c

builtin-bench.c is general framework for benchmark suites.

Signed-off-by: Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
Cc: Rusty Russell <rusty@rustcorp.com.au>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
Cc: Mike Galbraith <efault@gmx.de>
---
 tools/perf/builtin-bench.c |   87 ++++++++++++++++++++++++++++++++++++++++++++
 1 files changed, 87 insertions(+), 0 deletions(-)
 create mode 100644 tools/perf/builtin-bench.c

diff --git a/tools/perf/builtin-bench.c b/tools/perf/builtin-bench.c
new file mode 100644
index 0000000..85fa927
--- /dev/null
+++ b/tools/perf/builtin-bench.c
@@ -0,0 +1,87 @@
+/*
+ *
+ * builtin-bench.c
+ *
+ * General benchmarking subsystem provided by perf
+ *
+ * Copyright (C) 2009, Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
+ *
+ */
+
+/*
+ *
+ * Available subsystem list:
+ *  sched ... scheduler and IPC mechanism
+ *
+ */
+
+#include "perf.h"
+#include "util/util.h"
+#include "util/parse-options.h"
+#include "builtin.h"
+#include "bench-suite.h"
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+
+static const char * const bench_sched_usage[] = {
+	"perf bench sched <options>",
+	NULL
+};
+
+struct bench_suite {
+	const char *name;
+	int (*fn)(int, const char **, const char *);
+};
+
+static struct bench_suite sched_suite_array[] = {
+	{ "messaging", bench_sched_messaging },
+	{ "pipe", bench_sched_pipe },
+	{ NULL, NULL }
+};
+
+struct bench_subsys {
+	const char *name;
+	struct bench_suite *suite_array;
+};
+
+static struct bench_subsys subsys_array[] = {
+	{ "sched", sched_suite_array },
+	{ NULL, NULL }
+};
+
+int cmd_bench(int argc, const char **argv, const char *prefix __used)
+{
+	int i, j, status = 0;
+	const char *s;
+	int (*fn)(int, const char **, const char *);
+
+	if (argc < 3) {
+		printf("Usage: perf bench <subsystem> <suite> [<options>]\n");
+		goto end;
+	}
+
+	for (i = 0; subsys_array[i].name; i++) {
+		if (!strcmp(subsys_array[i].name, argv[1])) {
+			for (j = 0;
+			     subsys_array[i].suite_array[j].name;
+			     j++) {
+				s = subsys_array[i].suite_array[j].name;
+				if (!strcmp(s, argv[2])) {
+					fn = subsys_array[i].suite_array[j].fn;
+					status = fn(argc - 2,
+						    argv + 2, prefix);
+					goto end;
+				}
+			}
+		}
+	}
+
+	/* No subsystem matched. */
+	fprintf(stderr, "Unknown pair... subsystem:%s & suite:%s\n", argv[1], argv[2]);
+	status = 1;
+
+end:
+	return status;
+}
-- 
1.5.6.5


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [RFC][PATCH 5/7] Adding general performance benchmarking subsystem to perf.
  2009-11-03  4:38 [RFC][PATCH 5/7] Adding general performance benchmarking subsystem to perf Hitoshi Mitake
@ 2009-11-03  7:40 ` Ingo Molnar
  0 siblings, 0 replies; 2+ messages in thread
From: Ingo Molnar @ 2009-11-03  7:40 UTC (permalink / raw)
  To: Hitoshi Mitake
  Cc: linux-kernel, Rusty Russell, Thomas Gleixner, Peter Zijlstra,
	Mike Galbraith, Arnaldo Carvalho de Melo,
	Frédéric_Weisbecker


* Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp> wrote:

> 
> Adding general performance benchmarking subsystem to perf.
> This patch adds builtin-bench.c
> 
> builtin-bench.c is general framework for benchmark suites.
> 
> Signed-off-by: Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
> Cc: Rusty Russell <rusty@rustcorp.com.au>
> Cc: Thomas Gleixner <tglx@linutronix.de>
> Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
> Cc: Mike Galbraith <efault@gmx.de>
> ---
>  tools/perf/builtin-bench.c |   87 ++++++++++++++++++++++++++++++++++++++++++++
>  1 files changed, 87 insertions(+), 0 deletions(-)
>  create mode 100644 tools/perf/builtin-bench.c
> 
> diff --git a/tools/perf/builtin-bench.c b/tools/perf/builtin-bench.c
> new file mode 100644
> index 0000000..85fa927
> --- /dev/null
> +++ b/tools/perf/builtin-bench.c
> @@ -0,0 +1,87 @@
> +/*
> + *
> + * builtin-bench.c
> + *
> + * General benchmarking subsystem provided by perf
> + *
> + * Copyright (C) 2009, Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>
> + *
> + */
> +
> +/*
> + *
> + * Available subsystem list:
> + *  sched ... scheduler and IPC mechanism
> + *
> + */
> +
> +#include "perf.h"
> +#include "util/util.h"
> +#include "util/parse-options.h"
> +#include "builtin.h"
> +#include "bench-suite.h"
> +
> +#include <stdio.h>
> +#include <stdlib.h>
> +#include <string.h>
> +
> +static const char * const bench_sched_usage[] = {
> +	"perf bench sched <options>",
> +	NULL
> +};
> +
> +struct bench_suite {
> +	const char *name;
> +	int (*fn)(int, const char **, const char *);
> +};
> +
> +static struct bench_suite sched_suite_array[] = {
> +	{ "messaging", bench_sched_messaging },
> +	{ "pipe", bench_sched_pipe },
> +	{ NULL, NULL }
> +};


ok, making it flexible on that level is a good thing - we'll likely want 
to add more tests so having an array is useful.

a really small style nit, we tend to write tools/perf array initializers 
like this:

static struct bench_suite sched_suite_array[] = {
	{ "messaging",		bench_sched_messaging	},
	{ "pipe",		bench_sched_pipe	},
	{ NULL,			NULL			}
};


> +	for (i = 0; subsys_array[i].name; i++) {
> +		if (!strcmp(subsys_array[i].name, argv[1])) {
> +			for (j = 0;
> +			     subsys_array[i].suite_array[j].name;
> +			     j++) {
> +				s = subsys_array[i].suite_array[j].name;
> +				if (!strcmp(s, argv[2])) {
> +					fn = subsys_array[i].suite_array[j].fn;
> +					status = fn(argc - 2,
> +						    argv + 2, prefix);
> +					goto end;
> +				}
> +			}
> +		}
> +	}

The 80 cols line limit is hurting the nested code above. You can avoid 
that problem and still have nice-looking code by doing something like:

	for (i = 0; subsys_array[i].name; i++) {
		if (strcmp(subsys_array[i].name, argv[1]))
			continue;

		for (j = 0; subsys_array[i].suite_array[j].name; j++) {
			s = subsys_array[i].suite_array[j].name;
			if (strcmp(s, argv[2]))
				continue;

			fn = subsys_array[i].suite_array[j].fn;

also, i'd suggest to shorten the subsys_array[i].suite_array[j] name. 
One trick you use for that is by naming it subsystems[i].suites[j] - 
it's very clear from that kind of plural usage that this is an array.

	Ingo

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2009-11-03  7:41 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-11-03  4:38 [RFC][PATCH 5/7] Adding general performance benchmarking subsystem to perf Hitoshi Mitake
2009-11-03  7:40 ` Ingo Molnar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®