mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/11] Series short description
@ 2009-11-18 14:18 Alan Cox
  2009-11-18 14:19 ` [PATCH 01/11] tty_port: Move hupcl handling Alan Cox
                   ` (10 more replies)
  0 siblings, 11 replies; 15+ messages in thread
From: Alan Cox @ 2009-11-18 14:18 UTC (permalink / raw)
  To: greg, linux-kernel

Resend: This patch series reworks the sdio_uart driver into a modern format
and also replaces the circ buffer stuff it uses with a kfifo which makes the
code a good deal easier to follow.
---

Alan Cox (10):
      sdio_uart: add modem functionality
      sdio_uart: Fix the locking on "func" for new code
      sdio_uart: Style fixes
      sdio_uart: Use kfifo instead of the messy circ stuff
      sdio_uart: Fix termios handling
      sdio_uart: Switch to the open/close helpers
      sdio_uart: Move the open lock
      sdio_uart: refcount the tty objects
      sdio_uart: use tty_port
      tty_port: Move hupcl handling

Nicolas Pitre (1):
      sdio_uart: Fix oops caused by the previous changeset


 drivers/char/tty_port.c      |   13 +
 drivers/mmc/card/sdio_uart.c |  393 ++++++++++++++++++++++++------------------
 2 files changed, 235 insertions(+), 171 deletions(-)


^ permalink raw reply	[flat|nested] 15+ messages in thread
* [PATCH 00/11] Series short description
@ 2009-04-07 15:40 Alan Cox
  0 siblings, 0 replies; 15+ messages in thread
From: Alan Cox @ 2009-04-07 15:40 UTC (permalink / raw)
  To: torvalds, linux-kernel

More small updates and a driver for the MAX3100. The MAX3100 driver needs kref
bits eventually but its otherwise fine and good enough to merge
---

Adrian Bunk (1):
      tty: Correct inline types for tty_driver_kref_get()

Alan Cox (2):
      lanana: assign a device name and numbering for MAX3100
      serqt: initial clean up pass for tty side

Breno Leitao (1):
      Here are some cleanups, mainly removing unused variables and silly

Christian Pellegrin (1):
      Add support for the MAX3100 SPI UART.

Claudio Scordino (1):
      tty: Use the generic RS485 ioctl on CRIS

Mike Frysinger (3):
      Signed-off-by: Mike Frysinger <vapier.adi@gmail.com>
      Depend on KGDB_SERIAL_CONSOLE being set to N rather than !Y, since it can
      Signed-off-by: Mike Frysinger <vapier.adi@gmail.com>

Sonic Zhang (2):
      Both software emulated and hardware based CTS and RTS are enabled in
      Only CTS bit is affected.


 Documentation/devices.txt                          |    4 
 .../mach-bf518/include/mach/bfin_serial_5xx.h      |   10 
 .../mach-bf527/include/mach/bfin_serial_5xx.h      |   36 --
 .../mach-bf533/include/mach/bfin_serial_5xx.h      |   29 -
 .../mach-bf537/include/mach/bfin_serial_5xx.h      |   37 --
 .../mach-bf538/include/mach/bfin_serial_5xx.h      |   10 
 .../mach-bf548/include/mach/bfin_serial_5xx.h      |  117 +----
 .../mach-bf561/include/mach/bfin_serial_5xx.h      |   29 -
 arch/cris/include/asm/ioctls.h                     |    5 
 arch/cris/include/asm/rs485.h                      |    8 
 arch/cris/include/asm/termios.h                    |    1 
 drivers/serial/Kconfig                             |   47 ++
 drivers/serial/Makefile                            |    1 
 drivers/serial/bfin_5xx.c                          |  282 ++++++++-----
 drivers/serial/crisv10.c                           |   79 +++-
 drivers/serial/crisv10.h                           |    2 
 drivers/serial/jsm/jsm_neo.c                       |   14 -
 drivers/serial/jsm/jsm_tty.c                       |   19 -
 drivers/staging/serqt_usb/serqt_usb.c              |  449 +++++++-------------
 include/linux/serial_core.h                        |    3 
 include/linux/tty_driver.h                         |    3 
 21 files changed, 547 insertions(+), 638 deletions(-)

-- 

^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2009-11-20 19:21 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-11-18 14:18 [PATCH 00/11] Series short description Alan Cox
2009-11-18 14:19 ` [PATCH 01/11] tty_port: Move hupcl handling Alan Cox
2009-11-18 14:19 ` [PATCH 02/11] sdio_uart: use tty_port Alan Cox
2009-11-18 14:19 ` [PATCH 03/11] sdio_uart: Fix oops caused by the previous changeset Alan Cox
2009-11-18 14:19 ` [PATCH 04/11] sdio_uart: refcount the tty objects Alan Cox
2009-11-18 14:19 ` [PATCH 05/11] sdio_uart: Move the open lock Alan Cox
2009-11-18 14:19 ` [PATCH 06/11] sdio_uart: Switch to the open/close helpers Alan Cox
2009-11-20 17:35   ` Greg KH
2009-11-20 19:23     ` Alan Cox
2009-11-18 14:20 ` [PATCH 07/11] sdio_uart: Fix termios handling Alan Cox
2009-11-18 14:20 ` [PATCH 08/11] sdio_uart: Use kfifo instead of the messy circ stuff Alan Cox
2009-11-18 14:20 ` [PATCH 09/11] sdio_uart: Style fixes Alan Cox
2009-11-18 14:20 ` [PATCH 10/11] sdio_uart: Fix the locking on "func" for new code Alan Cox
2009-11-18 14:21 ` [PATCH 11/11] sdio_uart: add modem functionality Alan Cox
  -- strict thread matches above, loose matches on Subject: below --
2009-04-07 15:40 [PATCH 00/11] Series short description Alan Cox

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®