mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 18/25] input/gameport: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)
@ 2010-07-15 19:01 Peter Hüwe
  0 siblings, 0 replies; only message in thread
From: Peter Hüwe @ 2010-07-15 19:01 UTC (permalink / raw)
  To: Kernel Janitors
  Cc: Dmitry Torokhov,  Márton Németh, linux-input, linux-kernel

From: Peter Huewe <peterhuewe@gmx.de>

This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
.subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
PCI_VDEVICE macro, and thus improves readability.

Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
---
 drivers/input/gameport/fm801-gp.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/drivers/input/gameport/fm801-gp.c b/drivers/input/gameport/fm801-gp.c
index 14d3f3e..fa8446e 100644
--- a/drivers/input/gameport/fm801-gp.c
+++ b/drivers/input/gameport/fm801-gp.c
@@ -141,7 +141,7 @@ static void __devexit fm801_gp_remove(struct pci_dev *pci)
 }
 
 static const struct pci_device_id fm801_gp_id_table[] = {
-	{ PCI_VENDOR_ID_FORTEMEDIA, PCI_DEVICE_ID_FM801_GP, PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0  },
+	{ PCI_VDEVICE(FORTEMEDIA, PCI_DEVICE_ID_FM801_GP), 0 },
 	{ 0 }
 };
 
-- 
1.7.1


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2010-07-15 19:02 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-07-15 19:01 [PATCH 18/25] input/gameport: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used) Peter Hüwe

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®