mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Anton Vorontsov <cbouatmailru@gmail.com>
To: Ben Hutchings <ben@decadent.org.uk>
Cc: David Woodhouse <dwmw2@infradead.org>,
	Yulia Vilensky <vilensky@compulab.co.il>,
	Geert Stappers <stappers@stappers.nl>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ds2782_battery: Rename get_current and get_voltage operations
Date: Tue, 20 Jul 2010 11:46:59 +0400	[thread overview]
Message-ID: <20100720074659.GA32073@oksana.dev.rtsoft.ru> (raw)
In-Reply-To: <1279584175.4883.226.camel@localhost>

On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> support for ds2786 battery gas gauge" introduced an operation named
> get_current.  Since get_current() is defined as a macro on some
> architectures this driver no longer compiles on those architectures.
> 
> Rename get_current to get_current_now to avoid the macro.
> Rename get_voltage to get_voltage_now for consistency.
> 
> Reported-by: Geert Stappers <stappers@stappers.nl>
> Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
> ---

Thanks for the patch, but I have a similar fix in the
battery-2.6.git tree (for -next):

commit eb9650d6d989f24f21232a055d8fd45f1a9dcf99
Author: Peter Huewe <peterhuewe@gmx.de>
Date:   Thu May 13 01:54:57 2010 +0200

    ds2782_battery: Rename get_current to fix build failure / name conflict

    This patch changes the name of get_current function pointer to
    get_battery_current to resolve a name conflict with the get_current
    macro defined in current.h.

    This conflict resulted in a build-failure[1] for the sh4 arch
    allyesconfig:

      drivers/power/ds2782_battery.c:216:48: error: macro "get_current"
      passed 2 arguments, but takes just

    This patch fixes the issue. To be consistent the other function pointers
    (_voltage,_capacity) were renamed too.

    Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
    Acked-by: Ryan Mallon <ryan@bluewatersys.com>
    Acked-by: Mike Rapoport <mike@compulab.co.il>
    Signed-off-by: Anton Vorontsov <cbouatmailru@gmail.com>

I'm not pushing this into 2.6.35 as this is not a 2.6.35 regression,
it's there since 2.6.33, and nobody seemed to care for two releases.
So, I'm not considering this as urgent.

Thanks!

-- 
Anton Vorontsov
email: cbouatmailru@gmail.com
irc://irc.freenode.net/bd2

  reply	other threads:[~2010-07-20  7:47 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-07-20  0:02 Ben Hutchings
2010-07-20  7:46 ` Anton Vorontsov [this message]
2010-07-20  9:44   ` Ben Hutchings
2010-07-20 10:57     ` Anton Vorontsov
2010-07-20 11:50       ` Ben Hutchings
2010-07-20 12:32         ` Anton Vorontsov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100720074659.GA32073@oksana.dev.rtsoft.ru \
    --to=cbouatmailru@gmail.com \
    --cc=ben@decadent.org.uk \
    --cc=dwmw2@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=stappers@stappers.nl \
    --cc=vilensky@compulab.co.il \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome