mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Anton Vorontsov <cbouatmailru@gmail.com>
To: Ben Hutchings <ben@decadent.org.uk>
Cc: David Woodhouse <dwmw2@infradead.org>,
	Yulia Vilensky <vilensky@compulab.co.il>,
	Geert Stappers <stappers@stappers.nl>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ds2782_battery: Rename get_current and get_voltage operations
Date: Tue, 20 Jul 2010 16:32:22 +0400	[thread overview]
Message-ID: <20100720123222.GA403@oksana.dev.rtsoft.ru> (raw)
In-Reply-To: <20100720115019.GD3331@decadent.org.uk>

On Tue, Jul 20, 2010 at 12:50:19PM +0100, Ben Hutchings wrote:
> On Tue, Jul 20, 2010 at 02:57:12PM +0400, Anton Vorontsov wrote:
> > On Tue, Jul 20, 2010 at 10:44:26AM +0100, Ben Hutchings wrote:
> > > On Tue, 2010-07-20 at 11:46 +0400, Anton Vorontsov wrote:
> > > > On Tue, Jul 20, 2010 at 01:02:55AM +0100, Ben Hutchings wrote:
> > > > > commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
> > > > > support for ds2786 battery gas gauge" introduced an operation named
> > > > > get_current.  Since get_current() is defined as a macro on some
> > > > > architectures this driver no longer compiles on those architectures.
> > > > > 
> > > > > Rename get_current to get_current_now to avoid the macro.
> > > > > Rename get_voltage to get_voltage_now for consistency.
> > > > > 
> > > > > Reported-by: Geert Stappers <stappers@stappers.nl>
> > > > > Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
> > > > > ---
> > > > 
> > > > Thanks for the patch, but I have a similar fix in the
> > > > battery-2.6.git tree (for -next):
> > > [...]
> > > 
> > > This fix needs to go into 2.6.35.
> > 
> > Did you read why I don't push it into 2.6.35? Reread my email,
> > pay attention to the very bottom.
> 
> It is a 2.6.35 regression; these operations were introduced in 2.6.35-rc1.
> (Hint: use 'git describe --contains' not 'git describe'.  Or even
> 'git grep -w get_current v2.6.34:drivers/power/ds2782_battery.c'.)

Oh, I got it.

Will push, thanks!

-- 
Anton Vorontsov
email: cbouatmailru@gmail.com
irc://irc.freenode.net/bd2

      reply	other threads:[~2010-07-20 12:32 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-07-20  0:02 Ben Hutchings
2010-07-20  7:46 ` Anton Vorontsov
2010-07-20  9:44   ` Ben Hutchings
2010-07-20 10:57     ` Anton Vorontsov
2010-07-20 11:50       ` Ben Hutchings
2010-07-20 12:32         ` Anton Vorontsov [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100720123222.GA403@oksana.dev.rtsoft.ru \
    --to=cbouatmailru@gmail.com \
    --cc=ben@decadent.org.uk \
    --cc=dwmw2@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=stappers@stappers.nl \
    --cc=vilensky@compulab.co.il \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome