From: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
To: Peter Tyser <ptyser@xes-inc.com>
Cc: linux-kernel@vger.kernel.org, Alek Du <alek.du@intel.com>,
Samuel Ortiz <sameo@linux.intel.com>,
David Brownell <dbrownell@users.sourceforge.net>,
Eric Miao <eric.y.miao@gmail.com>,
Mark Brown <broonie@opensource.wolfsonmicro.com>,
Joe Perches <joe@perches.com>,
Alan Cox <alan@lxorguk.ukuu.org.uk>,
Grant Likely <grant.likely@secretlab.ca>
Subject: Re: [PATCH v3 1/4] gpiolib: Add "unknown" direction support
Date: Fri, 18 Feb 2011 09:51:23 +0100 [thread overview]
Message-ID: <20110218085123.GW22310@pengutronix.de> (raw)
In-Reply-To: <1297983799-4747-1-git-send-email-ptyser@xes-inc.com>
Hello,
On Thu, Feb 17, 2011 at 05:03:16PM -0600, Peter Tyser wrote:
> Previously, gpiolib would unconditionally flag all GPIO pins as inputs,
> regardless of their true state. This resulted in all GPIO output pins
> initially being incorrectly identified as "input" in the GPIO sysfs.
>
> Since the direction of GPIOs is not known prior to having their
> direction set, instead set the default direction to "unknown" to prevent
> user confusion. A pin with an "unknown" direction can not be written or
> read via sysfs; it must first be configured as an input or output before
> it can be used.
>
> While we're playing with the direction flag in/out defines, rename them to
> a more descriptive FLAG_DIR_* format.
Would it make sense to reset the state to unknown on gpio_free?
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |
prev parent reply other threads:[~2011-02-18 8:51 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-02-17 23:03 Peter Tyser
2011-02-17 23:03 ` [PATCH v3 2/4] gpiolib: Add ability to get GPIO pin direction Peter Tyser
2011-02-18 8:57 ` Uwe Kleine-König
2011-02-18 17:36 ` Peter Tyser
2011-02-18 18:49 ` Uwe Kleine-König
2011-02-18 20:27 ` Peter Tyser
2011-02-17 23:03 ` [PATCH v3 3/4] gpio: pca953x: Implement get_direction() hook Peter Tyser
2011-02-17 23:03 ` [PATCH v3 4/4] gpio: Add support for Intel ICHx/3100/Series[56] GPIO Peter Tyser
2011-02-18 17:58 ` Vincent Palatin
2011-02-18 20:28 ` Peter Tyser
2011-02-18 0:07 ` [PATCH v3 1/4] gpiolib: Add "unknown" direction support Ryan Mallon
2011-02-18 0:33 ` Peter Tyser
2011-02-18 8:51 ` Uwe Kleine-König [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110218085123.GW22310@pengutronix.de \
--to=u.kleine-koenig@pengutronix.de \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=alek.du@intel.com \
--cc=broonie@opensource.wolfsonmicro.com \
--cc=dbrownell@users.sourceforge.net \
--cc=eric.y.miao@gmail.com \
--cc=grant.likely@secretlab.ca \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=ptyser@xes-inc.com \
--cc=sameo@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®