From: Arnd Bergmann <arnd@arndb.de>
To: Shawn Guo <shawn.guo@freescale.com>
Cc: linux-arm-kernel@lists.infradead.org,
Shawn Guo <shawn.guo@linaro.org>,
linux-kernel@vger.kernel.org, patches@linaro.org,
linus.walleij@linaro.org, grant.likely@secretlab.ca,
kernel@pengutronix.de
Subject: Re: [PATCH 2/3] ARM: mxs: add gpio-mxs platform devices
Date: Fri, 20 May 2011 16:23:40 +0200 [thread overview]
Message-ID: <201105201623.40990.arnd@arndb.de> (raw)
In-Reply-To: <20110520140316.GA27551@S2100-06.ap.freescale.net>
On Friday 20 May 2011 16:03:17 Shawn Guo wrote:
> On Fri, May 20, 2011 at 12:23:00PM +0200, Arnd Bergmann wrote:
> >
> > I know it's tempting to use macros for these, but I think it obscures
> > the code a lot, especially when you use them to concatenate identifier
> > names. Why not just do:
> >
> The pattern is being widely used in mxc/mxs platform device codes.
> If you are not extremely unhappy about this, I would leave it as it
> is to keep consistency.
I think it's a real pain to do it like this, and we need to start
at some point cleaning up the mess. Why not start now?
> > > +
> > > + return mxs_add_platform_device("mxs-gpio", data->id,
> > > + res, ARRAY_SIZE(res), NULL, 0);
> > > +}
> >
> > mxs_add_platform_device doesn't set the parent pointer correctly, I think you
> > should either fix that or open-code the platform device creation to do it
> > right.
> >
> I see the following in drivers/base/platform.c, function
> platform_device_add():
>
> if (!pdev->dev.parent)
> pdev->dev.parent = &platform_bus;
>
> So we are fine?
No, this would put all gpio devices below the top-level /sys/devices/platform
directory, where they certainly don't belong. Please find a proper
place and put them there.
Arnd
next prev parent reply other threads:[~2011-05-20 14:23 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-05-20 9:57 [PATCH 0/3] remove mach-mxs gpio driver Shawn Guo
2011-05-20 9:57 ` [PATCH 1/3] ARM: mxs: remove gpio driver from mach-mxs Shawn Guo
2011-05-20 10:04 ` Arnd Bergmann
2011-05-20 10:27 ` Shawn Guo
2011-05-20 9:57 ` [PATCH 2/3] ARM: mxs: add gpio-mxs platform devices Shawn Guo
2011-05-20 10:23 ` Arnd Bergmann
2011-05-20 14:03 ` Shawn Guo
2011-05-20 14:23 ` Arnd Bergmann [this message]
2011-05-20 14:40 ` Shawn Guo
2011-05-27 9:11 ` Shawn Guo
2011-05-27 11:10 ` Arnd Bergmann
2011-05-27 8:29 ` Shawn Guo
2011-05-27 8:48 ` Arnd Bergmann
2011-05-20 9:57 ` [PATCH 3/3] ARM: mxs: select GPIO_MXS for i.MX23 and i.MX28 Shawn Guo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201105201623.40990.arnd@arndb.de \
--to=arnd@arndb.de \
--cc=grant.likely@secretlab.ca \
--cc=kernel@pengutronix.de \
--cc=linus.walleij@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=patches@linaro.org \
--cc=shawn.guo@freescale.com \
--cc=shawn.guo@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome