mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Felipe Balbi <balbi@ti.com>
To: Dave Young <hidave.darkstar@gmail.com>
Cc: Michal Nazarewicz <mnazarewicz@google.com>,
	Alan Stern <stern@rowland.harvard.edu>,
	Felipe Balbi <balbi@ti.com>,
	Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Yang Rui Rui <ruirui.r.yang@tieto.com>,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCHv4 3/4] usb: gadget: rename usb_gadget_driver::speed to max_speed
Date: Wed, 24 Aug 2011 11:58:29 +0300	[thread overview]
Message-ID: <20110824085828.GF12549@legolas.emea.dhcp.ti.com> (raw)
In-Reply-To: <CABqxG0c=y=hH83CqHewnvrx+OHTLssymzu0Hai+kJzN6LTvYHw@mail.gmail.com>

[-- Attachment #1: Type: text/plain, Size: 2205 bytes --]

Hi,

On Wed, Aug 24, 2011 at 10:26:53AM +0800, Dave Young wrote:
> On Tue, Aug 23, 2011 at 12:04 AM, Michal Nazarewicz
> <mnazarewicz@google.com> wrote:
> > From: Michal Nazarewicz <mina86@mina86.com>
> >
> > This commit renames the “speed” field of the usb_gadget_driver
> > structure to “max_speed”.  This is so that to make it more
> > apparent that the field represents the maximum speed gadget
> > driver can support.
> >
> > This also make the field look more like fields with the same
> > name in usb_gadget and usb_composite_driver structures.  All
> > of those represent the *maximal* speed given entity supports.
> >
> > After this commit, there are the following fields in various
> > structures:
> > * usb_gadget::speed - the current connection speed,
> > * usb_gadget::max_speed - maximal speed UDC supports,
> > * usb_gadget_driver::max_speed - maximal speed gadget driver
> >  supports, and
> > * usb_composite_driver::max_speed - maximal speed composite
> >  gadget supports.
> >
> > Signed-off-by: Michal Nazarewicz <mina86@mina86.com>
> > ---
> >  drivers/usb/gadget/amd5536udc.c   |    2 +-
> >  drivers/usb/gadget/ci13xxx_udc.c  |    2 +-
> >  drivers/usb/gadget/composite.c    |    8 ++++----
> >  drivers/usb/gadget/dbgp.c         |    2 +-
> >  drivers/usb/gadget/dummy_hcd.c    |   13 ++++++-------
> >  drivers/usb/gadget/file_storage.c |    4 ++--
> >  drivers/usb/gadget/gmidi.c        |    2 +-
> >  drivers/usb/gadget/goku_udc.c     |    2 +-
> >  drivers/usb/gadget/inode.c        |    6 +++---
> >  drivers/usb/gadget/m66592-udc.c   |    2 +-
> >  drivers/usb/gadget/net2272.c      |    2 +-
> >  drivers/usb/gadget/net2280.c      |    2 +-
> >  drivers/usb/gadget/pch_udc.c      |    2 +-
> >  drivers/usb/gadget/printer.c      |    2 +-
> >  drivers/usb/gadget/r8a66597-udc.c |    2 +-
> >  include/linux/usb/gadget.h        |    4 ++--
> >  16 files changed, 28 insertions(+), 29 deletions(-)
> >
> 
> Still missing drivers/usb/musb/musb_gadget for the speed check

and the new DWC3 on Greg's usb-next branch.

-- 
balbi

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 490 bytes --]

  reply	other threads:[~2011-08-24  8:58 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-08-22 16:04 [PATCHv4 0/4] Removing USB_GADGET_*SPEED macros Michal Nazarewicz
2011-08-22 16:04 ` [PATCHv4 1/4] usb: Provide usb_speed_string() function Michal Nazarewicz
2011-08-22 17:28   ` Alan Stern
2011-08-22 19:42     ` Michal Nazarewicz
2011-08-22 21:06       ` Alan Stern
2011-08-22 21:16         ` Michal Nazarewicz
2011-08-24  8:57           ` Felipe Balbi
2011-08-24 12:59             ` Michal Nazarewicz
2011-08-24  2:16     ` Dave Young
2011-08-22 16:04 ` [PATCHv4 2/4] usb: gadget: replace "is_dualspeed" with "max_speed" Michal Nazarewicz
2011-08-22 16:04 ` [PATCHv4 3/4] usb: gadget: rename usb_gadget_driver::speed to max_speed Michal Nazarewicz
2011-08-24  2:26   ` Dave Young
2011-08-24  8:58     ` Felipe Balbi [this message]
2011-08-24 13:26       ` Michal Nazarewicz
2011-08-22 16:04 ` [PATCHv4 4/4] usb: gadget: get rid of USB_GADGET_{DUAL,SUPER}SPEED Michal Nazarewicz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110824085828.GF12549@legolas.emea.dhcp.ti.com \
    --to=balbi@ti.com \
    --cc=bigeasy@linutronix.de \
    --cc=hidave.darkstar@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=mnazarewicz@google.com \
    --cc=ruirui.r.yang@tieto.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®