mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Felipe Balbi <balbi@ti.com>
To: Michal Nazarewicz <mnazarewicz@google.com>
Cc: Alan Stern <stern@rowland.harvard.edu>,
	Felipe Balbi <balbi@ti.com>,
	Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Yang Rui Rui <ruirui.r.yang@tieto.com>,
	Dave Young <hidave.darkstar@gmail.com>,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCHv5 2/4] usb: gadget: replace "is_dualspeed" with "max_speed"
Date: Thu, 6 Oct 2011 12:27:10 +0300	[thread overview]
Message-ID: <20111006092708.GC1714@legolas.emea.dhcp.ti.com> (raw)
In-Reply-To: <op.v1joh7yevgw7ix@mnazarewicz-glaptop>

[-- Attachment #1: Type: text/plain, Size: 1204 bytes --]

On Fri, Sep 09, 2011 at 04:14:21PM +0200, Michal Nazarewicz wrote:
> On Fri, 26 Aug 2011 15:18:35 +0200, Michal Nazarewicz
> <mnazarewicz@google.com> wrote:
> >This commit replaces usb_gadget's is_dualspeed field with
> >a max_speed field.
> >---
> >
> >I was unable to figure out how to create a symlink in
> >non-race-condition way so for now I've created both speed and
> >current_speed attributes.  This needs to get fixed before getting
> >merged.
> >
> >I would even consider just removing speed since udc-core got merged
> >only in 3.1, so maybe it won't be such a big issue?
> 
> I've dug a bit deeper and could not find *any* way of creating the
> speed -> current_speed symlink.  sysfs_create_link() requires target
> to be an kobject and as far as I can see attributes don't have one.
> 
> So I see the following possibilities:
> 
> 1. Leave speed only (as Felipe noticed, this may be confusing for
>    users since there will be "speed" and "maximum_speed").
> 2. Rename it to current_speed without transition period (udc-core is
>    young so maybe no one will notice, but that won't be very nice).

let's use current_speed without the grace period.

-- 
balbi

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 490 bytes --]

  reply	other threads:[~2011-10-06  9:27 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-08-26 13:18 [PATCHv5 0/4] Removing USB_GADGET_*SPEED macros Michal Nazarewicz
2011-08-26 13:18 ` [PATCHv5 1/4] usb: Provide usb_speed_string() function Michal Nazarewicz
2011-08-26 18:07   ` Greg KH
2011-08-26 18:26     ` Alan Stern
2011-08-26 18:34       ` Greg KH
2011-08-26 18:49         ` Alan Stern
2011-08-26 18:57           ` Michal Nazarewicz
2011-08-26 20:46             ` Alan Stern
2011-08-30 15:11         ` [PATCHv5.1 " Michal Nazarewicz
2011-08-26 13:18 ` [PATCHv5 2/4] usb: gadget: replace "is_dualspeed" with "max_speed" Michal Nazarewicz
2011-09-09 14:14   ` Michal Nazarewicz
2011-10-06  9:27     ` Felipe Balbi [this message]
2011-10-10  6:02   ` Felipe Balbi
2011-10-10  6:22     ` Dave Young
2011-10-10  7:40     ` Michal Nazarewicz
2011-10-10  7:42       ` Felipe Balbi
2011-08-26 13:18 ` [PATCHv5 3/4] usb: gadget: rename usb_gadget_driver::speed to max_speed Michal Nazarewicz
2011-10-10  6:02   ` Felipe Balbi
2011-08-26 13:18 ` [PATCHv5 4/4] usb: gadget: get rid of USB_GADGET_{DUAL,SUPER}SPEED Michal Nazarewicz
2011-10-10  6:02   ` Felipe Balbi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20111006092708.GC1714@legolas.emea.dhcp.ti.com \
    --to=balbi@ti.com \
    --cc=bigeasy@linutronix.de \
    --cc=hidave.darkstar@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=mnazarewicz@google.com \
    --cc=ruirui.r.yang@tieto.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®