From: Felipe Balbi <balbi@ti.com>
To: Michal Nazarewicz <mina86@mina86.com>
Cc: Felipe Balbi <balbi@ti.com>,
Alan Stern <stern@rowland.harvard.edu>,
Greg Kroah-Hartman <gregkh@suse.de>,
linux-kernel@vger.kernel.org, linux-usb@vger.kernel.org
Subject: Re: [PATCH 3/3] usb: gadget: rename usb_gadget_driver::speed to max_speed
Date: Thu, 24 Nov 2011 13:36:22 +0200 [thread overview]
Message-ID: <20111124113621.GH3352@legolas.emea.dhcp.ti.com> (raw)
In-Reply-To: <cc474a48df8db0ec55a1baecac9708de46b8c151.1321719300.git.mina86@mina86.com>
[-- Attachment #1: Type: text/plain, Size: 990 bytes --]
On Sat, Nov 19, 2011 at 06:27:38PM +0100, Michal Nazarewicz wrote:
> This commit renames the “speed” field of the usb_gadget_driver
> structure to “max_speed”. This is so that to make it more
> apparent that the field represents the maximum speed gadget
> driver can support.
>
> This also make the field look more like fields with the same
> name in usb_gadget and usb_composite_driver structures. All
> of those represent the *maximal* speed given entity supports.
>
> After this commit, there are the following fields in various
> structures:
> * usb_gadget::speed - the current connection speed,
> * usb_gadget::max_speed - maximal speed UDC supports,
> * usb_gadget_driver::max_speed - maximal speed gadget driver
> supports, and
> * usb_composite_driver::max_speed - maximal speed composite
> gadget supports.
>
> Signed-off-by: Michal Nazarewicz <mina86@mina86.com>
> Signed-off-by: Felipe Balbi <balbi@ti.com>
applied, thanks
--
balbi
[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2011-11-24 11:36 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <Pine.LNX.4.44L0.1111161624570.3443-100000@iolanthe.rowland.org>
2011-11-19 17:26 ` [PATCH 1/3] usb: udc: Fix gadget driver's speed check in various UDC drivers Michal Nazarewicz
2011-11-19 17:27 ` [PATCH 2/3] usb: gadget: replace usb_gadget::is_dualspeed with max_speed Michal Nazarewicz
2011-11-24 11:36 ` Felipe Balbi
2011-11-19 17:27 ` [PATCH 3/3] usb: gadget: rename usb_gadget_driver::speed to max_speed Michal Nazarewicz
2011-11-24 11:36 ` Felipe Balbi [this message]
2011-11-19 20:50 ` [PATCH 1/3] usb: udc: Fix gadget driver's speed check in various UDC drivers Heiko Stübner
2011-11-19 21:02 ` Alan Stern
2011-11-24 9:46 ` Felipe Balbi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20111124113621.GH3352@legolas.emea.dhcp.ti.com \
--to=balbi@ti.com \
--cc=gregkh@suse.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=mina86@mina86.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®