* [PATCH 81/90] staging: comedi: ke_counter: remove the cnt_board_nbr macro
@ 2012-07-19 2:03 H Hartley Sweeten
0 siblings, 0 replies; only message in thread
From: H Hartley Sweeten @ 2012-07-19 2:03 UTC (permalink / raw)
To: Linux Kernel; +Cc: devel, abbotti, gregkh
This macro is an open-coded version of ARRAY_SIZE(). Use that
instead.
Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com>
Cc: Ian Abbott <abbotti@mev.co.uk>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
drivers/staging/comedi/drivers/ke_counter.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ke_counter.c b/drivers/staging/comedi/drivers/ke_counter.c
index 4153977..d4e9292 100644
--- a/drivers/staging/comedi/drivers/ke_counter.c
+++ b/drivers/staging/comedi/drivers/ke_counter.c
@@ -62,8 +62,6 @@ static const struct cnt_board_struct cnt_boards[] = {
.cnt_bits = 24}
};
-#define cnt_board_nbr (sizeof(cnt_boards)/sizeof(struct cnt_board_struct))
-
/*-- counter write ----------------------------------------------------------*/
/* This should be used only for resetting the counters; maybe it is better
@@ -132,7 +130,7 @@ static struct pci_dev *cnt_find_pci_dev(struct comedi_device *dev,
if (pcidev->vendor != PCI_VENDOR_ID_KOLTER)
continue;
- for (i = 0; i < cnt_board_nbr; i++) {
+ for (i = 0; i < ARRAY_SIZE(cnt_boards); i++) {
board = &cnt_boards[i];
if (board->device_id != pcidev->device)
continue;
--
1.7.11
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2012-07-19 2:03 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-07-19 2:03 [PATCH 81/90] staging: comedi: ke_counter: remove the cnt_board_nbr macro H Hartley Sweeten
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome