mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Joe Perches <joe@perches.com>
Cc: Kay Sievers <kay@vrfy.org>, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 00/23] printk: refactoring
Date: Thu, 18 Oct 2012 16:16:01 -0700	[thread overview]
Message-ID: <20121018161601.c47c50c8.akpm@linux-foundation.org> (raw)
In-Reply-To: <cover.1350449851.git.joe@perches.com>

On Tue, 16 Oct 2012 23:06:04 -0700
Joe Perches <joe@perches.com> wrote:

> Make printk a bit more readable.
> 
> Joe Perches (23):
>   printk: Move to separate directory for easier modification
>   printk: Add console_cmdline.h
>   printk: Move braille console support into separate braille.[ch] files
>   printk: Use pointer for console_cmdline indexing
>   printk: rename struct log to struct printk_log
>   printk: Rename log_buf and __LOG_BUF_LEN
>   printk: Rename log_first and log_next variables
>   printk: Rename log_<foo> variables and functions
>   printk: Rename enum log_flags to printk_log_flags
>   printk: Rename log_wait to printk_log_wait
>   printk: Rename logbuf_lock to printk_logbuf_lock
>   printk: Rename clear_seq and clear_idx variables
>   printk: Remove static from printk_ variables
>   printk: Rename LOG_ALIGN to PRINTK_LOG_ALIGN
>   printk: Add and use printk_log.h
>   printk: Add printk_log.c
>   printk: Make wait_queue_head_t printk_log_wait extern
>   printk: Rename and move 2 #defines to printk_log.h
>   printk: Move devkmsg bits to separate file
>   printk: Prefix print_time and msg_print_text with printk_
>   printk: Move functions printk_print_time and printk_msg_print_text
>   printk: Add printk_syslog.c and .h
>   printk: Move kmsg_dump functions to separate file

OK, nobody's allowed to change the printk code for two months.

>  drivers/accessibility/braille/braille_console.c |    9 +-
>  fs/proc/kmsg.c                                  |    4 +-
>  kernel/Makefile                                 |    3 +-
>  kernel/printk.c                                 | 2820 -----------------------
>  kernel/printk/Makefile                          |    6 +
>  kernel/printk/braille.c                         |   48 +
>  kernel/printk/braille.h                         |   48 +
>  kernel/printk/console_cmdline.h                 |   14 +
>  kernel/printk/devkmsg.c                         |  309 +++
>  kernel/printk/kmsg_dump.c                       |  328 +++
>  kernel/printk/printk.c                          | 1515 ++++++++++++
>  kernel/printk/printk_log.c                      |  263 +++
>  kernel/printk/printk_log.h                      |  123 +
>  kernel/printk/printk_syslog.c                   |  354 +++
>  kernel/printk/printk_syslog.h                   |   12 +

It wouldn't hurt to describe the design here a bit.  How was the code
partitioned and what is the role of each file?

That's reasonably obvious from the names, but some might wonder about
the difference between printk_log and printk_syslog and how that
division was decided upon.



  parent reply	other threads:[~2012-10-18 23:16 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-10-17  6:06 Joe Perches
2012-10-17  6:06 ` [PATCH 01/23] printk: Move to separate directory for easier modification Joe Perches
2012-10-17  6:06 ` [PATCH 02/23] printk: Add console_cmdline.h Joe Perches
2012-10-17  6:06 ` [PATCH 03/23] printk: Move braille console support into separate braille.[ch] files Joe Perches
2012-10-17 23:47   ` Samuel Thibault
2012-10-25  0:12   ` Stephen Warren
2012-10-25  0:31     ` Joe Perches
2012-10-25 15:32       ` Stephen Warren
2012-10-17  6:06 ` [PATCH 04/23] printk: Use pointer for console_cmdline indexing Joe Perches
2012-10-17  6:06 ` [PATCH 05/23] printk: rename struct log to struct printk_log Joe Perches
2012-10-17  6:06 ` [PATCH 06/23] printk: Rename log_buf and __LOG_BUF_LEN Joe Perches
2012-10-17  6:06 ` [PATCH 07/23] printk: Rename log_first and log_next variables Joe Perches
2012-10-17  6:06 ` [PATCH 08/23] printk: Rename log_<foo> variables and functions Joe Perches
2012-10-17  6:06 ` [PATCH 09/23] printk: Rename enum log_flags to printk_log_flags Joe Perches
2012-10-17  6:06 ` [PATCH 10/23] printk: Rename log_wait to printk_log_wait Joe Perches
2012-10-17  6:06 ` [PATCH 11/23] printk: Rename logbuf_lock to printk_logbuf_lock Joe Perches
2012-10-17  6:06 ` [PATCH 12/23] printk: Rename clear_seq and clear_idx variables Joe Perches
2012-10-17  6:06 ` [PATCH 13/23] printk: Remove static from printk_ variables Joe Perches
2012-10-17  6:06 ` [PATCH 14/23] printk: Rename LOG_ALIGN to PRINTK_LOG_ALIGN Joe Perches
2012-10-17  6:06 ` [PATCH 15/23] printk: Add and use printk_log.h Joe Perches
2012-10-17  6:06 ` [PATCH 16/23] printk: Add printk_log.c Joe Perches
2012-10-17  6:06 ` [PATCH 17/23] printk: Make wait_queue_head_t printk_log_wait extern Joe Perches
2012-10-17  6:06 ` [PATCH 18/23] printk: Rename and move 2 #defines to printk_log.h Joe Perches
2012-10-17  6:06 ` [PATCH 19/23] printk: Move devkmsg bits to separate file Joe Perches
2012-10-17  6:06 ` [PATCH 20/23] printk: Prefix print_time and msg_print_text with printk_ Joe Perches
2012-10-17  6:06 ` [PATCH 21/23] printk: Move functions printk_print_time and printk_msg_print_text Joe Perches
2012-10-17  6:06 ` [PATCH 22/23] printk: Add printk_syslog.c and .h Joe Perches
2012-10-17  6:06 ` [PATCH 23/23] printk: Move kmsg_dump functions to separate file Joe Perches
2012-10-18 23:16 ` Andrew Morton [this message]
2012-10-19  0:43   ` [PATCH 00/23] printk: refactoring Joe Perches
2012-10-19  1:00   ` Joe Perches

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20121018161601.c47c50c8.akpm@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=joe@perches.com \
    --cc=kay@vrfy.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome