mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* Linux 3.7 does not boot on OMAP L137 with CONFIG_TI_EDMA=y
@ 2012-12-10 23:31 Krzysztof Mazur
  2012-12-10 23:43 ` Krzysztof Mazur
  0 siblings, 1 reply; 2+ messages in thread
From: Krzysztof Mazur @ 2012-12-10 23:31 UTC (permalink / raw)
  To: Matt Porter; +Cc: linux-kernel

Hi,

commit c2dde5f8f2095d7c623ff3565c1462e190272273
(dmaengine: add TI EDMA DMA engine driver)
with new option CONFIG_TI_EDMA=y causes system hang after
"Uncompressing Linux... done, booting the kernel."
on OMAP L137.

The same problem still exists in current v3.7-rc8-41-gcaf4919.

This causes some regressions, for instance the converted to new DMA engine
SPI driver does not work without CONFIG_TI_EDMA=y:

spi_davinci spi_davinci.0: Runtime PM disabled, clock forced on.
spi_davinci spi_davinci.0: request RX DMA channel failed
Trying to free nonexistent resource <0000000001c41000-0000000001c41000>

By the way:

1. It's possible to compile davinci SPI driver with
CONFIG_DMADEVICES=n (and CONFIG_TI_EMDA=n), but it does work
in that configuration (see error above).

2. The "Trying to free nonexistent resource" seems to indicate some
other error in SPI driver cleanup after error code.


Krzysiek

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Linux 3.7 does not boot on OMAP L137 with CONFIG_TI_EDMA=y
  2012-12-10 23:31 Linux 3.7 does not boot on OMAP L137 with CONFIG_TI_EDMA=y Krzysztof Mazur
@ 2012-12-10 23:43 ` Krzysztof Mazur
  0 siblings, 0 replies; 2+ messages in thread
From: Krzysztof Mazur @ 2012-12-10 23:43 UTC (permalink / raw)
  To: Matt Porter; +Cc: linux-kernel

On Tue, Dec 11, 2012 at 12:31:29AM +0100, Krzysztof Mazur wrote:
> Hi,
> 
> commit c2dde5f8f2095d7c623ff3565c1462e190272273
> (dmaengine: add TI EDMA DMA engine driver)
> with new option CONFIG_TI_EDMA=y causes system hang after
> "Uncompressing Linux... done, booting the kernel."
> on OMAP L137.

The system board is probably also important. The problem
occurs on Spectrum Digital OMAP-L137 EVM. I used following
board-specific options:

CONFIG_ARCH_DAVINCI=y
CONFIG_CP_INTC=y
CONFIG_ARCH_DAVINCI_DA830=y
CONFIG_ARCH_DAVINCI_DA8XX=y
CONFIG_MACH_DAVINCI_DA830_EVM=y
CONFIG_DA830_UI_LCD=y
CONFIG_GPIO_PCA953X=y
CONFIG_DAVINCI_MUX=y
CONFIG_DAVINCI_RESET_CLOCKS=y

> 
> The same problem still exists in current v3.7-rc8-41-gcaf4919.
> 
> This causes some regressions, for instance the converted to new DMA engine
> SPI driver does not work without CONFIG_TI_EDMA=y:
> 
> spi_davinci spi_davinci.0: Runtime PM disabled, clock forced on.
> spi_davinci spi_davinci.0: request RX DMA channel failed
> Trying to free nonexistent resource <0000000001c41000-0000000001c41000>
> 
> By the way:
> 
> 1. It's possible to compile davinci SPI driver with
> CONFIG_DMADEVICES=n (and CONFIG_TI_EMDA=n), but it does work
> in that configuration (see error above).
> 
> 2. The "Trying to free nonexistent resource" seems to indicate some
> other error in SPI driver cleanup after error code.
> 

Krzysiek

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2012-12-10 23:43 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-12-10 23:31 Linux 3.7 does not boot on OMAP L137 with CONFIG_TI_EDMA=y Krzysztof Mazur
2012-12-10 23:43 ` Krzysztof Mazur

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®