From: Arnd Bergmann <arnd@arndb.de>
To: "gregkh@linuxfoundation.org" <gregkh@linuxfoundation.org>
Cc: Samuel Ortiz <sameo@linux.intel.com>,
"Winkler, Tomas" <tomas.winkler@intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [char-misc-next 01/12 v3] mei: Rename mei_device to mei_host
Date: Tue, 12 Feb 2013 23:09:00 +0000 [thread overview]
Message-ID: <201302122309.01176.arnd@arndb.de> (raw)
In-Reply-To: <20130212213823.GA20745@kroah.com>
On Tuesday 12 February 2013, gregkh@linuxfoundation.org wrote:
> >
> > > Please let's find something that makes both hw and Linux happy
> > I still believe it makes sense to use mei_device for what we add to the MEI
> > bus. I'd be fine with mei_bus_device as well, but that would somehow look
> > a bit awkward. Greg, Arnd, any preference ?
>
> "mei_device" works the best for me. Tomas, what you think of as a "MEI
> Device" really is a "MEI Controller", it bridges the difference between
> the PCI bus and your new MEI bus, so you will need to start thinking of
> these things a bit differently now that you have created your own little
> virtual bus.
Yes, I agree. mei_bus_device would also work as the name for the controller,
but not for the devices attached to it IMO.
Arnd
next prev parent reply other threads:[~2013-02-12 23:09 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-02-12 18:36 [char-misc-next 00/12 v3] Add MEI bus and NFC device Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 01/12 v3] mei: Rename mei_device to mei_host Samuel Ortiz
2013-02-12 21:17 ` Winkler, Tomas
2013-02-12 21:29 ` Samuel Ortiz
2013-02-12 21:38 ` gregkh
2013-02-12 23:09 ` Arnd Bergmann [this message]
2013-02-13 9:39 ` Samuel Ortiz
2013-02-19 13:32 ` Tomas Winkler
2013-02-20 10:57 ` Samuel Ortiz
2013-03-11 10:44 ` Samuel Ortiz
2013-03-11 13:34 ` Arnd Bergmann
2013-02-12 18:36 ` [char-misc-next 02/12 v3] mei: bus: Initial MEI bus type implementation Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 03/12 v3] mei: bus: Implement driver registration Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 04/12 v3] mei: bus: Initial implementation for I/O routines Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 05/12 v3] mei: bus: Add bus related structures to mei_cl Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 06/12 v3] mei: bus: Call bus routines from the core code Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 07/12 v3] mei: bus: Synchronous API for the data transmission Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 08/12 v3] mei: bus: Implement bus driver data setter/getter Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 09/12 v3] mei: nfc: Initial nfc implementation Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 10/12 v3] mei: nfc: Connect also the regular ME client Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 11/12 v3] mei: nfc: Add NFC device to the MEI bus Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 12/12 v3] mei: nfc: Implement MEI bus IO ops Samuel Ortiz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=201302122309.01176.arnd@arndb.de \
--to=arnd@arndb.de \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sameo@linux.intel.com \
--cc=tomas.winkler@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome