mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Samuel Ortiz <sameo@linux.intel.com>
To: Tomas Winkler <tomas.winkler@intel.com>
Cc: Arnd Bergmann <arnd@arndb.de>,
	Greg KH <gregkh@linuxfoundation.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [char-misc-next 01/12 v3] mei: Rename mei_device to mei_host
Date: Wed, 20 Feb 2013 11:57:31 +0100	[thread overview]
Message-ID: <20130220105731.GT18295@sortiz-mobl> (raw)
In-Reply-To: <CA+i0qc6G83xsakt4FVzV1+=b6MVS9C73rE6+3Wmf1R8gs7rH1A@mail.gmail.com>

On Tue, Feb 19, 2013 at 03:32:44PM +0200, Tomas Winkler wrote:
> On Wed, Feb 13, 2013 at 11:39 AM, Samuel Ortiz <sameo@linux.intel.com> wrote:
> >
> > On Tue, Feb 12, 2013 at 11:09:00PM +0000, Arnd Bergmann wrote:
> > > On Tuesday 12 February 2013, gregkh@linuxfoundation.org wrote:
> > > > >
> > > > > > Please let's find something that makes both hw and Linux happy
> > > > > I still believe it makes sense to use mei_device for what we add to the MEI
> > > > > bus. I'd be fine with mei_bus_device as well, but that would somehow look
> > > > > a bit awkward. Greg, Arnd, any preference ?
> > > >
> > > > "mei_device" works the best for me.  Tomas, what you think of as a "MEI
> > > > Device" really is a "MEI Controller", it bridges the difference between
> > > > the PCI bus and your new MEI bus, so you will need to start thinking of
> > > > these things a bit differently now that you have created your own little
> > > > virtual bus.
> > >
> > > Yes, I agree. mei_bus_device would also work as the name for the controller,
> > > but not for the devices attached to it IMO.
> > Tomas, I propose to switch to mei_controller instead of mei_host and keep the
> > mei_device name for the devices we attach to the MEI bus.
> > Does that work for you ?
> >
> 
> The issue is that when we added our virtual bus we haven't gave up on
> /dev/mei backed by mei_device
> This is the interface, defined in linux/mei.h  which user space
> applications use to connect to ME Clients within ME device.
> Any ME client can be connected through this interface and we have few
> legacy applications running for few years that use this interface so
> we are not going to break them.
> 
> What we've done now is we added a virtual bus so also in-kernel
> applications/subsystems can more naturally connect to the ME Clients,
> this connection is client specific.  So the device that connect to the
> bus is not an mei device but mei client device hence the name I've
> proposed mei_cl_device.
I don't have a strong opinion here, so that would be fine with me.
Greg, Arnd, would mei_cl_device and mei_cl_driver be an acceptable compromise?

Cheers,
Samuel.

-- 
Intel Open Source Technology Centre
http://oss.intel.com/

  reply	other threads:[~2013-02-20 10:57 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-02-12 18:36 [char-misc-next 00/12 v3] Add MEI bus and NFC device Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 01/12 v3] mei: Rename mei_device to mei_host Samuel Ortiz
2013-02-12 21:17   ` Winkler, Tomas
2013-02-12 21:29     ` Samuel Ortiz
2013-02-12 21:38       ` gregkh
2013-02-12 23:09         ` Arnd Bergmann
2013-02-13  9:39           ` Samuel Ortiz
2013-02-19 13:32             ` Tomas Winkler
2013-02-20 10:57               ` Samuel Ortiz [this message]
2013-03-11 10:44                 ` Samuel Ortiz
2013-03-11 13:34                   ` Arnd Bergmann
2013-02-12 18:36 ` [char-misc-next 02/12 v3] mei: bus: Initial MEI bus type implementation Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 03/12 v3] mei: bus: Implement driver registration Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 04/12 v3] mei: bus: Initial implementation for I/O routines Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 05/12 v3] mei: bus: Add bus related structures to mei_cl Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 06/12 v3] mei: bus: Call bus routines from the core code Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 07/12 v3] mei: bus: Synchronous API for the data transmission Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 08/12 v3] mei: bus: Implement bus driver data setter/getter Samuel Ortiz
2013-02-12 18:36 ` [char-misc-next 09/12 v3] mei: nfc: Initial nfc implementation Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 10/12 v3] mei: nfc: Connect also the regular ME client Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 11/12 v3] mei: nfc: Add NFC device to the MEI bus Samuel Ortiz
2013-02-12 18:37 ` [char-misc-next 12/12 v3] mei: nfc: Implement MEI bus IO ops Samuel Ortiz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130220105731.GT18295@sortiz-mobl \
    --to=sameo@linux.intel.com \
    --cc=arnd@arndb.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tomas.winkler@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome