From: Joonsoo Kim <iamjoonsoo.kim@lge.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@redhat.com>,
Srivatsa Vaddagiri <vatsa@linux.vnet.ibm.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/8] sched: rename load_balance_tmpmask to load_balance_cpu_active
Date: Wed, 20 Mar 2013 16:35:00 +0900 [thread overview]
Message-ID: <20130320073500.GD11672@lge.com> (raw)
In-Reply-To: <1363705261.22553.57.camel@laptop>
On Tue, Mar 19, 2013 at 04:01:01PM +0100, Peter Zijlstra wrote:
> On Thu, 2013-02-14 at 14:48 +0900, Joonsoo Kim wrote:
> > This name doesn't represent specific meaning.
> > So rename it to imply it's purpose.
> >
> > Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@lge.com>
> >
> > diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> > index 26058d0..e6f8783 100644
> > --- a/kernel/sched/core.c
> > +++ b/kernel/sched/core.c
> > @@ -6814,7 +6814,7 @@ struct task_group root_task_group;
> > LIST_HEAD(task_groups);
> > #endif
> >
> > -DECLARE_PER_CPU(cpumask_var_t, load_balance_tmpmask);
> > +DECLARE_PER_CPU(cpumask_var_t, load_balance_cpu_active);
>
> That's not much better; how about we call it: load_balance_mask.
Okay, in next spin, I will call it as load_balance_mask.
Thanks.
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at http://www.tux.org/lkml/
next prev parent reply other threads:[~2013-03-20 7:34 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-02-14 5:48 [PATCH 0/8] correct load_balance() Joonsoo Kim
2013-02-14 5:48 ` [PATCH 1/8] sched: change position of resched_cpu() in load_balance() Joonsoo Kim
2013-03-19 12:59 ` Peter Zijlstra
2013-02-14 5:48 ` [PATCH 2/8] sched: explicitly cpu_idle_type checking in rebalance_domains() Joonsoo Kim
2013-03-19 14:02 ` Peter Zijlstra
2013-03-20 6:48 ` Joonsoo Kim
2013-02-14 5:48 ` [PATCH 3/8] sched: don't consider other cpus in our group in case of NEWLY_IDLE Joonsoo Kim
2013-03-19 14:20 ` Peter Zijlstra
2013-03-20 6:52 ` Joonsoo Kim
2013-02-14 5:48 ` [PATCH 4/8] sched: clean up move_task() and move_one_task() Joonsoo Kim
2013-03-19 14:30 ` Peter Zijlstra
2013-03-20 7:33 ` Joonsoo Kim
2013-03-20 11:11 ` Peter Zijlstra
2013-03-20 13:42 ` JoonSoo Kim
2013-03-20 11:16 ` Peter Zijlstra
2013-03-20 12:07 ` Peter Zijlstra
2013-02-14 5:48 ` [PATCH 5/8] sched: move up affinity check to mitigate useless redoing overhead Joonsoo Kim
2013-02-14 5:48 ` [PATCH 6/8] sched: rename load_balance_tmpmask to load_balance_cpu_active Joonsoo Kim
2013-03-19 15:01 ` Peter Zijlstra
2013-03-20 7:35 ` Joonsoo Kim [this message]
2013-02-14 5:48 ` [PATCH 7/8] sched: prevent to re-select dst-cpu in load_balance() Joonsoo Kim
2013-03-19 15:05 ` Peter Zijlstra
2013-03-20 7:43 ` Joonsoo Kim
2013-03-20 12:38 ` Peter Zijlstra
2013-03-20 13:48 ` JoonSoo Kim
2013-02-14 5:48 ` [PATCH 8/8] sched: reset lb_env when redo " Joonsoo Kim
2013-03-19 15:21 ` Peter Zijlstra
2013-03-20 8:13 ` Joonsoo Kim
2013-02-25 4:56 ` [PATCH 0/8] correct load_balance() Joonsoo Kim
2013-03-19 5:11 ` Joonsoo Kim
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130320073500.GD11672@lge.com \
--to=iamjoonsoo.kim@lge.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=vatsa@linux.vnet.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome