* [PATCH 00/10] autofs4 - rename autofs4 to autofs
@ 2013-08-31 11:41 Ian Kent
0 siblings, 0 replies; 4+ messages in thread
From: Ian Kent @ 2013-08-31 11:41 UTC (permalink / raw)
Cc: linux-fsdevel, autofs mailing list, Kernel Mailing List
The autofs4 kernel module provides function for autofs version 3, 4 and
5 and autofs module has long since been removed. Now we're left with a
misnamed module. Appart from the name another problem this presents is
that module autoload doesn't work because of the mismatch of the directory
name and the name of the file system provided by the module.
So autofs4 should be renamed to autofs but I've held back doing it because
of the potential disruption that could occur with a change like this.
The issues are somewhat reduced now because systemd needs the autofs
module at startup, and because of the autoload issue it's easier to just
compile the module into the kernel, which is what is often done.
Changes since the last posting of the series:
- removed the patches that updated the configs to use CONFIG_AUTOFS_FS
instead of CONFIG_AUTOFS4_FS, as recommended by Stephen Rothwell.
- Broke up large patches to meet list post size requirements.
By leaving a Kconfig and Makefile in fs/autofs4 (to build autofs4.ko)
with a deprication message sub-system maintainers and other users will
make any needed changes before these are removed after two kernel versions.
IMHO the presence of the warning is reason enough to leave a build stub
rather than do a straight out rename.
Any comments on the rename are welcome.
---
Ian Kent (10):
autofs4 - coding style fixes
autofs4 - fix string.h include in auto_dev-ioctl.h
autofs4 - move linux/auto_dev-ioctl.h to uapi/linux
autofs - merge auto_fs.h and auto_fs4.h
autofs - use autofs instead of autofs4 everywhere
autofs - copy autofs4 to autofs
autofs - create autofs Kconfig and Makefile
autofs - update fs/autofs4/Kconfig
autofs - update fs/autofs4/Makefile
autofs - delete fs/autofs4
fs/Kconfig | 1
fs/Makefile | 1
fs/autofs/Kconfig | 19 +
fs/autofs/Makefile | 7
fs/autofs/autofs_i.h | 341 +++++++++++++
fs/autofs/dev-ioctl.c | 759 ++++++++++++++++++++++++++++++
fs/autofs/expire.c | 561 ++++++++++++++++++++++
fs/autofs/init.c | 49 ++
fs/autofs/inode.c | 368 ++++++++++++++
fs/autofs/root.c | 898 +++++++++++++++++++++++++++++++++++
fs/autofs/symlink.c | 21 +
fs/autofs/waitq.c | 570 ++++++++++++++++++++++
fs/autofs4/Kconfig | 30 +
fs/autofs4/Makefile | 4
fs/autofs4/autofs_i.h | 341 -------------
fs/autofs4/dev-ioctl.c | 760 ------------------------------
fs/autofs4/expire.c | 562 ----------------------
fs/autofs4/init.c | 52 --
fs/autofs4/inode.c | 371 --------------
fs/autofs4/root.c | 898 -----------------------------------
fs/autofs4/symlink.c | 24 -
fs/autofs4/waitq.c | 572 ----------------------
fs/compat_ioctl.c | 1
include/linux/auto_dev-ioctl.h | 229 ---------
include/linux/auto_fs.h | 5
include/uapi/linux/auto_dev-ioctl.h | 224 +++++++++
include/uapi/linux/auto_fs.h | 156 ++++++
include/uapi/linux/auto_fs4.h | 158 ------
28 files changed, 3991 insertions(+), 3991 deletions(-)
create mode 100644 fs/autofs/Kconfig
create mode 100644 fs/autofs/Makefile
create mode 100644 fs/autofs/autofs_i.h
create mode 100644 fs/autofs/dev-ioctl.c
create mode 100644 fs/autofs/expire.c
create mode 100644 fs/autofs/init.c
create mode 100644 fs/autofs/inode.c
create mode 100644 fs/autofs/root.c
create mode 100644 fs/autofs/symlink.c
create mode 100644 fs/autofs/waitq.c
delete mode 100644 fs/autofs4/autofs_i.h
delete mode 100644 fs/autofs4/dev-ioctl.c
delete mode 100644 fs/autofs4/expire.c
delete mode 100644 fs/autofs4/init.c
delete mode 100644 fs/autofs4/inode.c
delete mode 100644 fs/autofs4/root.c
delete mode 100644 fs/autofs4/symlink.c
delete mode 100644 fs/autofs4/waitq.c
delete mode 100644 include/linux/auto_dev-ioctl.h
create mode 100644 include/uapi/linux/auto_dev-ioctl.h
--
Ian
^ permalink raw reply [flat|nested] 4+ messages in thread* [PATCH 00/10] autofs4 - rename autofs4 to autofs
@ 2013-08-31 11:42 Ian Kent
2013-09-03 11:28 ` Michael Tokarev
0 siblings, 1 reply; 4+ messages in thread
From: Ian Kent @ 2013-08-31 11:42 UTC (permalink / raw)
To: linux-next; +Cc: linux-fsdevel, autofs mailing list, Kernel Mailing List
The autofs4 kernel module provides function for autofs version 3, 4 and
5 and autofs module has long since been removed. Now we're left with a
misnamed module. Appart from the name another problem this presents is
that module autoload doesn't work because of the mismatch of the directory
name and the name of the file system provided by the module.
So autofs4 should be renamed to autofs but I've held back doing it because
of the potential disruption that could occur with a change like this.
The issues are somewhat reduced now because systemd needs the autofs
module at startup, and because of the autoload issue it's easier to just
compile the module into the kernel, which is what is often done.
Changes since the last posting of the series:
- removed the patches that updated the configs to use CONFIG_AUTOFS_FS
instead of CONFIG_AUTOFS4_FS, as recommended by Stephen Rothwell.
- Broke up large patches to meet list post size requirements.
By leaving a Kconfig and Makefile in fs/autofs4 (to build autofs4.ko)
with a deprication message sub-system maintainers and other users will
make any needed changes before these are removed after two kernel versions.
IMHO the presence of the warning is reason enough to leave a build stub
rather than do a straight out rename.
Any comments on the rename are welcome.
---
Ian Kent (10):
autofs4 - coding style fixes
autofs4 - fix string.h include in auto_dev-ioctl.h
autofs4 - move linux/auto_dev-ioctl.h to uapi/linux
autofs - merge auto_fs.h and auto_fs4.h
autofs - use autofs instead of autofs4 everywhere
autofs - copy autofs4 to autofs
autofs - create autofs Kconfig and Makefile
autofs - update fs/autofs4/Kconfig
autofs - update fs/autofs4/Makefile
autofs - delete fs/autofs4
fs/Kconfig | 1
fs/Makefile | 1
fs/autofs/Kconfig | 19 +
fs/autofs/Makefile | 7
fs/autofs/autofs_i.h | 341 +++++++++++++
fs/autofs/dev-ioctl.c | 759 ++++++++++++++++++++++++++++++
fs/autofs/expire.c | 561 ++++++++++++++++++++++
fs/autofs/init.c | 49 ++
fs/autofs/inode.c | 368 ++++++++++++++
fs/autofs/root.c | 898 +++++++++++++++++++++++++++++++++++
fs/autofs/symlink.c | 21 +
fs/autofs/waitq.c | 570 ++++++++++++++++++++++
fs/autofs4/Kconfig | 30 +
fs/autofs4/Makefile | 4
fs/autofs4/autofs_i.h | 341 -------------
fs/autofs4/dev-ioctl.c | 760 ------------------------------
fs/autofs4/expire.c | 562 ----------------------
fs/autofs4/init.c | 52 --
fs/autofs4/inode.c | 371 --------------
fs/autofs4/root.c | 898 -----------------------------------
fs/autofs4/symlink.c | 24 -
fs/autofs4/waitq.c | 572 ----------------------
fs/compat_ioctl.c | 1
include/linux/auto_dev-ioctl.h | 229 ---------
include/linux/auto_fs.h | 5
include/uapi/linux/auto_dev-ioctl.h | 224 +++++++++
include/uapi/linux/auto_fs.h | 156 ++++++
include/uapi/linux/auto_fs4.h | 158 ------
28 files changed, 3991 insertions(+), 3991 deletions(-)
create mode 100644 fs/autofs/Kconfig
create mode 100644 fs/autofs/Makefile
create mode 100644 fs/autofs/autofs_i.h
create mode 100644 fs/autofs/dev-ioctl.c
create mode 100644 fs/autofs/expire.c
create mode 100644 fs/autofs/init.c
create mode 100644 fs/autofs/inode.c
create mode 100644 fs/autofs/root.c
create mode 100644 fs/autofs/symlink.c
create mode 100644 fs/autofs/waitq.c
delete mode 100644 fs/autofs4/autofs_i.h
delete mode 100644 fs/autofs4/dev-ioctl.c
delete mode 100644 fs/autofs4/expire.c
delete mode 100644 fs/autofs4/init.c
delete mode 100644 fs/autofs4/inode.c
delete mode 100644 fs/autofs4/root.c
delete mode 100644 fs/autofs4/symlink.c
delete mode 100644 fs/autofs4/waitq.c
delete mode 100644 include/linux/auto_dev-ioctl.h
create mode 100644 include/uapi/linux/auto_dev-ioctl.h
--
Ian
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH 00/10] autofs4 - rename autofs4 to autofs
2013-08-31 11:42 Ian Kent
@ 2013-09-03 11:28 ` Michael Tokarev
2013-09-03 12:47 ` Ian Kent
0 siblings, 1 reply; 4+ messages in thread
From: Michael Tokarev @ 2013-09-03 11:28 UTC (permalink / raw)
To: Ian Kent
Cc: linux-next, linux-fsdevel, autofs mailing list, Kernel Mailing List
31.08.2013 15:42, Ian Kent wrote:
[...]
> By leaving a Kconfig and Makefile in fs/autofs4 (to build autofs4.ko)
> with a deprication message sub-system maintainers and other users will
> make any needed changes before these are removed after two kernel versions.
> IMHO the presence of the warning is reason enough to leave a build stub
> rather than do a straight out rename.
Why do you want to continue building autofs4.ko? (or allowing to)
What's actually wrong with a stright rename?
If the new module can be auto-loaded by both name (by providing an
alias), there's no need to keep ability to build autofs4.ko, I think.
Well, maybe except of the case when autofs is needed in initramfs (like
for systemd). For this, indeed, you can keep autofs4.ko which is a
dummy depending on autofs.ko...
> Ian Kent (10):
> autofs4 - coding style fixes
> autofs4 - fix string.h include in auto_dev-ioctl.h
> autofs4 - move linux/auto_dev-ioctl.h to uapi/linux
> autofs - merge auto_fs.h and auto_fs4.h
> autofs - use autofs instead of autofs4 everywhere
> autofs - copy autofs4 to autofs
> autofs - create autofs Kconfig and Makefile
> autofs - update fs/autofs4/Kconfig
> autofs - update fs/autofs4/Makefile
> autofs - delete fs/autofs4
By doing it this way, you're losing all git history.
If you perform stright rename and git detects it, you
can use, eg, git log --follow to see whole hostory
across rename. This way you create new files without
history.
So I strongly shuggest actually renaming the subdirectory
(together with appropriate kconfig/makefile changes so
things are bisectable), and creating the stubs after this.
Thanks,
/mjt
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 00/10] autofs4 - rename autofs4 to autofs
2013-09-03 11:28 ` Michael Tokarev
@ 2013-09-03 12:47 ` Ian Kent
0 siblings, 0 replies; 4+ messages in thread
From: Ian Kent @ 2013-09-03 12:47 UTC (permalink / raw)
To: Michael Tokarev
Cc: linux-next, linux-fsdevel, autofs mailing list, Kernel Mailing List
On Tue, 2013-09-03 at 15:28 +0400, Michael Tokarev wrote:
> 31.08.2013 15:42, Ian Kent wrote:
> [...]
> > By leaving a Kconfig and Makefile in fs/autofs4 (to build autofs4.ko)
> > with a deprication message sub-system maintainers and other users will
> > make any needed changes before these are removed after two kernel versions.
> > IMHO the presence of the warning is reason enough to leave a build stub
> > rather than do a straight out rename.
>
> Why do you want to continue building autofs4.ko? (or allowing to)
> What's actually wrong with a stright rename?
> If the new module can be auto-loaded by both name (by providing an
> alias), there's no need to keep ability to build autofs4.ko, I think.
The hope is that within two subsequent kernel versions, when it is
removed, people that need to change will have noticed this and made the
needed changes. That's scripts that may have looked for autofs4.ko to
work around the auto-load problem, aliases that won't work now, kernel
configurations, etc...
The configuration message for autofs4 now says these things and says the
module is going to be removed.
>
> Well, maybe except of the case when autofs is needed in initramfs (like
> for systemd). For this, indeed, you can keep autofs4.ko which is a
> dummy depending on autofs.ko...
>
> > Ian Kent (10):
> > autofs4 - coding style fixes
> > autofs4 - fix string.h include in auto_dev-ioctl.h
> > autofs4 - move linux/auto_dev-ioctl.h to uapi/linux
> > autofs - merge auto_fs.h and auto_fs4.h
> > autofs - use autofs instead of autofs4 everywhere
> > autofs - copy autofs4 to autofs
> > autofs - create autofs Kconfig and Makefile
> > autofs - update fs/autofs4/Kconfig
> > autofs - update fs/autofs4/Makefile
> > autofs - delete fs/autofs4
>
> By doing it this way, you're losing all git history.
> If you perform stright rename and git detects it, you
> can use, eg, git log --follow to see whole hostory
> across rename. This way you create new files without
> history.
>
> So I strongly shuggest actually renaming the subdirectory
> (together with appropriate kconfig/makefile changes so
> things are bisectable), and creating the stubs after this.
>
> Thanks,
>
> /mjt
> --
> To unsubscribe from this list: send the line "unsubscribe autofs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2013-09-03 12:47 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-08-31 11:41 [PATCH 00/10] autofs4 - rename autofs4 to autofs Ian Kent
2013-08-31 11:42 Ian Kent
2013-09-03 11:28 ` Michael Tokarev
2013-09-03 12:47 ` Ian Kent
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®