From: Peter Zijlstra <peterz@infradead.org>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Yuanhan Liu <yuanhan.liu@linux.intel.com>,
mingo@kernel.org, hpa@zytor.com, linux-kernel@vger.kernel.org,
tglx@linutronix.de, linux-tip-commits@vger.kernel.org,
Fengguang Wu <fengguang.wu@intel.com>,
Huang Ying <ying.huang@intel.com>,
lkp@linux.intel.com
Subject: Re: [PATCH] ftrace, sched: Add TRACE_FLAG_PREEMPT_RESCHED
Date: Wed, 6 Nov 2013 17:45:25 +0100 [thread overview]
Message-ID: <20131106164525.GF16117@laptop.programming.kicks-ass.net> (raw)
In-Reply-To: <20131106113704.41b6ed5c@gandalf.local.home>
On Wed, Nov 06, 2013 at 11:37:04AM -0500, Steven Rostedt wrote:
> On Fri, 27 Sep 2013 17:29:08 +0200
> Peter Zijlstra <peterz@infradead.org> wrote:
>
> > Subject: ftrace, sched: Add TRACE_FLAG_PREEMPT_RESCHED
> > From: Peter Zijlstra <peterz@infradead.org>
> > Date: Fri Sep 27 17:11:00 CEST 2013
> >
> > Since we now have two need_resched states; trace the two so we can
> > observe discrepancies.
>
> I see this is dependent on the addition of tif_need_resched() and
> friends.
This also wasn't the last version of the patch, I distinctly remember
you making me update some documentation crap.
> > +
> > + if ((entry->flags & TRACE_FLAG_NEED_RESCHED) &&
> > + (entry->flags & TRACE_FLAG_PREEMPT_RESCHED))
> > + need_resched = 'N';
> > + else if (entry->flags & TRACE_FLAG_NEED_RESCHED)
> > + need_resched = 'n';
> > + else if (entry->flags & TRACE_FLAG_PREEMPT_RESCHED)
> > + need_resched = 'p';
> > + else
> > + need_resched = '.';
>
> Perhaps we should make this a switch statement?
>
> switch (entry->flags & (TRACE_FLAG_NEED_RESCHED |
> TRACE_FLAG_PREEMPT_RESCHED)) {
> case TRACE_FLAG_NEED_RESCHED | TRACE_FLAG_PREEMPT_RESCHED:
> need_resched = 'N';
> break;
> case TRACE_FLAG_NEED_RESCHED:
> need_resched = 'n';
> break;
> case TRACE_FLAG_PREEMPT_RESCHED:
> need_resched = 'p';
> break;
> default:
> need_resched = '.';
> break;
> }
>
> Simply because I find switch statements easier to read than else if
> statements.
Sure whatever your code ;-), but says he who wrote:
hardsoft_irq =
(hardirq && softirq) ? 'H' :
hardirq ? 'h' :
softirq ? 's' :
'.';
Just apply the later patch and change it however you like.
next prev parent reply other threads:[~2013-11-06 16:45 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-09-25 16:38 [tip:sched/core] sched: Add NEED_RESCHED to the preempt_count tip-bot for Peter Zijlstra
2013-09-27 9:14 ` Yuanhan Liu
2013-09-27 11:57 ` Peter Zijlstra
2013-09-27 12:13 ` Fengguang Wu
2013-09-27 12:20 ` Fengguang Wu
2013-09-27 15:29 ` [PATCH] ftrace, sched: Add TRACE_FLAG_PREEMPT_RESCHED Peter Zijlstra
2013-10-04 8:09 ` Peter Zijlstra
2013-10-04 14:53 ` Steven Rostedt
2013-10-04 15:16 ` Peter Zijlstra
2013-10-04 15:25 ` Steven Rostedt
2013-10-04 15:28 ` Peter Zijlstra
2013-10-04 15:57 ` Steven Rostedt
2013-10-04 16:28 ` Peter Zijlstra
2013-11-11 17:52 ` [tip:sched/core] " tip-bot for Peter Zijlstra
2013-11-06 16:37 ` [PATCH] " Steven Rostedt
2013-11-06 16:45 ` Peter Zijlstra [this message]
2013-11-06 16:58 ` Steven Rostedt
2013-11-06 17:23 ` Peter Zijlstra
2013-09-27 15:30 ` [PATCH] sched: Revert need_resched() to look at TIF_NEED_RESCHED Peter Zijlstra
2013-09-28 8:28 ` [tip:sched/core] " tip-bot for Peter Zijlstra
2013-12-09 6:41 ` [PATCH] " Aneesh Kumar K.V
2013-12-10 15:52 ` Peter Zijlstra
2013-11-28 13:26 ` [PATCH] sched: Remove PREEMPT_NEED_RESCHED from generic code Peter Zijlstra
2013-11-28 15:24 ` Alexander Graf
2013-12-09 6:29 ` Benjamin Herrenschmidt
2013-12-12 9:51 ` [tip:sched/urgent] " tip-bot for Peter Zijlstra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20131106164525.GF16117@laptop.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=fengguang.wu@intel.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=lkp@linux.intel.com \
--cc=mingo@kernel.org \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
--cc=ying.huang@intel.com \
--cc=yuanhan.liu@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome