mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] libahci: correct a misleading comment
@ 2014-01-17 11:43 Lukasz Dorau
  2014-01-17 12:00 ` Tejun Heo
  0 siblings, 1 reply; 3+ messages in thread
From: Lukasz Dorau @ 2014-01-17 11:43 UTC (permalink / raw)
  To: tj; +Cc: linux-ide, linux-kernel

There is an error in a comment introduced by:
	commit fa070ee6dc70bcc19737a2406d741b089b3149d5
	libahci: fix turning on LEDs in ahci_start_port()

Correct it.

Signed-off-by: Lukasz Dorau <lukasz.dorau@intel.com>
---
 drivers/ata/libahci.c |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
index c482f8c..1f526e6 100644
--- a/drivers/ata/libahci.c
+++ b/drivers/ata/libahci.c
@@ -780,8 +780,8 @@ static void ahci_start_port(struct ata_port *ap)
 							       4);
 				/*
 				 * If busy, give a breather but do not
-				 * release EH ownership by using msleep()
-				 * instead of ata_msleep().  EM Transmit
+				 * release EH ownership by using ata_msleep()
+				 * instead of msleep().  EM Transmit
 				 * bit is busy for the whole host and
 				 * releasing ownership will cause other
 				 * ports to fail the same way.


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] libahci: correct a misleading comment
  2014-01-17 11:43 [PATCH] libahci: correct a misleading comment Lukasz Dorau
@ 2014-01-17 12:00 ` Tejun Heo
  2014-01-17 12:10   ` Dorau, Lukasz
  0 siblings, 1 reply; 3+ messages in thread
From: Tejun Heo @ 2014-01-17 12:00 UTC (permalink / raw)
  To: Lukasz Dorau; +Cc: linux-ide, linux-kernel

On Fri, Jan 17, 2014 at 12:43:20PM +0100, Lukasz Dorau wrote:
> There is an error in a comment introduced by:
> 	commit fa070ee6dc70bcc19737a2406d741b089b3149d5
> 	libahci: fix turning on LEDs in ahci_start_port()
> 
> Correct it.
> 
> Signed-off-by: Lukasz Dorau <lukasz.dorau@intel.com>
> ---
>  drivers/ata/libahci.c |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
> index c482f8c..1f526e6 100644
> --- a/drivers/ata/libahci.c
> +++ b/drivers/ata/libahci.c
> @@ -780,8 +780,8 @@ static void ahci_start_port(struct ata_port *ap)
>  							       4);
>  				/*
>  				 * If busy, give a breather but do not
> -				 * release EH ownership by using msleep()
> -				 * instead of ata_msleep().  EM Transmit
> +				 * release EH ownership by using ata_msleep()
> +				 * instead of msleep().  EM Transmit

Can't the sentence be parsed to mean the same thing either way?  "(do
not release EH ownership) by using msleep..." or "do not (release EH
ownership by using ata_msleep)..."

With the context, I don't think which way to group things is
ambiguous.  In fact, saying "instead of msleep()" is kinda confusing
because using ata_msleep() should be the default.

Thanks.

-- 
tejun

^ permalink raw reply	[flat|nested] 3+ messages in thread

* RE: [PATCH] libahci: correct a misleading comment
  2014-01-17 12:00 ` Tejun Heo
@ 2014-01-17 12:10   ` Dorau, Lukasz
  0 siblings, 0 replies; 3+ messages in thread
From: Dorau, Lukasz @ 2014-01-17 12:10 UTC (permalink / raw)
  To: Tejun Heo; +Cc: linux-ide, linux-kernel

On Friday, January 17, 2014 1:00 PM Tejun Heo <tj@kernel.org> wrote:
> On Fri, Jan 17, 2014 at 12:43:20PM +0100, Lukasz Dorau wrote:
> > There is an error in a comment introduced by:
> > 	commit fa070ee6dc70bcc19737a2406d741b089b3149d5
> > 	libahci: fix turning on LEDs in ahci_start_port()
> >
> > Correct it.
> >
> > Signed-off-by: Lukasz Dorau <lukasz.dorau@intel.com>
> > ---
> >  drivers/ata/libahci.c |    4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/ata/libahci.c b/drivers/ata/libahci.c
> > index c482f8c..1f526e6 100644
> > --- a/drivers/ata/libahci.c
> > +++ b/drivers/ata/libahci.c
> > @@ -780,8 +780,8 @@ static void ahci_start_port(struct ata_port *ap)
> >  							       4);
> >  				/*
> >  				 * If busy, give a breather but do not
> > -				 * release EH ownership by using msleep()
> > -				 * instead of ata_msleep().  EM Transmit
> > +				 * release EH ownership by using ata_msleep()
> > +				 * instead of msleep().  EM Transmit
> 
> Can't the sentence be parsed to mean the same thing either way?  "(do
> not release EH ownership) by using msleep..." or "do not (release EH
> ownership by using ata_msleep)..."
> 
> With the context, I don't think which way to group things is
> ambiguous.  In fact, saying "instead of msleep()" is kinda confusing
> because using ata_msleep() should be the default.
> 

You are right. I give up ;-)

Thanks,
Lukasz


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2014-01-17 12:10 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-01-17 11:43 [PATCH] libahci: correct a misleading comment Lukasz Dorau
2014-01-17 12:00 ` Tejun Heo
2014-01-17 12:10   ` Dorau, Lukasz

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®