From: Peter Zijlstra <peterz@infradead.org>
To: Trond Myklebust <trond.myklebust@primarydata.com>
Cc: linux-kernel@vger.kernel.org,
John Stultz <john.stultz@linaro.org>,
Ingo Molnar <mingo@kernel.org>,
"David S. Miller" <davem@davemloft.net>,
Al Viro <viro@zeniv.linux.org.uk>
Subject: Re: [PATCH] Revert lockdep check in raw_seqcount_begin
Date: Fri, 6 Jun 2014 16:07:32 +0200 [thread overview]
Message-ID: <20140606140732.GA11371@laptop.programming.kicks-ass.net> (raw)
In-Reply-To: <1401982261-11246-1-git-send-email-trond.myklebust@primarydata.com>
On Thu, Jun 05, 2014 at 11:31:01AM -0400, Trond Myklebust wrote:
> This commit reverts the addition of lockdep checking to raw_seqcount_begin
> for the following reasons:
>
> 1) It violates the naming convention that raw_* functions should not
> do lockdep checks (a convention that is also followed by the other
> raw_*_seqcount_begin functions).
> 2) raw_seqcount_begin does not spin, so it can only be part of an ABBA
> deadlock in very special circumstances (for instance if a lock
> is held across the entire raw_seqcount_begin()+read_seqcount_retry()
> loop while also being taken inside the write_seqcount protected area).
> 3) It is causing false positives with some existing callers, and there
> is no non-lockdep alternative for those callers to use.
>
> None of the three existing callers (__d_lookup_rcu, netdev_get_name, and
> the NFS state code) appear to use the function in a manner that is ABBA
> deadlock prone.
>
> Fixes: 1ca7d67cf5d5: seqcount: Add lockdep functionality to seqcount/seqlock
> Cc: John Stultz <john.stultz@linaro.org>
> Cc: Peter Zijlstra <peterz@infradead.org>
> Cc: Ingo Molnar <mingo@kernel.org>
> Cc: "David S. Miller" <davem@davemloft.net>
> Cc: Al Viro <viro@zeniv.linux.org.uk>
> Link: http://lkml.kernel.org/r/CAHQdGtRR6SvEhXiqWo24hoUh9AU9cL82Z8Z-d8-7u951F_d+5g@mail.gmail.com
> Signed-off-by: Trond Myklebust <trond.myklebust@primarydata.com>
Thanks Trond!
next prev parent reply other threads:[~2014-06-06 14:07 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-06-05 15:31 Trond Myklebust
2014-06-06 14:07 ` Peter Zijlstra [this message]
2014-06-11 18:39 ` John Stultz
2014-06-11 18:44 ` John Stultz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140606140732.GA11371@laptop.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=davem@davemloft.net \
--cc=john.stultz@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=trond.myklebust@primarydata.com \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome