mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v7 0/2] usb: gadget: f_fs: userspace API fixes and improvements
@ 2014-09-04  6:32 Robert Baldyga
  2014-09-04  6:32 ` [PATCH v7 1/2] usb: gadget: f_fs: add ioctl returning ep descriptor Robert Baldyga
  2014-09-04  6:32 ` [PATCH v7 2/2] usb: gadget: f_fs: virtual endpoint address mapping Robert Baldyga
  0 siblings, 2 replies; 4+ messages in thread
From: Robert Baldyga @ 2014-09-04  6:32 UTC (permalink / raw)
  To: balbi
  Cc: gregkh, linux-usb, linux-kernel, mina86, m.szyprowski, andrzej.p,
	k.opasiak, Robert Baldyga

This patchset contains changes in FunctionFS making it easier and
safer to use. It fixes bug in endpoint files handling code, adds new
ioctl allowing to obtain endpoint descriptor, and introduces virtual
address mapping which allows to separate endpoint address space in
function from physical endpoint addresses, and introduces new endpoint
files naming convention.

Changelog:

v7:
- return proper value from ffs_epfile_ioctl() function
- remove patch "usb: gadget: f_fs: fix the redundant ep files problem"
  from this patchset because it's already in Gregs tree

v6: https://lkml.org/lkml/2014/8/25/101
- unlock spinlock before copy_to_user() call 
- remove duplicated eps_count value check
- few minor fixes

v5: https://lkml.org/lkml/2014/8/21/252
- fix typo pointed by Sergei Shtylyov

v4: https://lkml.org/lkml/2014/8/20/277
- change if() sequence into switch() statement
v3: https://lkml.org/lkml/2014/7/30/115
- move fix for the redundant ep files problem into sepatare patch
- merge user space API affecting changes into single patch
- add flag switching between old and new style API

v2: https://lkml.org/lkml/2014/7/25/296
- return proper endpont address in setup request handling
- add patch usb: gadget: f_fs: add ioctl returning ep descriptor
- add patch usb: gadget: f_fs: make numbers in ep file names the same
  as ep addresses

v1: https://lkml.org/lkml/2014/7/18/1010

Robert Baldyga (2):
  usb: gadget: f_fs: add ioctl returning ep descriptor
  usb: gadget: f_fs: virtual endpoint address mapping

 drivers/usb/gadget/function/f_fs.c  | 46 +++++++++++++++++++++++++++++++++++--
 drivers/usb/gadget/function/u_fs.h  |  2 ++
 include/uapi/linux/usb/functionfs.h |  7 ++++++
 3 files changed, 53 insertions(+), 2 deletions(-)

-- 
1.9.1


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2014-09-05 17:38 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-09-04  6:32 [PATCH v7 0/2] usb: gadget: f_fs: userspace API fixes and improvements Robert Baldyga
2014-09-04  6:32 ` [PATCH v7 1/2] usb: gadget: f_fs: add ioctl returning ep descriptor Robert Baldyga
2014-09-04  6:32 ` [PATCH v7 2/2] usb: gadget: f_fs: virtual endpoint address mapping Robert Baldyga
2014-09-05 17:38   ` Felipe Balbi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®