From: Jason Gunthorpe <jgunthorpe@obsidianresearch.com>
To: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
Cc: Peter Huewe <peterhuewe@gmx.de>,
Ashley Lai <ashley@ashleylai.com>,
Marcel Selhorst <tpmdd@selhorst.net>,
tpmdd-devel@lists.sourceforge.net, linux-kernel@vger.kernel.org,
josh.triplett@intel.com, christophe.ricard@gmail.com,
jason.gunthorpe@obsidianresearch.com
Subject: Re: [PATCH v6 04/10] tpm: rename chip->dev to chip->pdev
Date: Mon, 10 Nov 2014 10:45:11 -0700 [thread overview]
Message-ID: <20141110174511.GA5296@obsidianresearch.com> (raw)
In-Reply-To: <1415623794-6090-5-git-send-email-jarkko.sakkinen@linux.intel.com>
On Mon, Nov 10, 2014 at 02:49:48PM +0200, Jarkko Sakkinen wrote:
> Rename chip->dev to chip->pdev to make it explicit that this not the
> character device but actually represents the platform device.
I don't really have time to take a detailed look at this for a few
weeks, but I like this entire patch set.
> - if (try_module_get(pos->dev->driver->owner)) {
> + if (try_module_get(pos->pdev->driver->owner)) {
> chip = pos;
> break;
Yes, this needs to be pdev
> if (test_and_set_bit(0, &chip->is_open)) {
> - dev_dbg(chip->dev, "Another process owns this TPM\n");
> + dev_dbg(chip->pdev, "Another process owns this TPM\n");
> return -EBUSY;
This should be moved to the class dev, ie it should ultimately say dev_dbg(&chip->dev,..
Similar comments all over the place.
Jason
next prev parent reply other threads:[~2014-11-10 17:45 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-10 12:49 [PATCH v6 00/10] TPM 2.0 support Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 01/10] tpm: merge duplicate transmit_cmd() functions Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 02/10] tpm: two-phase chip management functions Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 03/10] tpm: fix multiple race conditions in tpm_ppi.c Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 04/10] tpm: rename chip->dev to chip->pdev Jarkko Sakkinen
2014-11-10 17:45 ` Jason Gunthorpe [this message]
2014-11-11 8:13 ` Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 05/10] tpm: device class for tpm Jarkko Sakkinen
2014-11-10 18:00 ` Jason Gunthorpe
2014-11-11 8:20 ` Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 06/10] tpm: fix race condition with sysfs attributes Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 07/10] tpm: TPM 2.0 baseline support Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 08/10] tpm: TPM 2.0 CRB Interface Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 09/10] tpm: TPM 2.0 FIFO Interface Jarkko Sakkinen
2014-11-10 12:49 ` [PATCH v6 10/10] tpm: TPM 2.0 sysfs attributes Jarkko Sakkinen
2014-11-10 18:03 ` Jason Gunthorpe
2014-11-11 8:22 ` Jarkko Sakkinen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20141110174511.GA5296@obsidianresearch.com \
--to=jgunthorpe@obsidianresearch.com \
--cc=ashley@ashleylai.com \
--cc=christophe.ricard@gmail.com \
--cc=jarkko.sakkinen@linux.intel.com \
--cc=jason.gunthorpe@obsidianresearch.com \
--cc=josh.triplett@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peterhuewe@gmx.de \
--cc=tpmdd-devel@lists.sourceforge.net \
--cc=tpmdd@selhorst.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome