mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Bjorn Andersson <bjorn.andersson@sonymobile.com>
Cc: Liam Girdwood <lgirdwood@gmail.com>,
	agross@codeaurora.org, linux-arm-msm@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org,
	patches@opensource.wolfsonmicro.com
Subject: Re: [PATCH 2/9] regulator: core: Introduce set_optimum_mode op
Date: Wed, 28 Jan 2015 19:52:04 +0000	[thread overview]
Message-ID: <20150128195204.GN21293@sirena.org.uk> (raw)
In-Reply-To: <1422413199-17273-3-git-send-email-bjorn.andersson@sonymobile.com>

[-- Attachment #1: Type: text/plain, Size: 784 bytes --]

On Tue, Jan 27, 2015 at 06:46:32PM -0800, Bjorn Andersson wrote:

> +	/* set most efficient regulator operating mode for load */
> +	int (*set_optimum_mode)(struct regulator_dev *, int input_uV,
> +				int output_uV, int load_uA);

This is basically fine but can you please rename this to be something
that more directly reflects the fact that we're just informing the
driver about the operating parameters - there are other things a driver
could usefully do with this, for example set current limits so that if
something starts to consume excessive current the device will flag this
as an error.

It'd also be better to split the voltage specs out into a separate
function, especially for the output voltage where obviously we have a
separate range based interface for setting that.

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 473 bytes --]

  reply	other threads:[~2015-01-29  1:25 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-28  2:46 [PATCH 0/9] Simplify regulator_set_optimum_mode Bjorn Andersson
2015-01-28  2:46 ` [PATCH 1/9] regulator: core: Consolidate drms update handling Bjorn Andersson
2015-01-28 19:52   ` Mark Brown
2015-01-28  2:46 ` [PATCH 2/9] regulator: core: Introduce set_optimum_mode op Bjorn Andersson
2015-01-28 19:52   ` Mark Brown [this message]
2015-01-30  0:07     ` Bjorn Andersson
2015-01-30 12:27       ` Mark Brown
2015-02-09 22:08         ` Bjorn Andersson
2015-02-10  7:08           ` Mark Brown
2015-02-05 22:16       ` Bjorn Andersson
2015-02-06 11:46         ` Mark Brown
2015-01-28  2:46 ` [PATCH 3/9] regulator: ab8500: move to set_optimum_mode Bjorn Andersson
2015-01-28 19:56   ` Mark Brown
2015-01-28  2:46 ` [PATCH 4/9] regulator: wm831x-ldo: " Bjorn Andersson
2015-01-28  2:46 ` [PATCH 5/9] regulator: wm8350: " Bjorn Andersson
2015-01-28  2:46 ` [PATCH 6/9] regulator: hi6421: " Bjorn Andersson
2015-01-28  2:46 ` [PATCH 7/9] regulator: wm8400: " Bjorn Andersson
2015-01-28  2:46 ` [PATCH 8/9] regulator: Drop now unused get_optimum_mode Bjorn Andersson
2015-01-28  2:46 ` [PATCH 9/9] regulator: qcom-rpm: Implement set_optimum_mode Bjorn Andersson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150128195204.GN21293@sirena.org.uk \
    --to=broonie@kernel.org \
    --cc=agross@codeaurora.org \
    --cc=bjorn.andersson@sonymobile.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=patches@opensource.wolfsonmicro.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®