mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jiri Olsa <jolsa@redhat.com>
To: David Ahern <david.ahern@oracle.com>
Cc: Jiri Olsa <jolsa@kernel.org>,
	linux-kernel@vger.kernel.org,
	Arnaldo Carvalho de Melo <acme@redhat.com>,
	Corey Ashford <cjashfor@linux.vnet.ibm.com>,
	Ingo Molnar <mingo@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Paul Mackerras <paulus@samba.org>,
	Peter Zijlstra <peterz@infradead.org>
Subject: Re: [PATCH 12/14] tools build: Allow to override feature checks setup
Date: Tue, 3 Mar 2015 18:55:31 +0100	[thread overview]
Message-ID: <20150303175531.GD27424@krava.brq.redhat.com> (raw)
In-Reply-To: <54F5F414.2070608@oracle.com>

On Tue, Mar 03, 2015 at 10:49:08AM -0700, David Ahern wrote:
> On 3/3/15 7:26 AM, Jiri Olsa wrote:
> >Allowing to override configuration variables for feature
> >checks. Also adding automated test and documentation.
> 
> Rather than an 'override' why not require users to specify feature checks of
> interest? ie., the previous patch moved all of perf's feature checks to a
> common Makefile. Why not have perf specify features of interest to it
> instead?

well, thats what they can do as you can see in the example:

+  FEATURE_TESTS   := glibc backtrace
+  FEATURE_DISPLAY := glibc
+
+  srctree := ../../../..
+  include $(srctree)/tools/build/Makefile.feature

you specify features you want to check in FEATURE_TESTS variable
and features status you want to display in FEATURE_DISPLAY variable

at the mean time the default settings for those 2 is what
perf uses now (perf is the only user)

in future when there's multiple users, perf will set those
variables as well..

jirka

  reply	other threads:[~2015-03-03 17:56 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-03 14:26 [PATCH 00/14] tools build: Move features framework into tools/build Jiri Olsa
2015-03-03 14:26 ` [PATCH 01/14] tools build: Remove Copyright from credits message Jiri Olsa
2015-03-03 14:26 ` [PATCH 02/14] perf build: Get rid of LIB_INCLUDE variable Jiri Olsa
2015-03-03 14:26 ` [PATCH 03/14] perf build: Rename CORE_FEATURE_TESTS to FEATURE_TESTS Jiri Olsa
2015-03-03 14:26 ` [PATCH 04/14] perf build: Get rid of VF_FEATURE_TESTS Jiri Olsa
2015-03-03 14:26 ` [PATCH 05/14] perf build: Rename display_lib into feature_display Jiri Olsa
2015-03-03 14:26 ` [PATCH 06/14] perf build: Rename display_vf to feature_verbose Jiri Olsa
2015-03-03 14:26 ` [PATCH 07/14] perf build: Rename PERF-FEATURES into FEATURE-DUMP Jiri Olsa
2015-03-03 14:26 ` [PATCH 08/14] perf build: Rename feature_print_var_code to print_var_code Jiri Olsa
2015-03-03 14:26 ` [PATCH 09/14] perf build: Separate feature make support into config/Makefile.feature Jiri Olsa
2015-03-03 14:26 ` [PATCH 10/14] perf build: Make features checks directory configurable Jiri Olsa
2015-03-03 14:26 ` [PATCH 11/14] tools build: Move feature checks code under tools/build Jiri Olsa
2015-03-03 17:18   ` David Ahern
2015-03-03 17:34     ` Jiri Olsa
2015-03-03 14:26 ` [PATCH 12/14] tools build: Allow to override feature checks setup Jiri Olsa
2015-03-03 17:49   ` David Ahern
2015-03-03 17:55     ` Jiri Olsa [this message]
2015-03-04 12:23   ` Namhyung Kim
2015-03-04 12:37     ` [PATCHv2 " Jiri Olsa
2015-03-03 14:26 ` [PATCH 13/14] tools build: Fix feature_check name clash Jiri Olsa
2015-03-03 14:26 ` [PATCH 14/14] tools build: Disable default check for libbabeltrace Jiri Olsa
2015-03-04 10:40   ` [PATCHv2 " Jiri Olsa
2015-03-04 20:24     ` Ingo Molnar
2015-03-04  4:41 ` [PATCH 00/14] tools build: Move features framework into tools/build Ingo Molnar
2015-03-04 10:18   ` Jiri Olsa

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150303175531.GD27424@krava.brq.redhat.com \
    --to=jolsa@redhat.com \
    --cc=acme@redhat.com \
    --cc=cjashfor@linux.vnet.ibm.com \
    --cc=david.ahern@oracle.com \
    --cc=jolsa@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=namhyung@kernel.org \
    --cc=paulus@samba.org \
    --cc=peterz@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome