From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
To: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Cc: Ingo Molnar <mingo@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
rusty@rustcorp.com.au, oleg@redhat.com,
torvalds@linux-foundation.org, linux-kernel@vger.kernel.org,
andi@firstfloor.org, rostedt@goodmis.org, tglx@linutronix.de,
laijs@cn.fujitsu.com, linux@horizon.com,
Andrea Arcangeli <aarcange@redhat.com>,
David Woodhouse <David.Woodhouse@intel.com>,
Rik van Riel <riel@redhat.com>,
Michel Lespinasse <walken@google.com>
Subject: Re: [PATCH v5 05/10] seqlock: Better document raw_write_seqcount_latch()
Date: Mon, 13 Apr 2015 10:43:23 -0700 [thread overview]
Message-ID: <20150413174323.GY23685@linux.vnet.ibm.com> (raw)
In-Reply-To: <1979415164.29724.1428944899771.JavaMail.zimbra@efficios.com>
On Mon, Apr 13, 2015 at 05:08:19PM +0000, Mathieu Desnoyers wrote:
> ----- Original Message -----
> >
> > * Peter Zijlstra <peterz@infradead.org> wrote:
> >
> [...]
> > > + * The query will have a form like:
> > > + *
> > > + * struct entry *latch_query(struct latch_struct *latch, ...)
> > > + * {
> > > + * struct entry *entry;
> > > + * unsigned seq, idx;
> > > + *
> > > + * do {
> > > + * seq = latch->seq;
> > > + * smp_rmb();
> > > + *
> > > + * idx = seq & 0x01;
> > > + * entry = data_query(latch->data[idx], ...);
> > > + *
> > > + * smp_rmb();
> > > + * } while (seq != latch->seq);
> >
> > Btw., I realize this is just a sample, but couldn't this be written
> > more optimally as:
> >
> > do {
> > seq = READ_ONCE(latch->seq);
> > smp_read_barrier_depends();
> >
> > idx = seq & 0x01;
> > entry = data_query(latch->data[idx], ...);
> >
> > smp_rmb();
> > } while (seq != latch->seq);
> >
> > Note that there's just a single smp_rmb() barrier: the READ_ONCE() is
> > there to make sure GCC doesn't calculate 'idx' from two separate
> > reads, but otherwise there's a direct data dependency on latch->seq so
> > no smp_rmb() is needed, only a data dependency barrier when doing the
> > first lookup AFAICS?
> >
> > (This doesn't matter on x86 where smp_rmb() is barrier().)
>
> The latch evolved from seqlock.h, where there was no
> data dependency between the sequence counter and the
> data read, hence the smp_rmb(). Indeed, there is a
> data dependency in the case of the latch, so I think
> your approach of READ_ONCE + smp_read_barrier_depends()
> is appropriate.
A shorthand for READ_ONCE + smp_read_barrier_depends() is the shiny
new lockless_dereference(). This helps readability, as it is often
non-trivial to work out which accesses smp_read_barrier_depends() is
helping to order.
Thanx, Paul
next prev parent reply other threads:[~2015-04-13 17:43 UTC|newest]
Thread overview: 46+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-13 14:11 [PATCH v5 00/10] latched RB-trees and __module_address() Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 01/10] module: Sanitize RCU usage and locking Peter Zijlstra
2015-04-13 15:32 ` Ingo Molnar
2015-04-13 15:40 ` Peter Zijlstra
2015-04-13 16:32 ` Ingo Molnar
2015-04-13 14:11 ` [PATCH v5 02/10] module: Annotate module version magic Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 03/10] module, jump_label: Fix module locking Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 04/10] rbtree: Make lockless searches non-fatal Peter Zijlstra
2015-04-13 15:50 ` Ingo Molnar
2015-04-13 19:10 ` Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 05/10] seqlock: Better document raw_write_seqcount_latch() Peter Zijlstra
2015-04-13 16:32 ` Ingo Molnar
2015-04-13 17:08 ` Mathieu Desnoyers
2015-04-13 17:43 ` Paul E. McKenney [this message]
2015-04-13 18:21 ` Linus Torvalds
2015-04-13 18:42 ` Paul E. McKenney
2015-04-14 10:25 ` Ingo Molnar
2015-04-14 13:04 ` Paul E. McKenney
2015-04-14 14:31 ` Ingo Molnar
2015-04-14 15:11 ` Paul E. McKenney
2015-04-13 19:17 ` Peter Zijlstra
2015-04-13 19:47 ` Peter Zijlstra
2015-04-14 10:26 ` Ingo Molnar
2015-04-13 14:11 ` [PATCH v5 06/10] rbtree: Implement generic latch_tree Peter Zijlstra
2015-04-13 16:43 ` Ingo Molnar
2015-04-13 19:20 ` Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 07/10] module: Optimize __module_address() using a latched RB-tree Peter Zijlstra
2015-04-13 16:49 ` Ingo Molnar
2015-04-14 12:31 ` Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 08/10] module: Make the mod_tree stuff conditional on PERF_EVENTS || TRACING Peter Zijlstra
2015-04-13 16:53 ` Ingo Molnar
2015-04-13 14:11 ` [PATCH v5 09/10] module: Use __module_address() for module_address_lookup() Peter Zijlstra
2015-04-13 14:11 ` [PATCH v5 10/10] module: Rework module_addr_{min,max} Peter Zijlstra
2015-04-13 16:56 ` Ingo Molnar
2015-04-14 2:55 ` Rusty Russell
2015-04-14 6:42 ` Peter Zijlstra
2015-04-14 12:56 ` Peter Zijlstra
2015-04-14 13:00 ` Ingo Molnar
2015-04-13 17:02 ` [PATCH v5 00/10] latched RB-trees and __module_address() Ingo Molnar
2015-04-14 2:57 ` Rusty Russell
2015-04-14 6:41 ` Peter Zijlstra
2015-04-15 4:41 ` Rusty Russell
2015-04-15 9:41 ` Peter Zijlstra
2015-05-28 2:07 ` Rusty Russell
2015-05-28 11:20 ` Peter Zijlstra
2015-05-28 23:49 ` Rusty Russell
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150413174323.GY23685@linux.vnet.ibm.com \
--to=paulmck@linux.vnet.ibm.com \
--cc=David.Woodhouse@intel.com \
--cc=aarcange@redhat.com \
--cc=andi@firstfloor.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@horizon.com \
--cc=mathieu.desnoyers@efficios.com \
--cc=mingo@kernel.org \
--cc=oleg@redhat.com \
--cc=peterz@infradead.org \
--cc=riel@redhat.com \
--cc=rostedt@goodmis.org \
--cc=rusty@rustcorp.com.au \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--cc=walken@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome