From: "Radim Krčmář" <rkrcmar@redhat.com>
To: Christian Borntraeger <borntraeger@de.ibm.com>
Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org,
Paolo Bonzini <pbonzini@redhat.com>
Subject: Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper
Date: Thu, 13 Aug 2015 11:11:11 +0200 [thread overview]
Message-ID: <20150813091110.GA26977@potion.brq.redhat.com> (raw)
In-Reply-To: <55CBA523.3010007@de.ibm.com>
2015-08-12 21:57+0200, Christian Borntraeger:
> kvm_check_request is now somewhat a misnomer (what is the difference between test and check?)
kvm_check_request has always been poetic; it uses two meanings of
check, "examine" and "tick off", at the same time.
We also want something that clears the request, so kvm_drop_request was
my best candidate so far.
> for the new interface. maybe we can rename kvm_check_request in a separate patch somewhen.
I wonder why haven't we copied the naming convention from bit operations
(or if programming would be better if German was its language),
kvm_test_request
kvm_set_request
kvm_clear_request
kvm_test_and_clear_request
The only disadvantage is that
kvm_test_and_clear_request
is longer than
kvm_check_request
123456789
by whooping 9 characters.
I could live with that.
next prev parent reply other threads:[~2015-08-13 9:11 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-05 16:32 [PATCH v2 0/5] KVM: optimize userspace exits with a new ioctl Radim Krčmář
2015-08-05 16:32 ` [PATCH v2 1/5] KVM: add kvm_has_request wrapper Radim Krčmář
2015-08-12 19:57 ` Christian Borntraeger
2015-08-13 9:11 ` Radim Krčmář [this message]
2015-08-13 9:29 ` Paolo Bonzini
2015-08-13 10:03 ` Christian Borntraeger
2015-08-14 8:42 ` Radim Krčmář
2015-08-05 16:32 ` [PATCH v2 2/5] KVM: add KVM_REQ_EXIT request for userspace exit Radim Krčmář
2015-08-05 16:32 ` [PATCH v2 3/5] KVM: x86: add request_exits debug counter Radim Krčmář
2015-08-05 16:33 ` [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Radim Krčmář
2015-08-05 16:36 ` Paolo Bonzini
2015-08-06 13:44 ` Radim Krčmář
2015-08-06 13:52 ` Paolo Bonzini
2015-08-06 17:21 ` Radim Krčmář
2015-08-16 20:27 ` Avi Kivity
2015-08-17 13:15 ` Paolo Bonzini
2015-08-18 18:30 ` Avi Kivity
2015-08-18 19:57 ` Paolo Bonzini
2015-08-19 6:43 ` Avi Kivity
2015-08-05 16:33 ` [PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch Radim Krčmář
2015-08-12 20:03 ` Christian Borntraeger
2015-08-13 8:53 ` Radim Krčmář
2015-08-13 9:29 ` Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150813091110.GA26977@potion.brq.redhat.com \
--to=rkrcmar@redhat.com \
--cc=borntraeger@de.ibm.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome