mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Felipe Balbi <balbi@ti.com>
To: Peter Senna Tschudin <peter.senna@gmail.com>
Cc: <balbi@ti.com>, <stern@rowland.harvard.edu>,
	<sergei.shtylyov@cogentembedded.com>, <standby24x7@gmail.com>,
	<pmladek@suse.cz>, <linux-usb@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <gregkh@linuxfoundation.org>
Subject: Re: [PATCH 01/14] RFC: usb/host/fotg210: Fix coding style issues
Date: Fri, 2 Oct 2015 12:29:39 -0500	[thread overview]
Message-ID: <20151002172939.GL5552@saruman.tx.rr.com> (raw)
In-Reply-To: <1442847678-7970-2-git-send-email-peter.senna@gmail.com>

[-- Attachment #1: Type: text/plain, Size: 4151 bytes --]

On Mon, Sep 21, 2015 at 05:01:05PM +0200, Peter Senna Tschudin wrote:
> This patch fix coding style issues reported by checkpatch that do not
> change semantics of the code.
> 
> Signed-off-by: Peter Senna Tschudin <peter.senna@gmail.com>
> ---
>  drivers/usb/host/fotg210-hcd.c | 1248 +++++++++++++++++-----------------------
>  drivers/usb/host/fotg210.h     |   36 +-
>  2 files changed, 558 insertions(+), 726 deletions(-)
> 
> diff --git a/drivers/usb/host/fotg210-hcd.c b/drivers/usb/host/fotg210-hcd.c
> index 000ed80..48eac34 100644
> --- a/drivers/usb/host/fotg210-hcd.c
> +++ b/drivers/usb/host/fotg210-hcd.c
> @@ -50,32 +50,30 @@
>  #include <asm/irq.h>
>  #include <asm/unaligned.h>
>  
> -/*-------------------------------------------------------------------------*/
>  #define DRIVER_AUTHOR "Yuan-Hsin Chen"
>  #define DRIVER_DESC "FOTG210 Host Controller (EHCI) Driver"
> -
> -static const char	hcd_name[] = "fotg210_hcd";
> +static const char hcd_name[] = "fotg210_hcd";
>  
>  #undef FOTG210_URB_TRACE
> -
>  #define FOTG210_STATS
>  
>  /* magic numbers that can affect system performance */
> -#define	FOTG210_TUNE_CERR		3 /* 0-3 qtd retries; 0 == don't stop */
> -#define	FOTG210_TUNE_RL_HS		4 /* nak throttle; see 4.9 */
> -#define	FOTG210_TUNE_RL_TT		0
> -#define	FOTG210_TUNE_MULT_HS	1	/* 1-3 transactions/uframe; 4.10.3 */
> -#define	FOTG210_TUNE_MULT_TT	1
> +#define FOTG210_TUNE_CERR	3 /* 0-3 qtd retries; 0 == don't stop */
> +#define FOTG210_TUNE_RL_HS	4 /* nak throttle; see 4.9 */
> +#define FOTG210_TUNE_RL_TT	0
> +#define FOTG210_TUNE_MULT_HS	1 /* 1-3 transactions/uframe; 4.10.3 */
> +#define FOTG210_TUNE_MULT_TT	1
> +
>  /*
> - * Some drivers think it's safe to schedule isochronous transfers more than
> - * 256 ms into the future (partly as a result of an old bug in the scheduling
> + * Some drivers think it's safe to schedule isochronous transfers more than 256
> + * ms into the future (partly as a result of an old bug in the scheduling
>   * code).  In an attempt to avoid trouble, we will use a minimum scheduling
>   * length of 512 frames instead of 256.
>   */
> -#define	FOTG210_TUNE_FLS		1 /* (medium) 512-frame schedule */
> +#define FOTG210_TUNE_FLS 1 /* (medium) 512-frame schedule */
>  
>  /* Initial IRQ latency:  faster than hw default */
> -static int log2_irq_thresh;		/* 0 to 6 */
> +static int log2_irq_thresh; /* 0 to 6 */
>  module_param(log2_irq_thresh, int, S_IRUGO);
>  MODULE_PARM_DESC(log2_irq_thresh, "log2 IRQ latency, 1-64 microframes");
>  
> @@ -89,66 +87,57 @@ static unsigned int hird;
>  module_param(hird, int, S_IRUGO);
>  MODULE_PARM_DESC(hird, "host initiated resume duration, +1 for each 75us");
>  
> -#define	INTR_MASK (STS_IAA | STS_FATAL | STS_PCD | STS_ERR | STS_INT)
> +#define INTR_MASK (STS_IAA | STS_FATAL | STS_PCD | STS_ERR | STS_INT)
>  
>  #include "fotg210.h"
>  
> -/*-------------------------------------------------------------------------*/
> -
>  #define fotg210_dbg(fotg210, fmt, args...) \
> -	dev_dbg(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args)
> +	dev_dbg(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args)
>  #define fotg210_err(fotg210, fmt, args...) \
> -	dev_err(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args)
> +	dev_err(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args)
>  #define fotg210_info(fotg210, fmt, args...) \
> -	dev_info(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args)
> +	dev_info(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args)
>  #define fotg210_warn(fotg210, fmt, args...) \
> -	dev_warn(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args)
> +	dev_warn(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args)
>  
> -/* check the values in the HCSPARAMS register
> - * (host controller _Structural_ parameters)
> - * see EHCI spec, Table 2-4 for each value
> +/* check the values in the HCSPARAMS register (host controller _Structural_

if you're fixing coding style issues, you might as well go ahead and fix this
comment style too:

/*
 * check the values ....

--
balbi

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 819 bytes --]

  reply	other threads:[~2015-10-02 17:29 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-09-07 14:47 similar files: fusbh200-hcd.c and fotg210-hcd.c Peter Senna Tschudin
2015-09-08 15:52 ` Felipe Balbi
2015-09-12 13:14   ` Peter Senna Tschudin
2015-09-14 15:01     ` Felipe Balbi
2015-09-14 17:50       ` Peter Senna Tschudin
2015-09-15 14:33         ` Felipe Balbi
2015-09-15 16:41           ` Peter Senna Tschudin
2015-09-15 16:50             ` Felipe Balbi
2015-09-21 15:01               ` [PATCH 00/14] RFC: Consolidation: FUSB200 and FOTG210 Peter Senna Tschudin
2015-09-21 15:01                 ` [PATCH 01/14] RFC: usb/host/fotg210: Fix coding style issues Peter Senna Tschudin
2015-10-02 17:29                   ` Felipe Balbi [this message]
2015-09-21 15:01                 ` [PATCH 02/14] RFC: usb/host/fotg210: remove KERN_WARNING from pr_info Peter Senna Tschudin
2015-09-21 18:54                   ` Sergei Shtylyov
2015-10-02 17:30                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 03/14] RFC: usb/host/fotg210: Remove useless else statement Peter Senna Tschudin
2015-10-02 17:30                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 04/14] RFC: usb/host/fotg210: Remove NULL checks dma_pool_destroy Peter Senna Tschudin
2015-10-02 17:30                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 05/14] RFC: usb/host/fotg210: change kmalloc by kmalloc_array Peter Senna Tschudin
2015-09-21 18:56                   ` Sergei Shtylyov
2015-10-02 17:30                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 06/14] RFC: usb/host/fotg210: replace msleep by usleep_range Peter Senna Tschudin
2015-10-02 17:31                   ` Felipe Balbi
2015-10-02 17:52                     ` Alan Stern
2015-10-04  9:58                       ` Peter Senna Tschudin
2015-10-04 15:20                         ` Alan Stern
2015-09-21 15:01                 ` [PATCH 07/14] RFC: usb/host/fotg210: Remove a macro from snprintf Peter Senna Tschudin
2015-10-02 17:31                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 08/14] RFC: usb/host/fotg210: convert macro to inline function Peter Senna Tschudin
2015-10-02 17:32                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 09/14] RFC: usb/host/fotg210: Add function: output_buf_tds_dir() Peter Senna Tschudin
2015-09-21 19:15                   ` Sergei Shtylyov
2015-10-02 17:32                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 10/14] RFC: usb/host/fotg210: Add function scan_frame_queue() Peter Senna Tschudin
2015-10-02 17:35                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 11/14] RFC: usb/host: Rename fotg210-hcd to faraday-hcd Peter Senna Tschudin
2015-10-02 17:35                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 12/14] RFC: usb/host/faraday-hcd: Replace fotg210 by fhcd2xx Peter Senna Tschudin
2015-10-02 17:36                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct Peter Senna Tschudin
2015-10-02 17:37                   ` Felipe Balbi
2015-09-21 15:01                 ` [PATCH 14/14] RFC: usb/host/faraday-hcd: Import FUSBH200 parameters Peter Senna Tschudin
2015-10-02 17:38                   ` Felipe Balbi
2015-10-02 11:18                 ` [PATCH] usb-host: Remove fusbh200 driver Peter Senna Tschudin
2015-10-02 17:39                   ` Felipe Balbi
2015-10-03  9:56                     ` Peter Senna Tschudin
2015-10-03 21:21                       ` Felipe Balbi
2015-10-05  0:25                         ` John Feng-Hsin Chiang(江峰興)
2015-10-12 21:22                 ` [PATCH 0/9] usb/host/fotg210: code style and warning fixes Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 1/9] usb/host/fotg210: Fix coding style issues Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 2/9] usb/host/fotg210: remove KERN_WARNING from pr_warn Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 3/9] usb/host/fotg210: Remove useless else statement Peter Senna Tschudin
2015-10-12 22:06                     ` Joe Perches
2015-10-17 19:28                       ` [PATCH 3/9 V2] usb/host/fotg210: Remove return statement inside if Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 4/9] usb/host/fotg210: Remove NULL checks dma_pool_destroy Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 5/9] usb/host/fotg210: change kmalloc by kmalloc_array Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 6/9] usb/host/fotg210: replace msleep by usleep_range Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 7/9] usb/host/fotg210: convert macro to inline function Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 8/9] usb/host/fotg210: Add function: output_buf_tds_dir() Peter Senna Tschudin
2015-10-12 21:22                   ` [PATCH 9/9] usb/host/fotg210: Add function scan_frame_queue() Peter Senna Tschudin
2015-09-25 13:04               ` similar files: fusbh200-hcd.c and fotg210-hcd.c Peter Senna Tschudin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20151002172939.GL5552@saruman.tx.rr.com \
    --to=balbi@ti.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=peter.senna@gmail.com \
    --cc=pmladek@suse.cz \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=standby24x7@gmail.com \
    --cc=stern@rowland.harvard.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome