From: Felipe Balbi <balbi@ti.com>
To: Peter Senna Tschudin <peter.senna@gmail.com>
Cc: <balbi@ti.com>, <stern@rowland.harvard.edu>,
<sergei.shtylyov@cogentembedded.com>, <standby24x7@gmail.com>,
<pmladek@suse.cz>, <linux-usb@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <gregkh@linuxfoundation.org>
Subject: Re: [PATCH 07/14] RFC: usb/host/fotg210: Remove a macro from snprintf
Date: Fri, 2 Oct 2015 12:31:43 -0500 [thread overview]
Message-ID: <20151002173143.GR5552@saruman.tx.rr.com> (raw)
In-Reply-To: <1442847678-7970-8-git-send-email-peter.senna@gmail.com>
[-- Attachment #1: Type: text/plain, Size: 2219 bytes --]
On Mon, Sep 21, 2015 at 05:01:11PM +0200, Peter Senna Tschudin wrote:
> This patch removes a macro from a call to snprintf() and moves it's
> content to just before the call to snprintf() assigning a value to a new
> variable named tmp. The goal of this patch is to make the code easier to
> understand.
>
> Signed-off-by: Peter Senna Tschudin <peter.senna@gmail.com>
it's a little unnecessary, but no objections.
> ---
> drivers/usb/host/fotg210-hcd.c | 43 ++++++++++++++++++++++--------------------
> 1 file changed, 23 insertions(+), 20 deletions(-)
>
> diff --git a/drivers/usb/host/fotg210-hcd.c b/drivers/usb/host/fotg210-hcd.c
> index 55c2279..4032ed0 100644
> --- a/drivers/usb/host/fotg210-hcd.c
> +++ b/drivers/usb/host/fotg210-hcd.c
> @@ -367,6 +367,8 @@ static void qh_lines(struct fotg210_hcd *fotg210, struct fotg210_qh *qh,
> unsigned size = *sizep;
> char *next = *nextp;
> char mark;
> + char *tmp;
> +
> __le32 list_end = FOTG210_LIST_END(fotg210);
> struct fotg210_qh_hw *hw = qh->hw;
>
> @@ -411,28 +413,29 @@ static void qh_lines(struct fotg210_hcd *fotg210, struct fotg210_qh *qh,
> else if (td->hw_alt_next != list_end)
> mark = '/';
> }
> - temp = snprintf(next, size,
> - "\n\t%p%c%s len=%d %08x urb %p",
> - td, mark, ({ char *tmp;
> - switch ((scratch>>8)&0x03) {
> - case 0:
> - tmp = "out";
> - break;
> - case 1:
> - tmp = "in";
> - break;
> - case 2:
> - tmp = "setup";
> - break;
> - default:
> - tmp = "?";
> - break;
> - } tmp; }),
> - (scratch >> 16) & 0x7fff,
> - scratch,
> - td->urb);
> +
> + switch ((scratch >> 8) & 0x03) {
> + case 0:
> + tmp = "out";
> + break;
> + case 1:
> + tmp = "in";
> + break;
> + case 2:
> + tmp = "setup";
> + break;
> + default:
> + tmp = "?";
> + break;
> + }
> +
> + temp = snprintf(next, size, "\n\t%p%c%s len=%d %08x urb %p",
> + td, mark, tmp, (scratch >> 16) & 0x7fff,
> + scratch, td->urb);
> +
> if (size < temp)
> temp = size;
> +
> size -= temp;
> next += temp;
> if (temp == size)
> --
> 2.1.0
>
--
balbi
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 819 bytes --]
next prev parent reply other threads:[~2015-10-02 17:31 UTC|newest]
Thread overview: 61+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-09-07 14:47 similar files: fusbh200-hcd.c and fotg210-hcd.c Peter Senna Tschudin
2015-09-08 15:52 ` Felipe Balbi
2015-09-12 13:14 ` Peter Senna Tschudin
2015-09-14 15:01 ` Felipe Balbi
2015-09-14 17:50 ` Peter Senna Tschudin
2015-09-15 14:33 ` Felipe Balbi
2015-09-15 16:41 ` Peter Senna Tschudin
2015-09-15 16:50 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 00/14] RFC: Consolidation: FUSB200 and FOTG210 Peter Senna Tschudin
2015-09-21 15:01 ` [PATCH 01/14] RFC: usb/host/fotg210: Fix coding style issues Peter Senna Tschudin
2015-10-02 17:29 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 02/14] RFC: usb/host/fotg210: remove KERN_WARNING from pr_info Peter Senna Tschudin
2015-09-21 18:54 ` Sergei Shtylyov
2015-10-02 17:30 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 03/14] RFC: usb/host/fotg210: Remove useless else statement Peter Senna Tschudin
2015-10-02 17:30 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 04/14] RFC: usb/host/fotg210: Remove NULL checks dma_pool_destroy Peter Senna Tschudin
2015-10-02 17:30 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 05/14] RFC: usb/host/fotg210: change kmalloc by kmalloc_array Peter Senna Tschudin
2015-09-21 18:56 ` Sergei Shtylyov
2015-10-02 17:30 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 06/14] RFC: usb/host/fotg210: replace msleep by usleep_range Peter Senna Tschudin
2015-10-02 17:31 ` Felipe Balbi
2015-10-02 17:52 ` Alan Stern
2015-10-04 9:58 ` Peter Senna Tschudin
2015-10-04 15:20 ` Alan Stern
2015-09-21 15:01 ` [PATCH 07/14] RFC: usb/host/fotg210: Remove a macro from snprintf Peter Senna Tschudin
2015-10-02 17:31 ` Felipe Balbi [this message]
2015-09-21 15:01 ` [PATCH 08/14] RFC: usb/host/fotg210: convert macro to inline function Peter Senna Tschudin
2015-10-02 17:32 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 09/14] RFC: usb/host/fotg210: Add function: output_buf_tds_dir() Peter Senna Tschudin
2015-09-21 19:15 ` Sergei Shtylyov
2015-10-02 17:32 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 10/14] RFC: usb/host/fotg210: Add function scan_frame_queue() Peter Senna Tschudin
2015-10-02 17:35 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 11/14] RFC: usb/host: Rename fotg210-hcd to faraday-hcd Peter Senna Tschudin
2015-10-02 17:35 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 12/14] RFC: usb/host/faraday-hcd: Replace fotg210 by fhcd2xx Peter Senna Tschudin
2015-10-02 17:36 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 13/14] RFC: usb/host/faraday-hcd: Move #defines outside struct Peter Senna Tschudin
2015-10-02 17:37 ` Felipe Balbi
2015-09-21 15:01 ` [PATCH 14/14] RFC: usb/host/faraday-hcd: Import FUSBH200 parameters Peter Senna Tschudin
2015-10-02 17:38 ` Felipe Balbi
2015-10-02 11:18 ` [PATCH] usb-host: Remove fusbh200 driver Peter Senna Tschudin
2015-10-02 17:39 ` Felipe Balbi
2015-10-03 9:56 ` Peter Senna Tschudin
2015-10-03 21:21 ` Felipe Balbi
2015-10-05 0:25 ` John Feng-Hsin Chiang(江峰興)
2015-10-12 21:22 ` [PATCH 0/9] usb/host/fotg210: code style and warning fixes Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 1/9] usb/host/fotg210: Fix coding style issues Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 2/9] usb/host/fotg210: remove KERN_WARNING from pr_warn Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 3/9] usb/host/fotg210: Remove useless else statement Peter Senna Tschudin
2015-10-12 22:06 ` Joe Perches
2015-10-17 19:28 ` [PATCH 3/9 V2] usb/host/fotg210: Remove return statement inside if Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 4/9] usb/host/fotg210: Remove NULL checks dma_pool_destroy Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 5/9] usb/host/fotg210: change kmalloc by kmalloc_array Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 6/9] usb/host/fotg210: replace msleep by usleep_range Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 7/9] usb/host/fotg210: convert macro to inline function Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 8/9] usb/host/fotg210: Add function: output_buf_tds_dir() Peter Senna Tschudin
2015-10-12 21:22 ` [PATCH 9/9] usb/host/fotg210: Add function scan_frame_queue() Peter Senna Tschudin
2015-09-25 13:04 ` similar files: fusbh200-hcd.c and fotg210-hcd.c Peter Senna Tschudin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20151002173143.GR5552@saruman.tx.rr.com \
--to=balbi@ti.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=peter.senna@gmail.com \
--cc=pmladek@suse.cz \
--cc=sergei.shtylyov@cogentembedded.com \
--cc=standby24x7@gmail.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome