From: Borislav Petkov <bp@alien8.de>
To: Ingo Molnar <mingo@kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros
Date: Mon, 7 Dec 2015 10:54:20 +0100 [thread overview]
Message-ID: <20151207095420.GB22248@pd.tnic> (raw)
In-Reply-To: <20151207094504.GA27386@gmail.com>
On Mon, Dec 07, 2015 at 10:45:04AM +0100, Ingo Molnar wrote:
>
> * Borislav Petkov <bp@alien8.de> wrote:
>
> > static int __init chacha20_simd_mod_init(void)
> > {
> > - if (!cpu_has_ssse3)
> > + if (!boot_cpu_has(X86_FEATURE_SSSE3))
> > return -ENODEV;
>
> Btw., could we rename 'boot_cpu_has()' to the more appropriate (and shorter!)
> 'system_has()' form?
>
> 'boot cpu' is a conceptual misnomer here really: it's just an implementational
> detail that we are looking at the boot CPU's flags, what we really mean to express
> is that these are system-wide features with no per-cpu properties.
>
> Agreed?
Yeah, sounds good to me.
Mind if I do it for the next part of the cleanup, though, and not rework
those patches which are already tested?
I have a bunch of bulletpoints on the TODO still and could take care of
the renaming then too.
Thanks.
--
Regards/Gruss,
Boris.
ECO tip #101: Trim your mails when you reply.
next prev parent reply other threads:[~2015-12-07 9:54 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-12-07 9:39 [PATCH 0/4] x86/cpufeature: Cleanup, p1 Borislav Petkov
2015-12-07 9:39 ` [PATCH 1/4] x86/cpufeature: Move some of the scattered feature bits to x86_capability Borislav Petkov
2015-12-19 10:18 ` [tip:x86/cpufeature] " tip-bot for Borislav Petkov
2015-12-19 10:54 ` [tip:x86/cleanups] " tip-bot for Borislav Petkov
2015-12-07 9:39 ` [PATCH 2/4] x86/cpufeature: Cleanup get_cpu_cap() Borislav Petkov
2015-12-19 10:19 ` [tip:x86/cpufeature] " tip-bot for Borislav Petkov
2015-12-19 10:55 ` [tip:x86/cleanups] " tip-bot for Borislav Petkov
2015-12-07 9:39 ` [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Borislav Petkov
2015-12-07 9:45 ` Ingo Molnar
2015-12-07 9:54 ` Borislav Petkov [this message]
2015-12-07 13:36 ` Ingo Molnar
2015-12-19 10:19 ` [tip:x86/cpufeature] " tip-bot for Borislav Petkov
2015-12-19 10:55 ` [tip:x86/cleanups] " tip-bot for Borislav Petkov
2015-12-07 9:39 ` [PATCH 4/4] x86/cpu: Provide a config option to disable static_cpu_has Borislav Petkov
2015-12-19 10:19 ` [tip:x86/cpufeature] " tip-bot for Borislav Petkov
2015-12-19 10:55 ` [tip:x86/cleanups] " tip-bot for Borislav Petkov
-- strict thread matches above, loose matches on Subject: below --
2015-12-01 15:00 [PATCH 0/4] x86/cpufeature: Cleanup stuff more Borislav Petkov
2015-12-01 15:00 ` [PATCH 3/4] x86/cpufeature: Remove unused and seldomly used cpu_has_xx macros Borislav Petkov
2015-12-05 18:50 ` Thomas Gleixner
2015-12-05 19:59 ` Thomas Gleixner
2015-12-05 20:03 ` Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20151207095420.GB22248@pd.tnic \
--to=bp@alien8.de \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®