From: Daniel Vetter <daniel@ffwll.ch>
To: Geliang Tang <geliangtang@163.com>
Cc: David Airlie <airlied@linux.ie>,
linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 3/5] drm/sysfs: use kobj_to_dev()
Date: Wed, 13 Jan 2016 16:43:22 +0100 [thread overview]
Message-ID: <20160113154322.GV19130@phenom.ffwll.local> (raw)
In-Reply-To: <3fea991541fbfc4ffece2c174adeb02cb9436c90.1452696179.git.geliangtang@163.com>
On Wed, Jan 13, 2016 at 10:48:41PM +0800, Geliang Tang wrote:
> Use kobj_to_dev() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@163.com>
Merged to drm-misc, thanks.
-Daniel
> ---
> drivers/gpu/drm/drm_sysfs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/drm_sysfs.c b/drivers/gpu/drm/drm_sysfs.c
> index 0ca6410..d503f8e 100644
> --- a/drivers/gpu/drm/drm_sysfs.c
> +++ b/drivers/gpu/drm/drm_sysfs.c
> @@ -240,7 +240,7 @@ static ssize_t edid_show(struct file *filp, struct kobject *kobj,
> struct bin_attribute *attr, char *buf, loff_t off,
> size_t count)
> {
> - struct device *connector_dev = container_of(kobj, struct device, kobj);
> + struct device *connector_dev = kobj_to_dev(kobj);
> struct drm_connector *connector = to_drm_connector(connector_dev);
> unsigned char *edid;
> size_t size;
> --
> 2.5.0
>
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/dri-devel
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
next prev parent reply other threads:[~2016-01-13 15:43 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-01-13 14:48 [PATCH 1/5] drm/i915: use hlist_for_each_entry Geliang Tang
2016-01-13 14:48 ` [PATCH 2/5] drm/i915: use kobj_to_dev() Geliang Tang
2016-01-13 15:42 ` [Intel-gfx] " Daniel Vetter
2016-01-13 14:48 ` [PATCH 3/5] drm/sysfs: " Geliang Tang
2016-01-13 15:43 ` Daniel Vetter [this message]
2016-01-13 14:48 ` [PATCH 4/5] drm/amdgpu: " Geliang Tang
2016-01-13 14:48 ` [PATCH 5/5] drm/radeon: " Geliang Tang
2016-01-13 17:17 ` Alex Deucher
2016-01-13 15:12 ` [Intel-gfx] [PATCH 1/5] drm/i915: use hlist_for_each_entry Chris Wilson
2016-01-18 15:54 ` [PATCH 1/5 v2] " Geliang Tang
2016-01-18 16:49 ` [Intel-gfx] " Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160113154322.GV19130@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=airlied@linux.ie \
--cc=dri-devel@lists.freedesktop.org \
--cc=geliangtang@163.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome