From: Peter Zijlstra <peterz@infradead.org>
To: Zhao Lei <zhaolei@cn.fujitsu.com>
Cc: cgroups@vger.kernel.org, linux-kernel@vger.kernel.org,
mingo@redhat.com, tj@kernel.org,
Yang Dongsheng <yangds.fnst@cn.fujitsu.com>
Subject: Re: [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage.
Date: Thu, 10 Mar 2016 14:27:28 +0100 [thread overview]
Message-ID: <20160310132728.GX6344@twins.programming.kicks-ass.net> (raw)
In-Reply-To: <340a5ec9cb4e7f97b3a41f3dc657b9aca4c76f25.1457082730.git.zhaolei@cn.fujitsu.com>
On Fri, Mar 04, 2016 at 05:47:06PM +0800, Zhao Lei wrote:
> +static u64 cpuacct_cpuusage_read(struct cpuacct *ca, int cpu,
> + enum cpuacct_usage_index index)
> {
> + struct cpuacct_usage *cpuusage = per_cpu_ptr(ca->cpuusage, cpu);
> + u64 data = 0;
> + int i = 0;
> +
> + /*
> + * We allow index == CPUACCT_USAGE_NRUSAGE here to read
> + * the sum of suages.
> + */
> + BUG_ON(index > CPUACCT_USAGE_NRUSAGE);
> +
> + if (index == CPUACCT_USAGE_NRUSAGE) {
> + raw_spin_lock_irq(&cpu_rq(cpu)->lock);
> + for (i = 0; i < CPUACCT_USAGE_NRUSAGE; i++)
> + data += cpuusage->usages[i];
> + raw_spin_unlock_irq(&cpu_rq(cpu)->lock);
Why do you unconditionally take the lock here? You really don't need it
on 64 bit.
> +
> + goto out;
> + }
>
> #ifndef CONFIG_64BIT
> /*
> * Take rq->lock to make 64-bit read safe on 32-bit platforms.
> */
> raw_spin_lock_irq(&cpu_rq(cpu)->lock);
> + data = cpuusage->usages[index];
> raw_spin_unlock_irq(&cpu_rq(cpu)->lock);
> #else
> + data = cpuusage->usages[index];
> #endif
>
> +out:
> return data;
> }
>
> +static void cpuacct_cpuusage_write(struct cpuacct *ca, int cpu,
> + enum cpuacct_usage_index index, u64 val)
> {
> + struct cpuacct_usage *cpuusage = per_cpu_ptr(ca->cpuusage, cpu);
> + int i = 0;
> +
> + /*
> + * We allow index == CPUACCT_USAGE_NRUSAGE here to write
> + * val to each index of usages.
> + */
> + BUG_ON(index > CPUACCT_USAGE_NRUSAGE);
> +
> + if (index == CPUACCT_USAGE_NRUSAGE) {
> + raw_spin_lock_irq(&cpu_rq(cpu)->lock);
> + for (i = 0; i < CPUACCT_USAGE_NRUSAGE; i++)
> + cpuusage->usages[i] = val;
> + raw_spin_unlock_irq(&cpu_rq(cpu)->lock);
> +
> + return;
> + }
Same for the above, and the below is dead code, you only ever call this
with NRUSAGE.
> #ifndef CONFIG_64BIT
> /*
> * Take rq->lock to make 64-bit write safe on 32-bit platforms.
> */
> raw_spin_lock_irq(&cpu_rq(cpu)->lock);
> + cpuusage->usages[index] = val;
> raw_spin_unlock_irq(&cpu_rq(cpu)->lock);
> #else
> + cpuusage->usages[index] = val;
> #endif
> }
>
> @@ -246,9 +344,15 @@ void cpuacct_charge(struct task_struct *tsk, u64 cputime)
>
> ca = task_ca(tsk);
>
> + user_time = user_mode(task_pt_regs(tsk));
> +
> while (true) {
> - u64 *cpuusage = per_cpu_ptr(ca->cpuusage, cpu);
> - *cpuusage += cputime;
> + struct cpuacct_usage *cpuusage = per_cpu_ptr(ca->cpuusage, cpu);
> +
> + if (user_time)
> + cpuusage->usages[CPUACCT_USAGE_USER] += cputime;
> + else
> + cpuusage->usages[CPUACCT_USAGE_SYSTEM] += cputime;
>
> ca = parent_ca(ca);
> if (!ca)
Have you tried to measure the performance impact of this?
Also, that code seems particularly silly for not using this_cpu_ptr().
After all, we only ever call this on current.
Also that ca iteration looks daft, should we fix that to read:
for (ca = task_ca(tsk); ca; ca = parent_ca(ca))
next prev parent reply other threads:[~2016-03-10 13:27 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-03-04 9:47 [PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability Zhao Lei
2016-03-04 9:47 ` [PATCH v2 1/2] " Zhao Lei
2016-03-11 17:42 ` Tejun Heo
2016-03-04 9:47 ` [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage Zhao Lei
2016-03-10 13:27 ` Peter Zijlstra [this message]
2016-03-16 10:39 ` Zhao Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20160310132728.GX6344@twins.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=cgroups@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tj@kernel.org \
--cc=yangds.fnst@cn.fujitsu.com \
--cc=zhaolei@cn.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®