mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0140/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:43 Baole Ni
  0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 10:43 UTC (permalink / raw)
  To: mchehab, maurochehab, mchehab, mchehab, m.chehab, mark.gross,
	dougthompson, bp
  Cc: linux-edac, linux-kernel, chuansheng.liu, baolex.ni, lee.jones

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/edac/e752x_edac.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/edac/e752x_edac.c b/drivers/edac/e752x_edac.c
index b2d7138..de1c459 100644
--- a/drivers/edac/e752x_edac.c
+++ b/drivers/edac/e752x_edac.c
@@ -1468,17 +1468,17 @@ MODULE_LICENSE("GPL");
 MODULE_AUTHOR("Linux Networx (http://lnxi.com) Tom Zimmerman\n");
 MODULE_DESCRIPTION("MC support for Intel e752x/3100 memory controllers");
 
-module_param(force_function_unhide, int, 0444);
+module_param(force_function_unhide, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(force_function_unhide, "if BIOS sets Dev0:Fun1 up as hidden:"
 		 " 1=force unhide and hope BIOS doesn't fight driver for "
 		"Dev0:Fun1 access");
 
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
 
-module_param(sysbus_parity, int, 0444);
+module_param(sysbus_parity, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(sysbus_parity, "0=disable system bus parity checking,"
 		" 1=enable system bus parity checking, default=auto-detect");
-module_param(report_non_memory_errors, int, 0644);
+module_param(report_non_memory_errors, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(report_non_memory_errors, "0=disable non-memory error "
 		"reporting, 1=enable non-memory error reporting");
-- 
2.9.2

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2016-08-02 12:17 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:43 [PATCH 0140/1285] Replace numeric parameter like 0444 with macro Baole Ni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®