* [PATCH 0147/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:44 Baole Ni
0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 10:44 UTC (permalink / raw)
To: mchehab, maurochehab, mchehab, mchehab, m.chehab, dougthompson, bp
Cc: linux-edac, linux-kernel, chuansheng.liu, baolex.ni, lee.jones
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/edac/i5000_edac.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/edac/i5000_edac.c b/drivers/edac/i5000_edac.c
index 72e07e3..f87698e 100644
--- a/drivers/edac/i5000_edac.c
+++ b/drivers/edac/i5000_edac.c
@@ -1587,8 +1587,8 @@ MODULE_AUTHOR
MODULE_DESCRIPTION("MC Driver for Intel I5000 memory controllers - "
I5000_REVISION);
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
-module_param(misc_messages, int, 0444);
+module_param(misc_messages, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(misc_messages, "Log miscellaneous non fatal messages");
--
2.9.2
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2016-08-02 11:24 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:44 [PATCH 0147/1285] Replace numeric parameter like 0444 with macro Baole Ni
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®