mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Baole Ni <baolex.ni@intel.com>
To: andrew.d.henroid@intel.com, davem@davemloft.net,
	linux@roeck-us.net, airlied@linux.ie, kgene@kernel.org,
	k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de
Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
	chuansheng.liu@intel.com, baolex.ni@intel.com,
	aduggan@synaptics.com, dianders@chromium.org
Subject: [PATCH 0250/1285] Replace numeric parameter like 0444 with macro
Date: Tue,  2 Aug 2016 18:53:15 +0800	[thread overview]
Message-ID: <20160802105315.30405-1-baolex.ni@intel.com> (raw)

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/idle/i7300_idle.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/idle/i7300_idle.c b/drivers/idle/i7300_idle.c
index ffeebc7..26d3e66 100644
--- a/drivers/idle/i7300_idle.c
+++ b/drivers/idle/i7300_idle.c
@@ -39,11 +39,11 @@
 #define MAX_STOP_RETRIES	10
 
 static int debug;
-module_param_named(debug, debug, uint, 0644);
+module_param_named(debug, debug, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(debug, "Enable debug printks in this driver");
 
 static int forceload;
-module_param_named(forceload, forceload, uint, 0644);
+module_param_named(forceload, forceload, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(debug, "Enable driver testing on unvalidated i5000");
 
 #define dprintk(fmt, arg...) \
@@ -58,7 +58,7 @@ MODULE_PARM_DESC(debug, "Enable driver testing on unvalidated i5000");
  */
 #define MAX_THROTTLE_LOW_LIMIT		168
 static uint throttle_low_limit = 1;
-module_param_named(throttle_low_limit, throttle_low_limit, uint, 0644);
+module_param_named(throttle_low_limit, throttle_low_limit, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(throttle_low_limit,
 		"Value for THRTLOWLM activation field "
 		"(0 = disable throttle, 1 = Max throttle, 168 = Min throttle)");
-- 
2.9.2

                 reply	other threads:[~2016-08-02 18:02 UTC|newest]

Thread overview: [no followups] expand[flat|nested]  mbox.gz  Atom feed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160802105315.30405-1-baolex.ni@intel.com \
    --to=baolex.ni@intel.com \
    --cc=aduggan@synaptics.com \
    --cc=airlied@linux.ie \
    --cc=andrew.d.henroid@intel.com \
    --cc=bp@alien8.de \
    --cc=chuansheng.liu@intel.com \
    --cc=davem@davemloft.net \
    --cc=dianders@chromium.org \
    --cc=dougthompson@xmission.com \
    --cc=k.kozlowski@samsung.com \
    --cc=kgene@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux@roeck-us.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®