mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0808/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 11:48 Baole Ni
  0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 11:48 UTC (permalink / raw)
  To: jdmason, dave.jiang, Allen.Hubbe, rjui, sbranden, m.chehab,
	pawel, m.szyprowski, kyungmin.park, k.kozlowski
  Cc: linux-ntb, linux-arm-kernel, bcm-kernel-feedback-list,
	linux-kernel, chuansheng.liu, baolex.ni

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/ntb/ntb_transport.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/ntb/ntb_transport.c b/drivers/ntb/ntb_transport.c
index 2ef9d91..222c5a1 100644
--- a/drivers/ntb/ntb_transport.c
+++ b/drivers/ntb/ntb_transport.c
@@ -73,23 +73,23 @@ MODULE_LICENSE("Dual BSD/GPL");
 MODULE_AUTHOR("Intel Corporation");
 
 static unsigned long max_mw_size;
-module_param(max_mw_size, ulong, 0644);
+module_param(max_mw_size, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(max_mw_size, "Limit size of large memory windows");
 
 static unsigned int transport_mtu = 0x10000;
-module_param(transport_mtu, uint, 0644);
+module_param(transport_mtu, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(transport_mtu, "Maximum size of NTB transport packets");
 
 static unsigned char max_num_clients;
-module_param(max_num_clients, byte, 0644);
+module_param(max_num_clients, byte, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(max_num_clients, "Maximum number of NTB transport clients");
 
 static unsigned int copy_bytes = 1024;
-module_param(copy_bytes, uint, 0644);
+module_param(copy_bytes, uint, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(copy_bytes, "Threshold under which NTB will use the CPU to copy instead of DMA");
 
 static bool use_dma;
-module_param(use_dma, bool, 0644);
+module_param(use_dma, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(use_dma, "Use DMA engine to perform large data copy");
 
 static struct dentry *nt_debugfs_dir;
-- 
2.9.2

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2016-08-02 12:27 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 11:48 [PATCH 0808/1285] Replace numeric parameter like 0444 with macro Baole Ni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®