From: Mikko Rapeli <mikko.rapeli@iki.fi>
To: Hauke Mehrtens <hauke@hauke-m.de>
Cc: davem@davemloft.net, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org, jarod@redhat.com, jogo@openwrt.org,
david.heidelberger@ixit.cz, maillist-linux@barfooze.de
Subject: Re: [PATCH 4/4] uapi/if_ether.h: prevent redefinition of struct ethhdr
Date: Mon, 13 Mar 2017 13:31:10 +0200 [thread overview]
Message-ID: <20170313113110.GC8672@lakka.kapsi.fi> (raw)
In-Reply-To: <20170312220039.16885-5-hauke@hauke-m.de>
On Sun, Mar 12, 2017 at 11:00:39PM +0100, Hauke Mehrtens wrote:
> From: David Heidelberger <david.heidelberger@ixit.cz>
>
> Musl provides its own ethhdr struct definition. Add a guard to prevent
> its definition of the appropriate musl header has already been included.
>
> Signed-off-by: John Spencer <maillist-linux@barfooze.de>
> Tested-by: David Heidelberger <david.heidelberger@ixit.cz>
> Signed-off-by: Jonas Gorski <jogo@openwrt.org>
Acked-by: Mikko Rapeli <mikko.rapeli@iki.fi>
> ---
> include/uapi/linux/if_ether.h | 3 +++
> include/uapi/linux/libc-compat.h | 11 +++++++++++
> 2 files changed, 14 insertions(+)
>
> diff --git a/include/uapi/linux/if_ether.h b/include/uapi/linux/if_ether.h
> index 5bc9bfd816b7..fb5ab8c1e753 100644
> --- a/include/uapi/linux/if_ether.h
> +++ b/include/uapi/linux/if_ether.h
> @@ -22,6 +22,7 @@
> #define _UAPI_LINUX_IF_ETHER_H
>
> #include <linux/types.h>
> +#include <linux/libc-compat.h>
>
> /*
> * IEEE 802.3 Ethernet magic constants. The frame sizes omit the preamble
> @@ -142,11 +143,13 @@
> * This is an Ethernet frame header.
> */
>
> +#if __UAPI_DEF_ETHHDR
> struct ethhdr {
> unsigned char h_dest[ETH_ALEN]; /* destination eth addr */
> unsigned char h_source[ETH_ALEN]; /* source ether addr */
> __be16 h_proto; /* packet type ID field */
> } __attribute__((packed));
> +#endif
>
>
> #endif /* _UAPI_LINUX_IF_ETHER_H */
> diff --git a/include/uapi/linux/libc-compat.h b/include/uapi/linux/libc-compat.h
> index ce2fa8a4ced6..c92d32f213d1 100644
> --- a/include/uapi/linux/libc-compat.h
> +++ b/include/uapi/linux/libc-compat.h
> @@ -87,6 +87,14 @@
>
> #endif /* _NET_IF_H */
>
> +/* musl defines the ethhdr struct itself in its netinet/if_ether.h.
> + * Glibc just includes the kernel header and uses a different guard. */
> +#if defined(_NETINET_IF_ETHER_H)
> +#define __UAPI_DEF_ETHHDR 0
> +#else
> +#define __UAPI_DEF_ETHHDR 1
> +#endif
> +
> /* Coordinate with glibc netinet/in.h header. */
> #if defined(_NETINET_IN_H)
>
> @@ -182,6 +190,9 @@
> /* For the future if glibc adds IFF_LOWER_UP, IFF_DORMANT and IFF_ECHO */
> #define __UAPI_DEF_IF_NET_DEVICE_FLAGS_LOWER_UP_DORMANT_ECHO 1
>
> +/* Definitions for if_ether.h */
> +#define __UAPI_DEF_ETHHDR 1
> +
> /* Definitions for in.h */
> #define __UAPI_DEF_IN_ADDR 1
> #define __UAPI_DEF_IN_IPPROTO 1
> --
> 2.11.0
>
next prev parent reply other threads:[~2017-03-13 11:31 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-12 22:00 [PATCH 0/4] uapi glibc compat: fix musl libc compatibility Hauke Mehrtens
2017-03-12 22:00 ` [PATCH 1/4] uapi glibc compat: add libc compat code when not build for kernel Hauke Mehrtens
2017-03-13 11:28 ` Mikko Rapeli
2017-03-12 22:00 ` [PATCH 2/4] uapi glibc compat: fix build if libc defines IFF_ECHO Hauke Mehrtens
2017-03-13 11:28 ` Mikko Rapeli
2017-03-12 22:00 ` [PATCH 3/4] uapi glibc compat: Do not check for __USE_MISC Hauke Mehrtens
2017-03-13 11:29 ` Mikko Rapeli
2017-03-16 7:59 ` David Woodhouse
2017-03-16 8:26 ` Mikko Rapeli
2017-03-17 18:17 ` Hauke Mehrtens
2017-03-12 22:00 ` [PATCH 4/4] uapi/if_ether.h: prevent redefinition of struct ethhdr Hauke Mehrtens
2017-03-13 11:31 ` Mikko Rapeli [this message]
2017-03-28 12:01 ` [PATCH 0/4] uapi glibc compat: fix musl libc compatibility Hauke Mehrtens
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170313113110.GC8672@lakka.kapsi.fi \
--to=mikko.rapeli@iki.fi \
--cc=davem@davemloft.net \
--cc=david.heidelberger@ixit.cz \
--cc=hauke@hauke-m.de \
--cc=jarod@redhat.com \
--cc=jogo@openwrt.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maillist-linux@barfooze.de \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®