From: Mel Gorman <mgorman@techsingularity.net>
To: Zi Yan <zi.yan@cs.rutgers.edu>
Cc: Anshuman Khandual <khandual@linux.vnet.ibm.com>,
n-horiguchi@ah.jp.nec.com, kirill.shutemov@linux.intel.com,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
akpm@linux-foundation.org, minchan@kernel.org, vbabka@suse.cz,
mhocko@kernel.org, dnellans@nvidia.com
Subject: Re: [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check()
Date: Fri, 19 May 2017 22:39:12 +0100 [thread overview]
Message-ID: <20170519213912.xm6zuucby3h6ne6r@techsingularity.net> (raw)
In-Reply-To: <61FCE04A-0227-4D5E-92E5-81EA06979FD3@cs.rutgers.edu>
On Fri, May 19, 2017 at 04:48:54PM -0400, Zi Yan wrote:
> On 19 May 2017, at 16:28, Mel Gorman wrote:
>
> > On Fri, May 19, 2017 at 12:37:38PM -0400, Zi Yan wrote:
> >>> As you say, there is no functional change but the helper name is vague
> >>> and gives no hint to what's it's checking for. It's somewhat tolerable as
> >>> it is as it's obvious what is being checked but the same is not true with
> >>> the helper name.
> >>>
> >>
> >> Does queue_pages_invert_nodemask_check() work? I can change the helper name
> >> in the next version.
> >>
> >
> > Not particularly, maybe queue_pages_required and invert the check with a
> > comment above it explaining what it's checking for would be ok.
> >
>
> queue_pages_required() is too broad,
I'm somewhat amused that you'd complain that "required" is too broad while
thinking "check" is somehow self-explanatory.
> I would take queue_pages_page_nid_check()
> and invert the check with a comment above saying
>
> /*
> * Check if the page's nid is in qp->nmask.
> *
> * If MPOL_MF_INVERT is set in qp->flags, check if the nid is
> * in the invert of qp->nmask.
> */
>
> Does it work?
>
I still don't like the name but I also am not interested in debating it
further for something so small. Add the comment, it's better than nothing.
--
Mel Gorman
SUSE Labs
next prev parent reply other threads:[~2017-05-19 21:39 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-20 20:47 [PATCH v5 00/11] mm: page migration enhancement for thp Zi Yan
2017-04-20 20:47 ` [PATCH v5 01/11] mm: x86: move _PAGE_SWP_SOFT_DIRTY from bit 7 to bit 1 Zi Yan
2017-05-19 13:07 ` Anshuman Khandual
2017-05-19 15:55 ` Dave Hansen
2017-05-19 16:31 ` Zi Yan
2017-05-19 16:36 ` Dave Hansen
2017-04-20 20:47 ` [PATCH v5 02/11] mm: mempolicy: add queue_pages_node_check() Zi Yan
2017-04-21 4:04 ` Anshuman Khandual
2017-05-19 13:13 ` Anshuman Khandual
2017-05-19 16:02 ` Mel Gorman
2017-05-19 16:37 ` Zi Yan
2017-05-19 20:28 ` Mel Gorman
2017-05-19 20:48 ` Zi Yan
2017-05-19 21:39 ` Mel Gorman [this message]
2017-04-20 20:47 ` [PATCH v5 03/11] mm: thp: introduce separate TTU flag for thp freezing Zi Yan
2017-04-21 4:29 ` Anshuman Khandual
2017-04-20 20:47 ` [PATCH v5 04/11] mm: thp: introduce CONFIG_ARCH_ENABLE_THP_MIGRATION Zi Yan
2017-04-21 4:36 ` Anshuman Khandual
2017-04-20 20:47 ` [PATCH v5 05/11] mm: thp: enable thp migration in generic path Zi Yan
2017-04-20 20:47 ` [PATCH v5 06/11] mm: thp: check pmd migration entry in common path Zi Yan
2017-04-21 6:17 ` Anshuman Khandual
2017-04-21 15:17 ` Zi Yan
2017-04-20 20:47 ` [PATCH v5 07/11] mm: soft-dirty: keep soft-dirty bits over thp migration Zi Yan
2017-04-20 20:47 ` [PATCH v5 08/11] mm: hwpoison: soft offline supports " Zi Yan
2017-04-21 8:10 ` Anshuman Khandual
2017-04-21 15:55 ` Zi Yan
2017-04-27 4:41 ` Naoya Horiguchi
2017-04-27 16:39 ` Zi Yan
2017-04-20 20:47 ` [PATCH v5 09/11] mm: mempolicy: mbind and migrate_pages support " Zi Yan
2017-04-21 8:22 ` Anshuman Khandual
2017-04-21 16:00 ` Zi Yan
2017-04-20 20:47 ` [PATCH v5 10/11] mm: migrate: move_pages() supports " Zi Yan
2017-04-20 20:47 ` [PATCH v5 11/11] mm: memory_hotplug: memory hotremove " Zi Yan
2017-05-19 13:56 ` Anshuman Khandual
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170519213912.xm6zuucby3h6ne6r@techsingularity.net \
--to=mgorman@techsingularity.net \
--cc=akpm@linux-foundation.org \
--cc=dnellans@nvidia.com \
--cc=khandual@linux.vnet.ibm.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@kernel.org \
--cc=minchan@kernel.org \
--cc=n-horiguchi@ah.jp.nec.com \
--cc=vbabka@suse.cz \
--cc=zi.yan@cs.rutgers.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®