From: Tejun Heo <tj@kernel.org>
To: Peter Zijlstra <peterz@infradead.org>
Cc: axboe@kernel.dk, linux-kernel@vger.kernel.org, oleg@redhat.com,
kernel-team@fb.com, osandov@fb.com
Subject: Re: [PATCH 2/6] blk-mq: replace timeout synchronization with a RCU and generation based scheme
Date: Tue, 12 Dec 2017 10:02:58 -0800 [thread overview]
Message-ID: <20171212180258.GH3919388@devbig577.frc2.facebook.com> (raw)
In-Reply-To: <20171212100935.dogysanf52mlwsau@hirez.programming.kicks-ass.net>
Hello, Peter.
On Tue, Dec 12, 2017 at 11:09:35AM +0100, Peter Zijlstra wrote:
> > + /*
> > + * ->aborted_gstate is used by the timeout to claim a specific
> > + * recycle instance of this request. See blk_mq_timeout_work().
> > + */
> > + struct u64_stats_sync aborted_gstate_sync;
> > + u64 aborted_gstate;
>
> So I dislike that u64_stats_sync thingy. Esp when used on a single
> variable like this.
Hmm... I see.
> There are two alternatives, but I don't understand the code well enough
> to judge the trade-offs.
>
> 1) use gstate_seq for this too; yes it will add some superfluous
> instructions on 64bit targets, but if timeouts are a slow path
> this might not matter.
For aborted_gstate, the heavier reader side is the completion hot
path. That's two rmbs, which in itself isn't too much but is still
difficult to justify.
> 2) use the pattern we use for cfs_rq::min_vruntime; namely:
>
> u64 aborted_gstate
> #ifdef CONFIG_64BIT
> u64 aborted_gstate_copy;
> #endif
>
>
> static inline void blk_mq_rq_set_abort(struct rq *rq, u64 gstate)
> {
> rq->aborted_gstate = gstate;
> #ifdef CONFIG_64BIT
> smp_wmb();
> rq->aborted_gstate_copy = gstate;
> #endif
> }
>
> static inline u64 blk_mq_rq_get_abort(struct rq *rq)
> {
> #ifdef CONFIG_64BIT
> u64 abort, copy;
>
> do {
> copy = rq->aborted_gstate_copy;
> smp_rmb();
> abort = rq->aborted_gstate;
> } while (abort != copy);
>
> return abort;
> #else
> return rq->aborted_gstate;
> #endif
> }
>
> which is actually _faster_ than the u64_stats_sync stuff (for a
> single variable).
Hmm... doing the seq reading on the variable content itself, so if we
had something like this as library, I'd be happy to use it but I
really don't want to open-code this.
> But it might not matter; I just dislike that thing, could be me.
I'll leave it as-is for now. Probably the right thing to do in the
longer term is adding the seq-reading-by-content-thing in the library.
Thanks.
--
tejun
next prev parent reply other threads:[~2017-12-12 18:03 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-12-09 19:25 [PATCHSET] blk-mq: reimplement timeout handling Tejun Heo
2017-12-09 19:25 ` [PATCH 1/6] blk-mq: protect completion path with RCU Tejun Heo
2017-12-13 3:10 ` jianchao.wang
2017-12-09 19:25 ` [PATCH 2/6] blk-mq: replace timeout synchronization with a RCU and generation based scheme Tejun Heo
2017-12-12 10:09 ` Peter Zijlstra
2017-12-12 18:02 ` Tejun Heo [this message]
2017-12-12 10:10 ` Peter Zijlstra
2017-12-12 18:03 ` Tejun Heo
2017-12-12 11:56 ` Peter Zijlstra
2017-12-12 18:04 ` Tejun Heo
2017-12-09 19:25 ` [PATCH 3/6] blk-mq: use blk_mq_rq_state() instead of testing REQ_ATOM_COMPLETE Tejun Heo
2017-12-09 19:25 ` [PATCH 4/6] blk-mq: make blk_abort_request() trigger timeout path Tejun Heo
2017-12-09 19:25 ` [PATCH 5/6] blk-mq: remove REQ_ATOM_COMPLETE usages from blk-mq Tejun Heo
2017-12-09 19:25 ` [PATCH 6/6] blk-mq: remove REQ_ATOM_STARTED Tejun Heo
2017-12-12 10:09 ` jianchao.wang
2017-12-12 17:01 ` Tejun Heo
2017-12-12 17:26 ` Tejun Heo
2017-12-13 3:05 ` jianchao.wang
2017-12-13 16:09 ` Tejun Heo
2017-12-14 2:14 ` jianchao.wang
2017-12-12 11:17 ` Nikolay Borisov
2017-12-12 17:29 ` Tejun Heo
2017-12-11 9:27 ` [PATCHSET] blk-mq: reimplement timeout handling Peter Zijlstra
2017-12-12 9:21 ` Christoph Hellwig
2017-12-12 16:39 ` Tejun Heo
2017-12-12 16:08 ` Peter Zijlstra
2017-12-12 19:01 [PATCHSET v2] " Tejun Heo
2017-12-12 19:01 ` [PATCH 2/6] blk-mq: replace timeout synchronization with a RCU and generation based scheme Tejun Heo
2017-12-12 21:37 ` Bart Van Assche
2017-12-12 21:44 ` tj
2017-12-13 5:07 ` jianchao.wang
2017-12-13 16:13 ` Tejun Heo
2017-12-14 18:51 ` Bart Van Assche
2017-12-14 19:19 ` tj
2017-12-14 21:13 ` Bart Van Assche
2017-12-15 13:30 ` tj
2017-12-14 20:20 ` Peter Zijlstra
2017-12-14 21:42 ` Bart Van Assche
2017-12-14 21:54 ` Peter Zijlstra
2017-12-15 2:12 ` jianchao.wang
2017-12-15 7:31 ` Peter Zijlstra
2017-12-15 15:14 ` jianchao.wang
2017-12-15 2:39 ` Mike Galbraith
2017-12-15 13:50 ` tj
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171212180258.GH3919388@devbig577.frc2.facebook.com \
--to=tj@kernel.org \
--cc=axboe@kernel.dk \
--cc=kernel-team@fb.com \
--cc=linux-kernel@vger.kernel.org \
--cc=oleg@redhat.com \
--cc=osandov@fb.com \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome