mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Valentin Vidic <Valentin.Vidic@CARNet.hr>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: "Simon Sandström" <simon@nikanor.nu>,
	"Marcin Ciupak" <marcin.s.ciupak@gmail.com>,
	"Marcus Wolf" <linux@wolf-entwicklungen.de>,
	devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org,
	"Valentin Vidic" <Valentin.Vidic@CARNet.hr>
Subject: [PATCH 6/8] staging: pi433: use defines for shifting register values
Date: Wed, 13 Dec 2017 15:21:54 +0100	[thread overview]
Message-ID: <20171213142156.3201-6-Valentin.Vidic@CARNet.hr> (raw)
In-Reply-To: <20171213142156.3201-1-Valentin.Vidic@CARNet.hr>

Avoid shifting by magic numbers and use defines instead:

  SHIFT_DATAMODUL_MODULATION_TYPE
  SHIFT_LNA_CURRENT_GAIN

Signed-off-by: Valentin Vidic <Valentin.Vidic@CARNet.hr>
---
 drivers/staging/pi433/rf69.c           | 4 ++--
 drivers/staging/pi433/rf69_registers.h | 2 ++
 2 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c
index b1e243e5bcac..8c4841c9d796 100644
--- a/drivers/staging/pi433/rf69.c
+++ b/drivers/staging/pi433/rf69.c
@@ -102,7 +102,7 @@ enum modulation rf69_get_modulation(struct spi_device *spi)
 
 	currentValue = rf69_read_reg(spi, REG_DATAMODUL);
 
-	switch ((currentValue & MASK_DATAMODUL_MODULATION_TYPE) >> 3) { // TODO improvement: change 3 to define
+	switch ((currentValue & MASK_DATAMODUL_MODULATION_TYPE) >> SHIFT_DATAMODUL_MODULATION_TYPE) {
 	case DATAMODUL_MODULATION_TYPE_OOK: return OOK;
 	case DATAMODUL_MODULATION_TYPE_FSK: return FSK;
 	default:			    return UNDEF;
@@ -340,7 +340,7 @@ enum lnaGain rf69_get_lna_gain(struct spi_device *spi)
 
 	currentValue = rf69_read_reg(spi, REG_LNA);
 
-	switch ((currentValue & MASK_LNA_CURRENT_GAIN) >> 3) { // improvement: change 3 to define
+	switch ((currentValue & MASK_LNA_CURRENT_GAIN) >> SHIFT_LNA_CURRENT_GAIN) {
 	case LNA_GAIN_AUTO:	    return automatic;
 	case LNA_GAIN_MAX:	    return max;
 	case LNA_GAIN_MAX_MINUS_6:  return maxMinus6;
diff --git a/drivers/staging/pi433/rf69_registers.h b/drivers/staging/pi433/rf69_registers.h
index 981b57d7cc0b..da12642cf249 100644
--- a/drivers/staging/pi433/rf69_registers.h
+++ b/drivers/staging/pi433/rf69_registers.h
@@ -124,6 +124,7 @@
 #define  MASK_DATAMODUL_MODE			0x06
 #define  MASK_DATAMODUL_MODULATION_TYPE		0x18
 #define  MASK_DATAMODUL_MODULATION_SHAPE	0x03
+#define  SHIFT_DATAMODUL_MODULATION_TYPE	3
 
 #define  DATAMODUL_MODE_PACKET			0x00 /* default */
 #define  DATAMODUL_MODE_CONTINUOUS		0x40
@@ -235,6 +236,7 @@
 #define  MASK_LNA_ZIN				0x80
 #define  MASK_LNA_CURRENT_GAIN			0x38
 #define  MASK_LNA_GAIN				0x07
+#define  SHIFT_LNA_CURRENT_GAIN			3
 
 #define  LNA_GAIN_AUTO				0x00 /* default */
 #define  LNA_GAIN_MAX				0x01
-- 
2.15.0

  parent reply	other threads:[~2017-12-13 15:07 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-12-13 14:21 [PATCH 1/8] staging: pi433: collapse else block after return statement Valentin Vidic
2017-12-13 14:21 ` [PATCH 2/8] staging: pi433: move var declaration to function level Valentin Vidic
2017-12-13 14:47   ` Dan Carpenter
2017-12-13 15:57     ` [PATCH 2/8 v2] " Valentin Vidic
2017-12-13 19:01   ` [PATCH 2/8] " Joe Perches
2017-12-13 19:46     ` [PATCH 2/8 v3] staging: pi433: cleanup local variable declaration Valentin Vidic
2017-12-13 14:21 ` [PATCH 3/8] staging: pi433: replace unsigned with unsigned int Valentin Vidic
2017-12-13 14:21 ` [PATCH 4/8] staging: pi433: add parentheses to mask and shift Valentin Vidic
2017-12-13 14:49   ` Dan Carpenter
2017-12-13 15:24   ` Marcus Wolf
2017-12-13 14:21 ` [PATCH 5/8] staging: pi433: fix DATAMODUL_MODULATION_TYPE_OOK value Valentin Vidic
2017-12-13 14:36   ` Dan Carpenter
2017-12-13 14:21 ` Valentin Vidic [this message]
2017-12-13 15:32   ` [PATCH 6/8] staging: pi433: use defines for shifting register values Marcus Wolf
2017-12-13 16:55     ` [PATCH 6/8 v2] " Valentin Vidic
2017-12-13 17:15       ` Marcus Wolf
2017-12-13 17:44         ` [PATCH 6/8 v3] " Valentin Vidic
2017-12-13 17:52           ` Marcus Wolf
2017-12-14 14:42           ` Dan Carpenter
2017-12-14 15:20             ` [PATCH 6/8 v4] staging: pi433: remove unused function Valentin Vidic
2017-12-14 16:08               ` rf69_get_lna_gain Marcus Wolf
2017-12-14 18:13                 ` rf69_get_lna_gain Simon Sandström
2017-12-19 14:12               ` [PATCH 6/8 v4] staging: pi433: remove unused function Greg Kroah-Hartman
2017-12-13 16:58     ` [PATCH 6/8] staging: pi433: use defines for shifting register values Valentin Vidic
2017-12-13 14:21 ` [PATCH 7/8] staging: pi433: avoid logging ENOMEM messages Valentin Vidic
2017-12-13 14:21 ` [PATCH 8/8] staging: pi433: replace printk calls with dev_dbg Valentin Vidic
2017-12-13 14:52   ` Dan Carpenter
2017-12-13 15:23     ` Valentin Vidic

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20171213142156.3201-6-Valentin.Vidic@CARNet.hr \
    --to=valentin.vidic@carnet.hr \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@wolf-entwicklungen.de \
    --cc=marcin.s.ciupak@gmail.com \
    --cc=simon@nikanor.nu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®