mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jessica Yu <jeyu@kernel.org>
To: rostedt@goodmis.org, Namit Gupta <gupta.namit@samsung.com>
Cc: mingo@redhat.com, linux-kernel@vger.kernel.org,
	pankaj.m@samsung.com, a.sahrawat@samsung.com
Subject: Re: [PATCH v3] ftrace/module: Move ftrace_release_mod() to ddebug_cleanup label
Date: Fri, 12 Jan 2018 18:32:27 +0100	[thread overview]
Message-ID: <20180112173224.junllgodqu3jgu42@redbean> (raw)
In-Reply-To: <1515388281-7941-1-git-send-email-gupta.namit@samsung.com>

+++ Namit Gupta [08/01/18 10:41 +0530]:
>ftrace_module_init happen after dynamic_debug_setup, it is desired that
>cleanup should be called after this label however in current implementation
>it is called in free module label,ie:even though ftrace in not initialized,
>from so many fail case ftrace_release_mod() will be called and unnecessary
>traverse the whole list.
>In below patch we moved ftrace_release_mod() from free_module label to
>ddebug_cleanup label. that is the best possible location, other solution
>is to make new label to ftrace_release_mod() but since ftrace_module_init()
>is not return with minimum changes it should be in ddebug_cleanup label.
>
>Signed-off-by: Namit Gupta <gupta.namit@samsung.com>

Hi Steven,

Could I get an ACK for this patch?

Thanks!

Jessica

  reply	other threads:[~2018-01-12 17:32 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20180108051623epcas5p1a2b9d68d83fd54937d71e3d726e36d38@epcas5p1.samsung.com>
2018-01-08  5:11 ` Namit Gupta
2018-01-12 17:32   ` Jessica Yu [this message]
2018-01-12 17:50     ` Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180112173224.junllgodqu3jgu42@redbean \
    --to=jeyu@kernel.org \
    --cc=a.sahrawat@samsung.com \
    --cc=gupta.namit@samsung.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=pankaj.m@samsung.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®