From: Marek Vasut <marek.vasut@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: Marek Vasut <marek.vasut+renesas@gmail.com>,
Geert Uytterhoeven <geert+renesas@glider.be>,
Lee Jones <lee.jones@linaro.org>, Mark Brown <broonie@kernel.org>,
Steve Twiss <stwiss.opensource@diasemi.com>,
Wolfram Sang <wsa+renesas@sang-engineering.com>,
linux-renesas-soc@vger.kernel.org
Subject: [PATCH v5 02/14] mfd: da9063: Replace mfd_add_devices with devm counterpart
Date: Wed, 6 Jun 2018 11:59:51 +0200 [thread overview]
Message-ID: <20180606100003.17067-2-marek.vasut+renesas@gmail.com> (raw)
In-Reply-To: <20180606100003.17067-1-marek.vasut+renesas@gmail.com>
Use devm_mfd_add_devices() instead of plain mfd_add_devices(), which
removes the need for da9063_device_exit() altogether and also for the
.remove callback in da9063-i2c.c .
Signed-off-by: Marek Vasut <marek.vasut+renesas@gmail.com>
Cc: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Lee Jones <lee.jones@linaro.org>
Cc: Mark Brown <broonie@kernel.org>
Cc: Steve Twiss <stwiss.opensource@diasemi.com>
Cc: Wolfram Sang <wsa+renesas@sang-engineering.com>
Cc: linux-renesas-soc@vger.kernel.org
---
V5: New patch
---
drivers/mfd/da9063-core.c | 11 +++--------
drivers/mfd/da9063-i2c.c | 10 ----------
include/linux/mfd/da9063/core.h | 2 --
3 files changed, 3 insertions(+), 20 deletions(-)
diff --git a/drivers/mfd/da9063-core.c b/drivers/mfd/da9063-core.c
index 2647bb371d86..76258e5709f8 100644
--- a/drivers/mfd/da9063-core.c
+++ b/drivers/mfd/da9063-core.c
@@ -226,20 +226,15 @@ int da9063_device_init(struct da9063 *da9063, unsigned int irq)
da9063->irq_base = regmap_irq_chip_get_base(da9063->regmap_irq);
- ret = mfd_add_devices(da9063->dev, -1, da9063_devs,
- ARRAY_SIZE(da9063_devs), NULL, da9063->irq_base,
- NULL);
+ ret = devm_mfd_add_devices(da9063->dev, -1, da9063_devs,
+ ARRAY_SIZE(da9063_devs), NULL,
+ da9063->irq_base, NULL);
if (ret)
dev_err(da9063->dev, "Cannot add MFD cells\n");
return ret;
}
-void da9063_device_exit(struct da9063 *da9063)
-{
- mfd_remove_devices(da9063->dev);
-}
-
MODULE_DESCRIPTION("PMIC driver for Dialog DA9063");
MODULE_AUTHOR("Krystian Garbaciak");
MODULE_AUTHOR("Michal Hajduk");
diff --git a/drivers/mfd/da9063-i2c.c b/drivers/mfd/da9063-i2c.c
index 981805a2c521..29456e807ed4 100644
--- a/drivers/mfd/da9063-i2c.c
+++ b/drivers/mfd/da9063-i2c.c
@@ -270,15 +270,6 @@ static int da9063_i2c_probe(struct i2c_client *i2c,
return da9063_device_init(da9063, i2c->irq);
}
-static int da9063_i2c_remove(struct i2c_client *i2c)
-{
- struct da9063 *da9063 = i2c_get_clientdata(i2c);
-
- da9063_device_exit(da9063);
-
- return 0;
-}
-
static const struct i2c_device_id da9063_i2c_id[] = {
{"da9063", PMIC_DA9063},
{},
@@ -291,7 +282,6 @@ static struct i2c_driver da9063_i2c_driver = {
.of_match_table = of_match_ptr(da9063_dt_ids),
},
.probe = da9063_i2c_probe,
- .remove = da9063_i2c_remove,
.id_table = da9063_i2c_id,
};
diff --git a/include/linux/mfd/da9063/core.h b/include/linux/mfd/da9063/core.h
index 9ab7049977aa..8e6684d884e0 100644
--- a/include/linux/mfd/da9063/core.h
+++ b/include/linux/mfd/da9063/core.h
@@ -94,6 +94,4 @@ struct da9063 {
int da9063_device_init(struct da9063 *da9063, unsigned int irq);
int da9063_irq_init(struct da9063 *da9063);
-void da9063_device_exit(struct da9063 *da9063);
-
#endif /* __MFD_DA9063_CORE_H__ */
--
2.16.2
next prev parent reply other threads:[~2018-06-06 10:03 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-06-06 9:59 [PATCH v5 01/14] mfd: da9063: Replace regmap_add_irq_chip " Marek Vasut
2018-06-06 9:59 ` Marek Vasut [this message]
2018-06-07 7:07 ` [PATCH v5 02/14] mfd: da9063: Replace mfd_add_devices " Lee Jones
2018-06-06 9:59 ` [PATCH v5 03/14] mfd: da9063: Use regmap_reg_range Marek Vasut
2018-06-06 11:33 ` Geert Uytterhoeven
2018-06-07 7:06 ` Lee Jones
2018-06-06 9:59 ` [PATCH v5 04/14] mfd: da9063: Use REGMAP_IRQ_REG Marek Vasut
2018-06-06 11:31 ` Geert Uytterhoeven
2018-06-06 16:06 ` Marek Vasut
2018-06-07 7:01 ` Lee Jones
2018-06-07 7:40 ` Geert Uytterhoeven
2018-06-07 7:05 ` Lee Jones
2018-06-06 9:59 ` [PATCH v5 05/14] mfd: da9063: Use PLATFORM_DEVID_NONE Marek Vasut
2018-06-06 9:59 ` [PATCH v5 06/14] mfd: da9063: Replace DA9063_NUM_IRQ with ARRAY_SIZE Marek Vasut
2018-06-06 9:59 ` [PATCH v5 07/14] mfd: da9063: Rename PMIC_DA9063 to PMIC_CHIP_ID_DA9063 Marek Vasut
2018-06-06 9:59 ` [PATCH v5 08/14] mfd: da9063: Replace model with type Marek Vasut
2018-06-11 14:45 ` kbuild test robot
2018-06-06 9:59 ` [PATCH v5 09/14] mfd: da9063: Add DA9063L type Marek Vasut
2018-06-06 9:59 ` [PATCH v5 10/14] mfd: da9063: Add custom regmap for DA9063L Marek Vasut
2018-06-06 10:00 ` [PATCH v5 11/14] mfd: da9063: Add custom IRQ map " Marek Vasut
2018-06-06 10:00 ` [PATCH v5 12/14] mfd: da9063: Register RTC only on DA9063L Marek Vasut
2018-06-06 10:00 ` [PATCH v5 13/14] regulator: da9063: Handle less LDOs " Marek Vasut
2018-06-06 10:00 ` [PATCH v5 14/14] mfd: da9063: Add DA9063L support Marek Vasut
2018-06-07 8:04 ` [PATCH v5 01/14] mfd: da9063: Replace regmap_add_irq_chip with devm counterpart Marek Vasut
2018-06-07 12:41 ` Lee Jones
2018-06-07 13:19 ` Marek Vasut
2018-06-08 6:37 ` Lee Jones
2018-06-08 8:50 ` Marek Vasut
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180606100003.17067-2-marek.vasut+renesas@gmail.com \
--to=marek.vasut@gmail.com \
--cc=broonie@kernel.org \
--cc=geert+renesas@glider.be \
--cc=lee.jones@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=stwiss.opensource@diasemi.com \
--cc=wsa+renesas@sang-engineering.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®