From: Manfred Spraul <manfred@colorfullife.com>
To: LKML <linux-kernel@vger.kernel.org>,
Davidlohr Bueso <dave@stgolabs.net>,
Dmitry Vyukov <dvyukov@google.com>
Cc: 1vier1@web.de, Andrew Morton <akpm@linux-foundation.org>,
Kees Cook <keescook@chromium.org>,
Manfred Spraul <manfred@colorfullife.com>
Subject: [PATCH 0/5] ipc: cleanups & bugfixes
Date: Thu, 5 Jul 2018 07:59:14 +0200 [thread overview]
Message-ID: <20180705055920.19611-1-manfred@colorfullife.com> (raw)
Hi,
Dmitry convinced me that I should properly review the initialization
of new ipc objects, and I found another issue.
The series corrects 3 issues with ipc_addid(), and also renames
two functions and corrects a wrong comment.
0001-ipc-reorganize-initialization-of-kern_ipc_perm.id:
Access kern_ipc_perm.id under the IPC spinlock.
My original idea of removing kern_ipc_perm entirely
is not possible, e.g. the proc interface needs the id.
0002-ipc-reorganize-initialization-of-kern_ipc_perm.seq:
Bugfix for the syzbot finding
0003-ipc-util.c-Use-ipc_rcu_putref-for-failues-in-ipc_add:
Bugfix from code review
0004-ipc-Rename-ipcctl_pre_down_nolock.patch:
Comment update & function rename from code review
0005-ipc-rename-ipc_lock-to-ipc_lock_idr:
Function rename from code review
0006-ipc-util.c-correct-comment-in-ipc_obtain_object_che
Comment correction from code review
The patches are lightly tested, especially I have not tested
the checkpoint/restore code or tested the failure cases.
--
Manfred
next reply other threads:[~2018-07-05 5:59 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-05 5:59 Manfred Spraul [this message]
2018-07-05 5:59 ` [PATCH 1/6] ipc: reorganize initialization of kern_ipc_perm.id Manfred Spraul
2018-07-05 5:59 ` [PATCH 2/6] ipc: reorganize initialization of kern_ipc_perm.seq Manfred Spraul
2018-07-05 8:36 ` Dmitry Vyukov
2018-07-05 15:12 ` Manfred Spraul
2018-07-05 16:08 ` Dmitry Vyukov
2018-07-05 21:56 ` Andrew Morton
2018-07-06 17:18 ` Davidlohr Bueso
2018-07-05 5:59 ` [PATCH 3/6] ipc/util.c: Use ipc_rcu_putref() for failues in ipc_addid() Manfred Spraul
2018-07-05 5:59 ` [PATCH 4/6] ipc: Rename ipcctl_pre_down_nolock() Manfred Spraul
2018-07-05 5:59 ` [PATCH 5/6] ipc: rename ipc_lock() to ipc_lock_idr() Manfred Spraul
2018-07-05 5:59 ` [PATCH 6/6] ipc/util.c: correct comment in ipc_obtain_object_check Manfred Spraul
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180705055920.19611-1-manfred@colorfullife.com \
--to=manfred@colorfullife.com \
--cc=1vier1@web.de \
--cc=akpm@linux-foundation.org \
--cc=dave@stgolabs.net \
--cc=dvyukov@google.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®