From: Peter Zijlstra <peterz@infradead.org>
To: Daniel Vetter <daniel.vetter@ffwll.ch>
Cc: LKML <linux-kernel@vger.kernel.org>,
DRI Development <dri-devel@lists.freedesktop.org>,
Intel Graphics Development <intel-gfx@lists.freedesktop.org>,
Daniel Vetter <daniel.vetter@intel.com>,
Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [PATCH 11/12] sched: use for_each_if in topology.h
Date: Mon, 9 Jul 2018 12:36:56 +0200 [thread overview]
Message-ID: <20180709103656.GH2476@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20180709083650.23549-11-daniel.vetter@ffwll.ch>
On Mon, Jul 09, 2018 at 10:36:49AM +0200, Daniel Vetter wrote:
> Avoids complaints from gcc about ambiguous else clauses.
Is that a new thing? I'm fairly sure I've never seen it do that,
> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: Peter Zijlstra <peterz@infradead.org>
> ---
> include/linux/topology.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/topology.h b/include/linux/topology.h
> index cb0775e1ee4b..4fba5a5b148d 100644
> --- a/include/linux/topology.h
> +++ b/include/linux/topology.h
> @@ -40,7 +40,7 @@
>
> #define for_each_node_with_cpus(node) \
> for_each_online_node(node) \
> - if (nr_cpus_node(node))
> + for_each_if (nr_cpus_node(node))
Not having gotten any of the other patches, I'm not really sure what
this does and such, but improve readability it does not :/
next prev parent reply other threads:[~2018-07-09 10:37 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-09 8:36 [PATCH 01/12] kernel.h: Add for_each_if() Daniel Vetter
2018-07-09 8:36 ` [PATCH 02/12] blk: use for_each_if Daniel Vetter
2018-07-11 16:40 ` Tejun Heo
2018-07-11 16:45 ` Tejun Heo
2018-07-11 18:30 ` Jens Axboe
2018-07-11 18:50 ` Daniel Vetter
2018-07-11 19:31 ` Jens Axboe
2018-07-11 20:06 ` Tejun Heo
2018-07-11 21:08 ` Daniel Vetter
2018-07-11 21:13 ` Jens Axboe
2018-07-12 6:41 ` Daniel Vetter
2018-07-12 6:45 ` Joe Perches
2018-07-12 13:54 ` Jens Axboe
2018-07-12 15:32 ` Joe Perches
2018-07-13 9:28 ` Vlastimil Babka
2018-07-09 8:36 ` [PATCH 03/12] cgroup: " Daniel Vetter
2018-07-11 16:46 ` Tejun Heo
2018-07-09 8:36 ` [PATCH 04/12] cpufreq: " Daniel Vetter
2018-07-09 9:28 ` Eric Engestrom
2018-07-09 16:11 ` [PATCH] " Daniel Vetter
2018-07-09 21:36 ` Rafael J. Wysocki
2018-07-09 8:36 ` [PATCH 05/12] dmar: Use for_each_If Daniel Vetter
2018-07-20 12:50 ` Joerg Roedel
2018-07-09 8:36 ` [PATCH 06/12] mm: use for_each_if Daniel Vetter
2018-07-09 18:00 ` Pavel Tatashin
2018-07-09 8:36 ` [PATCH 07/12] ide: " Daniel Vetter
2018-07-09 8:36 ` [PATCH 08/12] netdev: " Daniel Vetter
2018-07-09 8:36 ` [PATCH 09/12] nubus: " Daniel Vetter
2018-07-09 10:17 ` Finn Thain
2018-07-17 15:26 ` Geert Uytterhoeven
2018-07-09 8:36 ` [PATCH 10/12] pci: " Daniel Vetter
2018-07-09 22:48 ` Bjorn Helgaas
2018-07-09 8:36 ` [PATCH 11/12] sched: use for_each_if in topology.h Daniel Vetter
2018-07-09 10:36 ` Peter Zijlstra [this message]
2018-07-09 15:00 ` Daniel Vetter
2018-07-09 15:12 ` Peter Zijlstra
2018-07-09 15:52 ` Daniel Vetter
2018-07-09 16:03 ` Peter Zijlstra
2018-07-09 16:06 ` Daniel Vetter
2018-07-09 16:12 ` Mark Rutland
2018-07-09 17:55 ` [Intel-gfx] " Daniel Vetter
2018-07-11 16:51 ` Mark Rutland
2018-07-09 16:30 ` Peter Zijlstra
2018-07-09 8:36 ` [PATCH 12/12] usb: use for_each_if Daniel Vetter
2018-07-09 11:50 ` [PATCH 01/12] kernel.h: Add for_each_if() Andy Shevchenko
2018-07-09 16:25 ` [PATCH] " Daniel Vetter
2018-07-09 18:30 ` Andy Shevchenko
2018-07-09 23:30 ` Andrew Morton
2018-07-10 7:53 ` Daniel Vetter
2018-07-10 10:32 ` NeilBrown
2018-07-11 11:51 ` Daniel Vetter
2018-07-11 23:05 ` Andrew Morton
2018-07-12 6:39 ` Daniel Vetter
2018-07-13 23:37 ` NeilBrown
2018-07-13 23:42 ` Randy Dunlap
2018-07-16 8:11 ` Andy Shevchenko
2018-07-16 15:41 ` Randy Dunlap
2018-07-16 22:16 ` NeilBrown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180709103656.GH2476@hirez.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=akpm@linux-foundation.org \
--cc=daniel.vetter@ffwll.ch \
--cc=daniel.vetter@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome